Bug Hunting Session
Bug 91353 - Embedded Firebird – something wrong with the Table field type Date or displaying it
Summary: Embedded Firebird – something wrong with the Table field type Date or display...
Status: RESOLVED DUPLICATE of bug 91324
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
4.2.4.2 release
Hardware: Other All
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-05-18 10:12 UTC by Ulf
Modified: 2016-09-07 17:43 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
screen shot (27.57 KB, image/png)
2015-05-18 10:12 UTC, Ulf
Details
Sample Database (45.82 KB, application/vnd.oasis.opendocument.database)
2015-05-18 10:13 UTC, Ulf
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ulf 2015-05-18 10:12:23 UTC
Created attachment 115692 [details]
screen shot

It seems for me that the Month December "is forgotten", the January only have 28 Days or 29 in leap years like normally only February has.

Please take a look at the attached screen shot or the attached Database.

If you open the attached Database,
- go to tables
- open table "datum" by double-click
- manually change the first row "Datum" to 31.12.2014 where ID = 0
- leave the row
-> date switch to 31.01.2015

This goes back until 01.12.2014 switches to 01.01.2015. If you insert 30.11.2014 the displayed Date stays.

-  manually insert into "Datum" 29.01.2015
- leave the row
-> date switch to 01.02.2015
- insert into “Datum” 29.12.2014
- leave the row
-> date switch to 29.01.2015

Do it until 31.01.2015, the date always switch to the begin of February. After January seems to be OK. If you work with the date-function like DATEADD it is the same behavior of the date.

If I use the following SQL Statement in Tools/SQL...
UPDATE "datum"  SET "Datum" = '2014-12-31' WHERE "ID" = 0
and make a select
"Datum" from "datum" WHERE "ID" = 0 
the output returns 0114-11-31

I use Win 8.1 and attached the Base file
Comment 1 Ulf 2015-05-18 10:13:52 UTC
Created attachment 115693 [details]
Sample Database
Comment 2 Alex Thurgood 2015-05-19 16:11:15 UTC
Confirming on

Version: 4.4.3.2
Build ID: 88805f81e9fe61362df02b9941de8e38a9b5fd16
Locale : fr_

OSX 10.10.3

with test odb file supplied by reporter
Comment 3 Alex Thurgood 2015-05-19 16:15:25 UTC
Already present in 

Version: 4.3.5.2
Build ID: 3a87456aaa6a95c63eea1c1b3201acedf0751bd5
Comment 4 Alex Thurgood 2015-05-19 16:22:02 UTC
See the same problem in 

Version: 4.2.4.2
Build ID: 63150712c6d317d27ce2db16eb94c2f3d7b699f8

so it has probably been there since fbembed support was introduced
Comment 5 Tamas Bunth 2016-08-17 20:03:39 UTC
It is probably a duplicate of Bug 91324 and needs retesting.
It seems to me the issue is not present any more.

Version: 5.3.0.0.alpha0+
Build ID: bd28d789d0bfde255cfeef9422ddb816e3d57248
Comment 6 Lionel Elie Mamane 2016-09-07 17:43:43 UTC

*** This bug has been marked as a duplicate of bug 91324 ***