Bug Hunting Session
Bug 91386 - UI: Crash after visiting Sidebar Properties Character Spacing
Summary: UI: Crash after visiting Sidebar Properties Character Spacing
Status: RESOLVED DUPLICATE of bug 91382
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.0.0.alpha0+ Master
Hardware: x86-64 (AMD64) All
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks: VclPtr
  Show dependency treegraph
 
Reported: 2015-05-19 12:38 UTC by Gordo
Modified: 2015-05-19 20:19 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gordo 2015-05-19 12:38:54 UTC
1. New Text Document.
2. Open Sidebar -> Properties -> Character -> Character Spacing.
3. Exit application.
Result:
Program has stopped working.

Version: 5.0.0.0.alpha1+
Build ID: 60fb87cf6cfcbdb1a7ece00e8a2e9d1112903ed0
TinderBox: Win-x86@39, Branch:master, Time: 2015-05-18_14:12:34
Comment 1 Philippe Jung 2015-05-19 15:40:19 UTC
I don't have the same symptoms:

1
2
3 seems to behave correctly
3 Select a spacing, the combo box never closes
4 Click else where, the combo closes but selection is not taken into account
Comment 2 Julien Nabet 2015-05-19 19:50:37 UTC
On pc Debian x86-64 with master sources updated today, 5f653490a40850886f94c9fd6b381b4bed1de58a, I could reproduce this.
I noticed these on console:
warn:legacy.osl:32357:1:vcl/source/window/window.cxx:318: Window ( N3svx7sidebar17TextPropertyPanelE ()) with live SystemWindows destroyed:  25ImplListBoxFloatingWindow () N3svx7sidebar14PopupContainerE ()
Window ( N3svx7sidebar17TextPropertyPanelE ()) with live SystemWindows destroyed:  25ImplListBoxFloatingWindow () N3svx7sidebar14PopupContainerE ()
Comment 3 Michael Meeks 2015-05-19 20:19:02 UTC
Thanks for filing =)

*** This bug has been marked as a duplicate of bug 91382 ***