Bug Hunting Session
Bug 91414 - crash when open list of recent files
Summary: crash when open list of recent files
Status: RESOLVED DUPLICATE of bug 91404
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.0.0.0.alpha0+ Master
Hardware: Other Linux (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, regression
Depends on:
Blocks:
 
Reported: 2015-05-20 17:42 UTC by raal
Modified: 2015-12-17 09:10 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
backtrace (14.04 KB, text/x-log)
2015-05-20 17:42 UTC, raal
Details
bt with debug symbols (6.57 KB, text/plain)
2015-05-20 20:25 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description raal 2015-05-20 17:42:45 UTC
Created attachment 115754 [details]
backtrace

Version: 5.0.0.0.alpha1+
Build ID: 2a886adb500fe481e1ea61573551b19e99c55b8b
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2015-05-20_00:31:27

steps to reproduce:
open LO (for example Writer)
click on second icon Open to show list of recent files
click outside of the list
Crash
Comment 1 Julien Nabet 2015-05-20 20:25:27 UTC
Created attachment 115757 [details]
bt with debug symbols

On pc Debian x86-64 with master sources updated today + enable-dbgutil, I could reproduce this.
Comment 2 Julien Nabet 2015-05-20 20:32:27 UTC
No pb with LO Debian package 4.4.3 => confirming regression.

Tomaz: perhaps I'm wrong but, looking at git history of vcl/source/window/toolbox.cxx (because it appears in bt) I wonder if it could be a side effect of RenderContext work. Any thoughts?
Comment 3 Tomaz Vajngerl 2015-05-21 00:55:21 UTC
I can't reproduce this in my build - could it be the same problem as with tdf#91404 ?
Comment 4 Tomaz Vajngerl 2015-05-21 00:56:34 UTC
Ah -- looking at bt with debug symbols it looks as it is.

*** This bug has been marked as a duplicate of bug 91404 ***
Comment 5 Robinson Tryon (qubit) 2015-12-17 09:10:40 UTC
Migrating Whiteboard tags to Keywords: (bibisectRequest)
[NinjaEdit]