Download it now!
Bug 91429 - DrawingML import of triangles
Summary: DrawingML import of triangles
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.4.3.2 release
Hardware: Other All
: medium normal
Assignee: Andras Timar
URL:
Whiteboard: target:5.1.0 target:5.0.0.0.beta2
Keywords:
Depends on:
Blocks:
 
Reported: 2015-05-21 13:32 UTC by Andras Timar
Modified: 2016-10-25 19:24 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andras Timar 2015-05-21 13:32:17 UTC
Open https://bugs.documentfoundation.org/attachment.cgi?id=114460 in LibreOffice, save it, open it again, and notice that triangles are skewed. But this re-saved document looks OK in PowerPoint Viewer 2013, so it is rather an import problem.

Original triangle:
            <a:prstGeom prst="triangle">
              <a:avLst/>
            </a:prstGeom>

Exported triangle:
          <a:prstGeom prst="triangle">
            <a:avLst>
              <a:gd name="adj" fmla="val 50000"/>
            </a:avLst>
          </a:prstGeom>

So at first look it seems we have an unnecessary <a:gd name="adj" fmla="val 50000"/> adjustment value in export, but PowerPoint Viewer and LibreOffice 4.2 does not have a problem with it, so probably this value is good.
Comment 1 Luke 2015-05-22 20:22:48 UTC
I can confirm the triangles are skewed on roundtrip.
Comment 2 Luke 2015-05-23 06:57:36 UTC
Also can confirm that removing "<a:gd name="adj" fmla="val 50000"/>" in slide1.xml fixes the skewed rendering in Impress. 

Does this code add anything? If not, shouldn't the exporter be fixed to not include it?
Comment 3 Andras Timar 2015-05-23 09:56:10 UTC
Word is happy with the exported file, therefore the problem is in our importer. I think I found the problem and will push the fix shortly.
Comment 4 Commit Notification 2015-05-23 15:11:12 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=da0a44b415f630ce39617b8c8f0c366177a7705e

tdf#91429 do not convert ooxml preset shape modifier values

It will be available in 5.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2015-05-23 15:14:40 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=383b82ef8e2c36415cf1039885bef4d44db412ac&h=libreoffice-5-0

tdf#91429 do not convert ooxml preset shape modifier values

It will be available in 5.0.0.0.beta2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.