Bug 91435 - Writer styles dialog won't open
Summary: Writer styles dialog won't open
Status: RESOLVED DUPLICATE of bug 83546
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.3.2 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-05-21 16:45 UTC by digitect
Modified: 2015-08-14 16:29 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description digitect 2015-05-21 16:45:27 UTC
The styles dialog won't open by any method (toolbar button, F11, Format menu selection, toolbar dropdown style menu "More Styles..."). There is no method to edit or add styles!

This is a critical problem for anyone using styles.

Writer version 4.4.3.2, on Windows 8.1.
Comment 1 Julien Nabet 2015-05-21 19:48:48 UTC
For the test, could you rename your LO directory profile (see https://wiki.documentfoundation.org/UserProfile#Windows) and give a new try?
Comment 2 Gordo 2015-05-22 12:28:53 UTC
It looks like it might be hidden.  There should be a little widget with dots half way down the right side of the window.  Hovering over it should reveal a tooltip that says "Show".  Click on it.

With the Sidebar hidden, none of the methods described show the Sidebar again except Show/Hide and toggling View -> Sidebar.

Windows Vista 64
Version: 4.4.3.2
Build ID: 88805f81e9fe61362df02b9941de8e38a9b5fd16
Comment 3 digitect 2015-06-19 03:53:58 UTC
(In reply to Gordo from comment #2)
> It looks like it might be hidden.  There should be a little widget with dots
> half way down the right side of the window.  Hovering over it should reveal
> a tooltip that says "Show".  Click on it.
> 
> With the Sidebar hidden, none of the methods described show the Sidebar
> again except Show/Hide and toggling View -> Sidebar.
> 
> Windows Vista 64
> Version: 4.4.3.2
> Build ID: 88805f81e9fe61362df02b9941de8e38a9b5fd16

That was it. Not very intuitive coming from 4.4.3!

Thanks.
Comment 4 V Stuart Foote 2015-08-13 15:17:59 UTC
Works as designed, closing NAB
Comment 5 Maxim Monastirsky 2015-08-13 15:36:43 UTC
(In reply to V Stuart Foote from comment #4)
> Works as designed
Any link to where it was discussed (if at all)? For me if a user clicks on an UI element (the "More Styles..." item in the styles combobox), and gets no feedback from the software, it is a bug.
Comment 6 V Stuart Foote 2015-08-13 16:32:16 UTC
(In reply to Maxim Monastirsky from comment #5)
> Any link to where it was discussed (if at all)?...

Which aspect?

1) Widget the Show/Hide the Sidebar -- with so much packed into the Sidebar, ability to collapse and hide it rather than exit from it is a performance issue as well as reasonable UI. Came over to LO from AOO with that feature. You can ask Andre Fisher for specifics. Or Caolán when he did the port of the AOO commits.
 
2) Move the Styles and Formatting dialog into the Sidebar -- with Sidebar available by default at 4.2, move of Dialog panels into Sidebar content panels proceeded apace. And while Navigator went in (disabling its dialog) we pulled it back out. The F11 Styles and Formatting dialog went in and stayed.

See bug 73151

Specific behavior -- honor Sidebar State --
https://wiki.documentfoundation.org/Design/Meetings/2014-11-05

    + Should sidebar return to its previous state after keyboard
      shortcut is pressed (Cor / Jay)
        + https://bugs.freedesktop.org/show_bug.cgi?id=85791
        + For many users, they are used to pressing F11 to open it and
          F11 a second time to close it
        + would like it to hide by F11 (Kendy)
        + so should we do that for everything? (Jay)
            + like eg. gallery - when you click it when it is show, hide
              it again?
                + I'd like it (Kendy)
        + various corner cases - open sidebar, but all decks closed,etc.
            + we should try to return to the state it was (Jay)
            + depends on how easy is to do that - probably best to do
              the easiest first (Kendy)
AI      + Samuel can have a look, but not immediately 


> For me if a user clicks on
> an UI element (the "More Styles..." item in the styles combobox), and gets
> no feedback from the software, it is a bug.

The mouse over "Show" "Hide" isn't enough?   I'd rank this right there with "minimizing" a window in your DE of choice. "Hey, where'd my Window go?".

BZ is for bugs not user help.

@Samuel any comment.
Comment 7 Maxim Monastirsky 2015-08-13 19:08:01 UTC
(In reply to V Stuart Foote from comment #6)
> Which aspect?
> 
> 1) Widget the Show/Hide the Sidebar ...
> 2) Move the Styles and Formatting dialog into the Sidebar ...
None of them. What I'm saying is that a UI widget (in this case the "More Styles..." item), if present on screen, should do *something* (it doesn't matter right now what exactly). The same way you understand that when you click on a toolbar button or a menu item, it should do something, or it should be disabled (or hidden), and if not that's a bug.

(In reply to V Stuart Foote from comment #6)
> The mouse over "Show" "Hide" isn't enough?
As said above, my point is not about whether something is enough or not, but about the fact the we have a UI widget the does nothing when clicked.
Comment 8 V Stuart Foote 2015-08-13 19:16:43 UTC
(In reply to Maxim Monastirsky from comment #7)
> None of them. What I'm saying is that a UI widget (in this case the "More
> Styles..." item), if present on screen, should do *something* (it doesn't
> matter right now what exactly). The same way you understand that when you
> click on a toolbar button or a menu item, it should do something, or it
> should be disabled (or hidden), and if not that's a bug.
> 

> As said above, my point is not about whether something is enough or not, but
> about the fact the we have a UI widget the does nothing when clicked.

Nonsense-- it isn't that it "does nothing" rather, just as with the DE hiding a Window, you've hidden the Sidebar. Actions are still applied to it, and when you unhide it, there they are.

It needs to be "hideable" because that is its function.  Again back to the DE analogy--you hid the Window, you have to unhide it if you want to work with it.

And still as with a DE, you have a graphical handle showing it is hidden. No mystery, just the function of the GUI as implemented.
Comment 9 Maxim Monastirsky 2015-08-13 19:27:00 UTC
(In reply to V Stuart Foote from comment #8)
> Nonsense-- it isn't that it "does nothing" rather, just as with the DE
> hiding a Window, you've hidden the Sidebar.
Hmm.. Just to make sure we're talking about the same thing, try this:
1. Hide the sidebar using the Show/Hide splitter.
2. Open the styles combobox.
3. Click on the "More Styles..." item.

What exactly did the last step?
Comment 10 V Stuart Foote 2015-08-13 19:47:28 UTC
(In reply to Maxim Monastirsky from comment #9)
> (In reply to V Stuart Foote from comment #8)
> > Nonsense-- it isn't that it "does nothing" rather, just as with the DE
> > hiding a Window, you've hidden the Sidebar.
> Hmm.. Just to make sure we're talking about the same thing, try this:
> 1. Hide the sidebar using the Show/Hide splitter.
> 2. Open the styles combobox.
> 3. Click on the "More Styles..." item.
> 
> What exactly did the last step?

Functions as expected.

It changes the Sidebar deck from whatever it had been at close (default of course is Properties) to the Styles and Formatting deck. And when you unhide the Sidebar using the Show/Hide handle it shows Styles and Formatting.

In other words the Show/Hide action of the Sidebar widget is isolated from the change in active deck.
Comment 11 Maxim Monastirsky 2015-08-13 20:02:21 UTC
(In reply to V Stuart Foote from comment #10)
> It changes the Sidebar deck from whatever it had been at close (default of
> course is Properties) to the Styles and Formatting deck. And when you unhide
> the Sidebar using the Show/Hide handle it shows Styles and Formatting.
And this is (at least) a bad UX, because there is no *visible* effect from this clicking. I can imagine a casual user (that didn't read this thread, and not aware of this behind-the-scenes happening) clicking over and over again, and thinking that it does nothing.

Let's hear Jay's opinion on that.
Comment 12 Yousuf Philips (jay) (retired) 2015-08-14 16:07:27 UTC
This looks exactly like bug 83546.
Comment 13 V Stuart Foote 2015-08-14 16:29:08 UTC
OK, over to duplicate of enhancement of bug 83546

IMHO the Show/Hide currently is adequate indication to the user.

*** This bug has been marked as a duplicate of bug 83546 ***