Bug 91584 - Navigationbar in forms show different (both wrong) values, if it's a formcontrol or a toolbar
Summary: Navigationbar in forms show different (both wrong) values, if it's a formcont...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-05-24 18:21 UTC by Robert Großkopf
Modified: 2016-09-22 19:29 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Description with screenshots - different (wrong) rowcount-values (34.09 KB, application/pdf)
2015-05-24 18:21 UTC, Robert Großkopf
Details
Database with one form - try to change any value in second or third row an move to another field ... (12.62 KB, application/vnd.oasis.opendocument.database)
2015-05-24 18:24 UTC, Robert Großkopf
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Großkopf 2015-05-24 18:21:12 UTC
Created attachment 115988 [details]
Description with screenshots - different (wrong) rowcount-values

Open the attached *.pdf-description. It shows the whole problem.

The example shows a form with row 3 of a table. Changing one value in one formcontrol and switching to another resets the value of rowcount to '1' in the toolbar-navigationbar (Bug82591). At the same time the value of rowcount is switched to '0' in the formcontrol-navigationbar.

If you read out oForm.getRow() it will give the value '0' - the same wron value as you see in the formcontrol-navigationbar.

Seems to be inherited from OOo as Bug82591.
Comment 1 Robert Großkopf 2015-05-24 18:24:40 UTC
Created attachment 115990 [details]
Database with one form - try to change any value in second or third row an move to another field ...

This is the database, which shows the buggy behavior on OpenSUSE 13.2 64bit rpm Linux with all LO-versions here.
You could ignore the macros - it's only for trying to get a workaround for this buggy behavior ...
Comment 2 Alex Thurgood 2015-05-29 13:27:20 UTC
Confirming on

Version: 5.1.0.0.alpha1+
Build ID: 8cbb94a2b79dcaf9675125da800b64a85bae52dc
Locale : fr-FR (fr.UTF-8)

OSX 10.10.3
Comment 3 Alex Thurgood 2015-05-29 13:31:36 UTC
DUP of bug 82591 ?
Comment 4 Robert Großkopf 2015-05-29 14:50:27 UTC
(In reply to Alex Thurgood from comment #3)
> DUP of bug 82591 ?

No. This bug is about the different values. The formcontrol-navigationbar shows the row you could also get by a macro. The navigationbar of the toolbar shows '1' instead of '0'.

Bug82591 is about the wrong value, which should be the value of the shown row (row 3 for the third row), not '0' or '1' when changing a value in one field and click in another.

Both navigationbars should never show different rows, if cursor is in a field of the same form.
Comment 5 Julien Nabet 2015-05-29 23:32:13 UTC
I tried to play with forms/source/solar/control/navtoolbar.cxx
forms/source/helper/formnavigation.cxx
and forms/source/runtime/formoperations.cxx
but I'm stuck.
Sorry, I can't help here.
Comment 6 Lionel Elie Mamane 2015-05-30 15:51:44 UTC
It is probably fixed by the same commit as bug 82591.
Comment 7 QA Administrators 2016-09-20 09:45:51 UTC Comment hidden (obsolete)
Comment 8 Robert Großkopf 2016-09-22 19:29:00 UTC
Have tested again. It is fixed by the same commit as bug 82591 since LO 5.0. See comment 6.