Bug Hunting Session
Bug 91588 - UI: Drawing toolbar doesn't show Select button by default
Summary: UI: Drawing toolbar doesn't show Select button by default
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.0.0.0.beta1
Hardware: All All
: medium minor
Assignee: Yousuf Philips (jay) (retired)
URL:
Whiteboard: target:5.1.0 target:5.0.1
Keywords:
Depends on:
Blocks:
 
Reported: 2015-05-24 18:57 UTC by Juanjo
Modified: 2016-10-25 19:24 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Juanjo 2015-05-24 18:57:27 UTC
Just after installing LO, Impress' Drawing toolbar doesn't show which is, in my view, the most important button: Select
It can be fixed right away by customizing this toolbar
Comment 1 Juanjo 2015-05-24 19:01:19 UTC
I mean DRAW component, not IMPRESS. Sorry!
Comment 2 Yousuf Philips (jay) (retired) 2015-06-08 11:32:32 UTC
Hi Juanjo,

Yes the select button has been hidden by default in 5.0 as its behaviour isnt something that cant be achieved by a simple mouse click on the page or an object or pressing the escape key. As the behaviour of inserting shapes only permits inserting a single shape at a time, after inserting a shape, select mode is always reverted back to once the shape has been drawn.

If you disagree with this, please do let me know of a scenario in which it is crucial to have access to the select button.
Comment 3 Juanjo 2015-06-08 20:23:03 UTC
Hi Yousuf,

You are right. Maybe it was a situation I came across that I can't reproduce or maybe that eventual "defect" has gone in the latest LODev nightly build I'm using right now.

Anyway, you can forget about this "bug"
Comment 4 Thomas Krumbein 2015-06-16 09:02:01 UTC
I guess, the select button should be visible by default!

The nessessary scenario is very easy:

create a drawing using some tools - i.e. text and squares.

so: 
- select square-tool and create one or two squares 
- select text-tool and create one or two text entries
- now you want move one of the squares but text-tool is still activ. you cannot deselect it - so with every click inside the document a new textfield will be created. This is not a good workflow!

If the select tool is visible, it is possible to deselect the text-tool and select the square direct. 
All grafic programms has a visible select tool in first place (i.e. adobe illustrator, draw, corel draw etc) - so this should even be visible in LO draw by default.
Comment 5 Yousuf Philips (jay) (retired) 2015-06-17 12:14:44 UTC
(In reply to Thomas Krumbein from comment #4)
> so: 
> - select square-tool and create one or two squares 
> - select text-tool and create one or two text entries
> - now you want move one of the squares but text-tool is still activ. you
> cannot deselect it - so with every click inside the document a new textfield
> will be created. This is not a good workflow!

Text tool is not a constantly active control. Once you draw a textbox and type something in it, you cant automatically draw a second one without pressing the text tool again. It is always possible to select a square once you've finished creating a textbox. If i have misunderstood what you have meant, please submit a screencast, so that its easier to understand.

> If the select tool is visible, it is possible to deselect the text-tool and
> select the square direct. 

If the text tool is active, pressing escape deactivates it. If a user doesnt know about the escape key, by using any app in LO, they would know that if you dont type anything in a textbox, the textbox disappears. So if the text tool was active and i didnt want to use it, clicking once would show a cursor line in a textbox and clicking a second time would return to select mode.

> All grafic programms has a visible select tool in first place (i.e. adobe
> illustrator, draw, corel draw etc) - so this should even be visible in LO
> draw by default.

Yes you are correct that other graphic apps have the select tool visible, but LO Draw acts quite different then other graphic apps. In other apps, if you click on a tool, that tool is always active until you click off of it, but with LO Draw, once you click a tool and draw, the tool is then deactivated and it returns to select mode. So if it is always on select mode unless you want to draw something and then returns to select mode after drawing it, there isnt much use of a select tool button.

What do other ux-advise members think of this?
Comment 6 Maxim Monastirsky 2015-06-17 12:58:06 UTC
(In reply to Yousuf (Jay) Philips from comment #5)
> but with LO Draw, once you click a tool and draw, the tool is then
> deactivated and it returns to select mode.
At least the zoom mode button doesn't work that way.
Comment 7 pierre-yves samyn 2015-07-18 06:19:15 UTC
Hi

I change component from DRAW to UI because select button has been hidden by default in other modules too.

Not useful in DRAW but in other modules this tools is necessary to select more than one object by dragging a selection frame around the objects.

I know of course that we can add to the selection by taking the objects one by one but when there is much the selection box is a must

Regards
Comment 8 Yousuf Philips (jay) (retired) 2015-08-02 17:40:57 UTC
I had re-enabled select in impress and draw and thought i re-enabled it in writer and excel, where it really is needs to be able to drag select, but for some strange reason it seems to have slipped past the commits i had made, so it has been done.

https://gerrit.libreoffice.org/17475
Comment 9 Commit Notification 2015-08-04 09:13:18 UTC
Yousuf Philips committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=6860400666683d9e42b8de89bc189721527956e3

tdf#91588 re-enable select button in draw toolbar in sw & sc

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2015-08-04 09:17:46 UTC
Yousuf Philips committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=60d61d5a8e2afaee5745a879170d4f3b47f49f64&h=libreoffice-5-0

tdf#91588 re-enable select button in draw toolbar in sw & sc

It will be available in 5.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.