Bug 91611 - FILEOPEN Web Layout DOCX: General error. Input/Output error
Summary: FILEOPEN Web Layout DOCX: General error. Input/Output error
Status: RESOLVED DUPLICATE of bug 96749
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.0.0.beta1
Hardware: Other All
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Writer-Web-Layout
  Show dependency treegraph
 
Reported: 2015-05-25 12:01 UTC by Ivan
Modified: 2016-10-17 22:38 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
The specific docx file mentioned (112.60 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2015-05-25 12:01 UTC, Ivan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ivan 2015-05-25 12:01:51 UTC
Created attachment 116014 [details]
The specific docx file mentioned

hi2all

Problem description: 

LibreOffice writer gives the message 'General error. General input/output error.' when opening this docx file.

Steps to reproduce:
1. download 2427.docx
2. open with libreoffice writer
3. observe descriptive error message

Current behavior:

doesn't open document

http://joxi.ru/Y2Lp9ypSoLxQ26
Comment 1 Michael 2015-05-25 12:15:09 UTC
Confirmed with Fedora 21 x64, present in 5.1.0.0.alpha1+

It's a regression, bibisected with bibisect-43only:

$ git bisect log
# bad: [a92705c1fabafddd43d175a0714855cd22551232] source-hash-c15927f20d4727c3b8de68497b6949e72f9e6e9e
# good: [6ab7f53af36f13bbefdd4e4fcbd3d1ea432a77d9] source-hash-22029c7e17b4cb48acb058d47ec9c3b6b8b6b294
git bisect start 'latest' 'oldest'
# good: [bebf9d31c8fe9de96798484288a0fffc4d54917d] source-hash-09e5de8278dd8f13adcf614db35c8a8a04ba8e47
git bisect good bebf9d31c8fe9de96798484288a0fffc4d54917d
# bad: [fac643700ecfabc737836bbed068776f34037d53] source-hash-40a61d93ade494fa98c23a9fd8776c8dadf8f30f
git bisect bad fac643700ecfabc737836bbed068776f34037d53
# good: [d97d068402198fd528087c954ff8bf7fc2380a77] source-hash-3d1b1eea83703919c43620f9adef05e5b24c4bed
git bisect good d97d068402198fd528087c954ff8bf7fc2380a77
# bad: [4bf5bbc5af411318f6507cbd13c220069da40347] source-hash-e9509e54b45fc429a93975917dca2ec343e5f48d
git bisect bad 4bf5bbc5af411318f6507cbd13c220069da40347
# skip: [3b5a7843bab0f8e2c3e2c073600c40c345882368] source-hash-c7363cb6d1d31f2a7d40a76e62b5934629a1a8a1
git bisect skip 3b5a7843bab0f8e2c3e2c073600c40c345882368
# bad: [3c1ab23558692285230ec53d78a1224f9a5cbd13] source-hash-722c82b018327c1f9578ddc533ebbb06080848eb
git bisect bad 3c1ab23558692285230ec53d78a1224f9a5cbd13
# good: [7080d6b380e45b67417ffba4b6cf41a6e6cb07ed] source-hash-1b922da415339726fb0186246dba6a03429b33bf
git bisect good 7080d6b380e45b67417ffba4b6cf41a6e6cb07ed
# skip: [e0c7dd2f57dfb2146b8fad25fa8403f7f33cef76] source-hash-a79afdaa11a1af26c9404441dcf27ef197e972b2
git bisect skip e0c7dd2f57dfb2146b8fad25fa8403f7f33cef76
# bad: [fdaec684ef591b54e0ae9ae41cb71b37d021bb19] source-hash-b7c3e851465638d4416ca8837937946353561088
git bisect bad fdaec684ef591b54e0ae9ae41cb71b37d021bb19
# bad: [e43a5b9b55d10db223b55ee7c76e2f84e30e5c83] source-hash-5b4b6b2aad548cdc27ba2aa7d87ff584ec7e97dd
git bisect bad e43a5b9b55d10db223b55ee7c76e2f84e30e5c83
# first bad commit: [e43a5b9b55d10db223b55ee7c76e2f84e30e5c83] source-hash-5b4b6b2aad548cdc27ba2aa7d87ff584ec7e97dd
Comment 2 Andras Timar 2015-06-27 08:33:10 UTC
warn:writerfilter:28620:1:writerfilter/source/filter/WriterFilter.cxx:214: WriterFilter::filter(): failed with exception Element does not exist and cannot be created: "header1.xml"
Comment 3 Andras Timar 2015-06-27 10:06:22 UTC
 23b65a84fd827555dfb84c7e2f78879c479c2f78 is the first bad commit
commit 23b65a84fd827555dfb84c7e2f78879c479c2f78
Author: sushil_shinde <sushil.shinde@synerzip.com>
Date:   Wed Mar 19 18:34:45 2014 +0530

    fdo#76356 : Docx file contianing chart in footer/header gets corrupted.
    
        -  Docx file with chart in footer/header or .bin file referred in chart
           was getting corrupted.
        -  Embedded file for footer.xml was not grabbaged.
        -  .bin embedded files were not grab baged.
        -  Added grab bag support for both case.
        -  Added UT to check .bin files are grab baged properly.
    
    Reviewed on:
    	https://gerrit.libreoffice.org/8674
    
    Change-Id: I221e3867798fc2a3a42f6385d687e80b80a3678f
Comment 4 Timur 2015-09-07 12:03:07 UTC
Docx file is set to open in Web Layout in MS Office and can't be changed to Print Layout at all. 
It opens (as Portrait) in Print Layout in LO 4.2 which is obviously wrong, but it can be changed to Landscape.
Comment 5 Robinson Tryon (qubit) 2015-12-13 11:13:04 UTC Comment hidden (obsolete)
Comment 6 Julien Nabet 2015-12-28 20:33:22 UTC
Sorry, I put this one as dup because I saw the other first and submitted a patch to review.
See https://gerrit.libreoffice.org/#/c/20993/1

*** This bug has been marked as a duplicate of bug 96749 ***