Bug 91645 - Menu title turns white when clicked on
Summary: Menu title turns white when clicked on
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.0.0.0.beta1
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:5.1.0 target:5.0.0.0.beta4
Keywords: regression
Depends on:
Blocks:
 
Reported: 2015-05-26 19:04 UTC by Mikeyy - L10n HR
Modified: 2016-10-25 19:24 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Comparison (27.65 KB, image/png)
2015-05-26 19:04 UTC, Mikeyy - L10n HR
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mikeyy - L10n HR 2015-05-26 19:04:10 UTC
Created attachment 116058 [details]
Comparison

Windows 7 64bit, LO 5.0 beta 1
Picture shows all.

Text color was changed to white which is not visible when clicked.
Comment 1 Michael Meeks 2015-05-28 11:44:30 UTC
Looks like a duplicate - I think the text color is not initialized on the RenderContext. Thank for reporting !

*** This bug has been marked as a duplicate of bug 91484 ***
Comment 2 Michael Meeks 2015-05-28 13:23:36 UTC
Not a duplicate in fact - that other bug is way odder =)
Comment 3 Michael Meeks 2015-05-28 13:25:55 UTC
Tamaz - quick review of https://gerrit.libreoffice.org/15947 appreciated; hopefully by initializing the text color we get the right result - if not; little harm done (I hope) =)
Comment 4 Tomaz Vajngerl 2015-05-29 08:18:26 UTC
Michael: can you please first check if [1] fixes it? 

[1]: http://cgit.freedesktop.org/libreoffice/core/commit/?id=9ce71b67f705ccbc6df327d1bb181ca20b3ed17f
Comment 5 Michael Meeks 2015-06-08 09:25:48 UTC
Nope - not fixed.
Comment 6 László Németh 2015-06-09 13:06:23 UTC
It seems, this is a duplicate of Bug 91462, that is just fixed in the master.

*** This bug has been marked as a duplicate of bug 91462 ***
Comment 7 László Németh 2015-06-09 15:42:09 UTC
Reopened, because the first fix for the possible duplicate was replaced by a simpler patch, but likely that won't fix this one.
Comment 8 László Németh 2015-06-10 00:05:12 UTC
It seems, this is not a RenderContext problem: changing the "Selected Items" Font color in Control Center->Personalization->Window color is a workaround for the bug (also changing the default heme).

On Windows 8.1, the selected title text is visible, bit its white color is a little bit light on the light blue background.
Comment 9 László Németh 2015-06-10 09:30:21 UTC
Removed from RenderContext metabug.

The background of the bug is the changed Windows base color for the selected menu title text, and this resulted the invisible menus on Windows 7, but not on Windows 8.1.
Comment 10 Commit Notification 2015-06-10 21:54:57 UTC
László Németh committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c8344322a7af75b84dd3ca8f78b05543a976dfd5

tdf#91645 don't change selected menu title text color in Aero theme

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2015-06-10 22:19:25 UTC
László Németh committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=6758a1b16461bea4fe787aa8634fbd602f51d474&h=libreoffice-5-0

tdf#91645 don't change selected menu title text color in Aero theme

It will be available in 5.0.0.0.beta4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.