Download it now!
Bug 91654 - FILEOPEN: XLSX - Conditional Formatting rules not compatible with Excel's
Summary: FILEOPEN: XLSX - Conditional Formatting rules not compatible with Excel's
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.0.0.0.alpha0+ Master
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Conditional-Formatting
  Show dependency treegraph
 
Reported: 2015-05-26 23:00 UTC by Yousuf Philips (jay) (retired)
Modified: 2018-06-16 01:46 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
excel conditional formatting manager (31.61 KB, image/png)
2015-11-05 21:21 UTC, Yousuf Philips (jay) (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2015-05-26 23:00:30 UTC
The green data bar lines mentioned in bug 90511 didnt get fixed with the patches Markus submitted and i believe this to be due to the order of the rules in LO is different from how it is in Excel.

Excel
------
C5:E30
F5:F30
F5:F29
C4:E30

LO
------
C4:E30
C5:E30
F5:F29
F5:F30

This maybe caused by the fact that C5:E30 and F5:F30 have multiple rules with the same range which appear above and below C4:E30 and F5:F29 with Excels rules list, while in LO they are all grouped under one entry in the manage conditional formatting dialog. I assumed this is the case, as deleting F5:F29 in LO fixes the problem.
Comment 1 Buovjaga 2015-06-08 13:28:04 UTC
(In reply to Yousuf (Jay) Philips from comment #0)
> LO
> ------
> C4:E30
> C5:E30
> F5:F29
> F5:F30

Confirming I see this in Format - Conditional Formatting - Manage.

In comment 12 of bug 90511 Darshan commented about the effect of this:
"Note the color of the Data Bar is set to "Orange" in Excel but shows Green in Calc." 

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: be8512f99bc9ab18e55aabe01cc0ab1e6baea9e6
TinderBox: Win-x86@39, Branch:master, Time: 2015-06-08_05:58:40
Locale: fi-FI (fi_FI)
Comment 2 Yousuf Philips (jay) (retired) 2015-11-05 21:21:10 UTC
Created attachment 120311 [details]
excel conditional formatting manager

Just to further clarify what i meant in the description, here is the full list

Excel
------
C5:E30  Color Scale  Light Orange to Orange
F5:F30  Data Bar     Orange
F5:F30  Data Bar     Brown
F5:F29  Data Bar     Green
C4:E30  Color Scale  Orange to Yellow
C5:E30  Color Scale  Light Orange to Orange
C5:E30  Color Scale  Yellow to Orange
F5:F30  Data Bar     Orange
F5:F30  Data Bar     Light Orange
F5:F30  Data Bar     Blue
Comment 3 Markus Mohrhard 2016-01-26 19:13:33 UTC
As might have been obvious from my comment in the other bug report this is a WONTFIX.
Comment 4 Buovjaga 2016-01-27 09:38:40 UTC
Must have missed it, closing.
Comment 5 Luke 2016-01-29 04:43:59 UTC
Markus, 
If I understand this correctly, Calc's evaluation rules differ from Excel's. Why can't this be left open as an enhancement? Is there a reason we couldn't implement both models like we do with the formula syntax(Calc A1 vs Excel A1)?