Bug 91670 - LO fails to repaint window behind some dialogs
Summary: LO fails to repaint window behind some dialogs
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: RenderContext
  Show dependency treegraph
 
Reported: 2015-05-27 17:00 UTC by Terrence Enger
Modified: 2015-06-02 13:08 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
other stuff hiding Start Center (186.71 KB, image/pjpeg)
2015-05-27 17:00 UTC, Terrence Enger
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Terrence Enger 2015-05-27 17:00:17 UTC
Created attachment 116077 [details]
other stuff hiding Start Center

This problem seems to have come into LibreOffice between
    Version: 5.1.0.0.alpha1+
    Build ID: 83eb114394879cbfd073322a51c47d02553c1fcf
    TinderBox: Win-x86@39, Branch:master, Time: 2015-05-22_06:33:51
    Locale: en-CA (en_CA)
and
    Version: 5.1.0.0.alpha1+
    Build ID: 891304bb0ad3af9d8d73f947f25477abf57485a4
    TinderBox: Win-x86@39, Branch:master, Time: 2015-05-24_00:17:01
    Locale: en-CA (en_CA)

All my observations are from Windows Vista SP2.


STR, for example:

(1) From Start Center, take menu options Help > About.  Program
    Displays the About dialog with useful information.  However ...

    Expected : In the Start Center window, behind the Help dialog, the
    Help menu should be closed.

    Observed : The Help menu is still open.

(2) Drag the Help dialog a short distance.  When you release the mouse
    button ...

    Expected : The program repaints the part of the Start Center
    window which is no longer behind the Help dialog.

    Observed : The part the the Start Center window vacated by the
    Help dialog shows overlapping parts of the Help dialog,
    more or fewer depending on how fast you dragged.

(3) Bring to the front some other application with a window
    overlapping Start Center and the Help dialog.

(4) Type "<Alt>+<Tab>" to give focus to the Help dailog.  The Help
    dialog comes to the front.  However, additionally ...

    Expected : The program will repaint the part of the Start Center
    not behind the Help dialog.

    Observed : The other applictaion activated in step (3) hides the
    the part of the Start Center not behind the Help dialog.  If the
    other application did not hide the remenants left by dragging the
    Help dialog in step (2), those remnants are still visible.
    Screenshot attached.


I have other examples.  The program behaviour is not consistent about
whether or not the invoking menu remains visible behind the dialog.
Otherwise, the following dialogs are afflicted:

  - in Start Center ...
      - Tools > Customize
  - in Writer ...
      - Help > About
      - Tools > "Spelling and Grammar"
  - in Calc ...
      - Tools > Customize

However not all dialogs are so afflicted.  I see the following
behaving normally:

  - In Start Center ...
      - Tools > Options
      - File > Open
  - in Writer ...
      - Format > Paragraph
Comment 1 tommy27 2015-06-02 07:44:06 UTC
I don't reproduce it under Win8.1 x64 using LibO  5.1.0.0.alpha1+
Build ID: 6c1cabe677f5eb24b465dd6e316c8c66df64bb29
TinderBox: Win-x86@39, Branch:master, Time: 2015-05-29_06:48:08
Locale: en-US (it_IT)

@Terrence 
are you still seeing this with a newer 5.1 daily buld?
Comment 2 Terrence Enger 2015-06-02 13:08:42 UTC
Thank you, tommy27, for the reminder about this one.

Yes, the problem is fixed in ...
    Version: 5.1.0.0.alpha1+
    Build ID: cba920edf88bef06a6689e7847c5789dd3ee67b7
    TinderBox: Win-x86@39, Branch:master, Time: 2015-06-01_04:22:29
    Locale: en-CA (en_CA)

I am closing the bug WORKSFORME.