Bug 91681 - Connector labels do not mask the line
Summary: Connector labels do not mask the line
Status: RESOLVED DUPLICATE of bug 45028
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
3.3 all versions
Hardware: Other All
: medium normal
Assignee: Josh Pettus
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-05-28 02:34 UTC by Josh Pettus
Modified: 2015-06-09 12:02 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Draw Document with a label on connector (8.33 KB, application/vnd.oasis.opendocument.graphics)
2015-05-28 04:10 UTC, Josh Pettus
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Josh Pettus 2015-05-28 02:34:42 UTC
Visible Result:  When you add a label to a connector the connector shows right behind the text which looks ugly at best, and illegible at worst if the line is somewhat horizontal.  This makes the labeling feature of the connector all but useless, and forces one to make their own textbox next to the line as an ugly workaround. This can be visually confusing for complicated diagrams. In charts, labels should go over the object they are labeling.

Expected Result: some sort of highlight that's the color of the background for the line to go behind, of have the line stop before it reaches the text and continue afterward.  Whichever is easier.
Comment 1 Joel Madero 2015-05-28 03:05:12 UTC
Please connect a simple test document. Setting to NEEDINFO - once you attach a document please set to UNCONFIRMED.

Clear instructions on how to reproduce would be nice also - stating HOW to add a label, HOW to add a connector, etc . . . but more than anything the test document would help. Thanks!
Comment 2 Josh Pettus 2015-05-28 04:10:16 UTC
Created attachment 116087 [details]
Draw Document with a label on connector

This document has such a connector with the described label
Comment 3 Josh Pettus 2015-05-28 04:13:06 UTC
Thanks and done.

What I did is first draw a connector in the draw program, then double click on the connector to create the label.  The text cursor appears in the middle of the connector.  Type in the label, and the line shows right through the written text.
Comment 4 Buovjaga 2015-06-08 13:57:20 UTC
Would implementing the feature request in bug 91428 (easier positioning) be enough for you or are you keen on the masking idea?
If 91428 is enough, you can mark this as RESOLVED DUPLICATE of it.
Comment 5 Josh Pettus 2015-06-08 22:13:11 UTC
What is meant by easier positioning?  Does that mean you position to the side of the connector If desired after entering?   As I said, labels should go on top of the things they label, especially for more complicated diagrams.  I believe visio can do such a label no problem where the connector doesn't cut through the text.  

http://www.visguy.com/wp-content/uploads/2014/04/3-label-connector.png

As I said the functionality is already there, it's just visually useless.
Comment 6 Josh Pettus 2015-06-08 22:15:26 UTC
sorry wrong selection
Comment 7 Buovjaga 2015-06-09 04:50:48 UTC
I agree with you that it would be a good functionality. However, there is already bug 45028 that refers to Visio import. It seems fixing bug 45028 would mean implementing the feature you want. Do you agree?
Comment 8 Josh Pettus 2015-06-09 12:02:34 UTC
Absolutely.  Sorry, I checked for bug duplicates, must have missed that one..
Comment 9 Josh Pettus 2015-06-09 12:02:58 UTC

*** This bug has been marked as a duplicate of bug 45028 ***