Bug Hunting Session
Bug 91682 - FILEOPEN: Empty Selection List (Tools>Validation). Lost on OOXML round trip
Summary: FILEOPEN: Empty Selection List (Tools>Validation). Lost on OOXML round trip
Status: RESOLVED DUPLICATE of bug 41425
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.4.3.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:xlsx
Depends on:
Blocks: XLSX Cell-Validity
  Show dependency treegraph
 
Reported: 2015-05-28 04:00 UTC by Luke
Modified: 2017-08-04 22:25 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample XLSX file with Selection List (7.96 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2015-05-28 04:00 UTC, Luke
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Luke 2015-05-28 04:00:35 UTC
Created attachment 116086 [details]
Sample XLSX file with Selection List

All Selection Lists are removed on XLSX round trip.

Steps to reproduce:
1. Open SelectionList.xlsx or create a file in Excel with a Selection List in Calc
2. Save
3. Close
4. Open the new file
Comment 1 raal 2015-05-28 06:02:58 UTC
I can confirm with LO 4.4.3, win7
Comment 2 Luke 2015-06-21 18:51:25 UTC
Eike,
Were you the one that recently added the OOXML import logic to read selection lists?
Comment 3 Eike Rathke 2015-06-22 10:21:43 UTC
What is a selection list? ;-p
(which hopefully answers your question ;-)
Comment 4 Luke 2015-09-06 01:03:13 UTC
If you select an item from the list, Calc will export the list correctly. So the issue is only with empty selection lists being stripped out.
Comment 5 Luke 2015-09-06 02:51:46 UTC
Data->Validity->Allow Empty Cells is checked. Also, saving as ODS preserves the selection list.
Comment 6 Bartosz 2016-09-25 23:43:14 UTC
For .xlsx format it is not possible to create empty list for data validation (the error will be displayed during creation.

Also .xlsx format is not support such behaviour.

To resolve that, when empty list was specified, the error should be displayed
Comment 7 Martin Spacek 2017-08-04 22:25:07 UTC

*** This bug has been marked as a duplicate of bug 41425 ***