Bug 91710 - VIEWING: list of themes overprints names when scrolled
Summary: VIEWING: list of themes overprints names when scrolled
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 91750 (view as bug list)
Depends on:
Blocks: RenderContext
  Show dependency treegraph
 
Reported: 2015-05-29 01:54 UTC by Terrence Enger
Modified: 2015-06-08 17:58 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
screenshot; plus red ellipse to direct your attention (86.66 KB, image/pjpeg)
2015-05-29 01:54 UTC, Terrence Enger
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Terrence Enger 2015-05-29 01:54:36 UTC
Created attachment 116114 [details]
screenshot; plus red ellipse to direct your attention

STR

(1) Start Writer.  Program displays window "Untitled 1".

(2) In the menu for the sidebar, click the icon for Gallery.  The
    program displays tab Gallery with button "New Theme..."; a list of
    theme categories with visible entries Arrows (which is selected),
    Background, Bullets, Computers, Diagrams; and a list titled
    Arrows.

(4) Click the down-arrow in the list of themes.

    Expected : That the entries should move up, Arrows going off the
    top of the list and Environment coming in at the bottom.

    Observed : That the scrolled-in entry Environment is displayed on
    the top of the word "Diagrams".  The entry Diagrams also appears
    in its expected place one position higher in the list.  Screenshot
    attached.

(5) Bring some window to the front over the garbled entry.

(6) Return focus to "Untitled 1".  Entry Environment is displayed
    correctly.

(7) Further scrolling produces overlap upon overlap.

(8) If you navigate the list of theme categories with <up-arrow> and
    <down-arrow> keystrokes, scrolled-in entries are briefly displayed
    overlapping the word previously at that place on the screen, but
    but program quickly corrects the rendering.


These observations were made in Windows Vista and LibreOffice version ...
    Version: 5.1.0.0.alpha1+
    Build ID: 487880b6882ec01c1b4679eae60bec484272a86b
    TinderBox: Win-x86@39, Branch:master, Time: 2015-05-28_04:59:56
    Locale: en-CA (en_CA)
In (a chroot environment to) debian-sid, dbgutil version 2015-05-28 ...
    Version: 5.1.0.0.alpha1+
    Build ID: be01d68420086fc36ecf26b5f597ba7c6b29b369
    Locale: en-CA (en_CA.UTF-8)
shows similar results.
Comment 1 Yousuf Philips (jay) (retired) 2015-05-30 19:13:51 UTC
*** Bug 91750 has been marked as a duplicate of this bug. ***
Comment 2 Jan Holesovsky 2015-06-08 14:38:18 UTC
Terrence: I am sorry, I cannot reproduce this :-(  Can you please try with Beta2 if it is still broken?

If it is - can you please bibisect to see where this started appearing?  Hopefully that would also give a clue how to make it better reproducible.

Thank you!
Comment 3 Buovjaga 2015-06-08 15:26:19 UTC
Not reproduced, maybe the glitch was fixed?

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: be8512f99bc9ab18e55aabe01cc0ab1e6baea9e6
TinderBox: Win-x86@39, Branch:master, Time: 2015-06-08_05:58:40
Locale: fi-FI (fi_FI)
Comment 4 Yousuf Philips (jay) (retired) 2015-06-08 17:15:50 UTC
This has been fixed from a while now, as i've been customizing the toolbars and havent seen it for atleast a week i believe.
Comment 5 Terrence Enger 2015-06-08 17:58:35 UTC
body
----
And I to see that the problem is gone in both the daily dbgutil repo
version 2015-06-08 and the Windows daily of 2015-06-08.  Yousuf has
already set RESOLVED WORKSFORME.

Thank you, Jan, for the reminder.

Terry.