Download it now!
Bug 91714 - Sidebar Could Share Space with Other Toolbars - an enhancement
Summary: Sidebar Could Share Space with Other Toolbars - an enhancement
Status: RESOLVED DUPLICATE of bug 33223
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: ux-advise (show other bugs)
Version:
(earliest affected)
4.4.3.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-05-29 06:08 UTC by Tom Colley
Modified: 2015-07-19 09:05 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tom Colley 2015-05-29 06:08:49 UTC
Currently, in Version 4.4.3.2, the sidebar seems to require a whole column of space. It won't share this space with other toolbars even though it typically only contains 4 icons. I suggest enabling the sidebar and toolbars to coexist in the same column or row, just as other toolbars do with each other. This enables more efficient use of the screen/window real estate.
Comment 1 Buovjaga 2015-06-08 14:53:38 UTC
This is for the design team to accept or reject.
Comment 2 V Stuart Foote 2015-06-08 15:05:37 UTC
The SideBar Tab bar is tied to the SideBar Deck and both are currently coded to be full height of the document canvas.  Other vertical toolbars can be docked outside of the SideBar, but there is not compelling UI need to make the docked SideBar any shorter than full document canvas height. Nor any need to complicate the Tab bar code, in collapsed Deck mode, to reduce its height to accommodate docked vertical toolbars below or above it.
Comment 3 Tom Colley 2015-06-16 05:26:27 UTC
In response to Comment 2, I beg to differ. I would have thought that the need to reserve screen real estate for document display/editing would be a "compelling" UI need. Having a key toolbar of only 4 buttons that reserves an entire vertical strip has been problematic for me in situations where I'm co-editing two documents on one laptop screen. I know this situation is not the most common situation, but neither is it rare. I am sure other users with limited screen space will be affected by this issue. I am in no position to judge whether the complications that might ensue from adapting the interface are too great. However, I think the UI need is reasonably compelling!
Comment 4 Jean-Baptiste Faure 2015-07-12 20:30:06 UTC
I agree with your considerations about small screens, but I prefer the more general solution I proposed: bug #33223. The idea is to have the possibility to add toolbars inside the sidebar.

Best regards. JBF
Comment 5 Tom Colley 2015-07-19 04:55:55 UTC
(In reply to Jean-Baptiste Faure from comment #4)
> I agree with your considerations about small screens, but I prefer the more
> general solution I proposed: bug #33223. The idea is to have the possibility
> to add toolbars inside the sidebar.
> 
> Best regards. JBF


I agree with you, JBF - the capacity to add toolbars within the sidebar would also solve the issue raised here.
Comment 6 Jean-Baptiste Faure 2015-07-19 09:05:09 UTC
(In reply to Tom Colley from comment #5)
> (In reply to Jean-Baptiste Faure from comment #4)
> > I agree with your considerations about small screens, but I prefer the more
> > general solution I proposed: bug #33223. The idea is to have the possibility
> > to add toolbars inside the sidebar.
> > 
> > Best regards. JBF
> 
> 
> I agree with you, JBF - the capacity to add toolbars within the sidebar
> would also solve the issue raised here.

Ok, so closing as duplicate of bug 33223.

Best regards. JBF

*** This bug has been marked as a duplicate of bug 33223 ***