Download it now!
Bug 91761 - Crash when copying contents from one form to another form
Summary: Crash when copying contents from one form to another form
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
4.4.3.2 release
Hardware: x86-64 (AMD64) All
: high critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: haveBacktrace
Depends on:
Blocks: Database-Forms Cut-Copy
  Show dependency treegraph
 
Reported: 2015-05-31 00:35 UTC by christian_kuhn
Modified: 2019-06-01 06:40 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
crash when copying contents from one form to another form (12.35 KB, image/png)
2015-05-31 00:35 UTC, christian_kuhn
Details
backtrace for this kind of crash (38.19 KB, text/plain)
2015-05-31 20:16 UTC, christian_kuhn
Details
example (196.81 KB, application/vnd.sun.xml.base)
2015-05-31 20:23 UTC, christian_kuhn
Details
new example (142.24 KB, application/vnd.oasis.opendocument.database)
2015-05-31 21:09 UTC, christian_kuhn
Details
message, when LO crashed (22.98 KB, image/jpeg)
2016-11-12 21:30 UTC, christian_kuhn
Details
bt with debug symbols (15.39 KB, text/plain)
2018-01-29 18:04 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description christian_kuhn 2015-05-31 00:35:32 UTC
Created attachment 116184 [details]
crash when copying contents from one form to another form

This crash is occured two times one after another. I have tried to copy the contents of one form which are combined with one table to another form and to assign the new contents to the another table. Following steps:

1) Open a database (HSQLDB) with at least two tables and two forms, the contents of one form are combined with a table. 

2) Open both two forms.

3) Select the contents of one form with the mouse and copy them to the second form via drag and drop. Perhaps the new contents must be edited --> the crash occured.
Comment 1 raal 2015-05-31 19:50:46 UTC
Hello Christian,

Thank you for reporting the bug. Please attach a sample document, as this makes it easier for us to verify the bug. 
I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' once the requested document is provided.
(Please note that the attachment will be public, remove any sensitive information before attaching it. 
See https://wiki.documentfoundation.org/QA/FAQ#How_can_I_eliminate_confidential_data_from_a_sample_document.3F for help on how to do so.)
Comment 2 christian_kuhn 2015-05-31 20:16:16 UTC
Created attachment 116201 [details]
backtrace for this kind of crash

Hello,

I have made a backtrace for this kind of crash. For reproducing this, it could be necessary to edit something in the form navigator of the new created form.
Comment 3 christian_kuhn 2015-05-31 20:23:19 UTC
Created attachment 116202 [details]
example

Hello,

I have uploaded the example database of bug 91357. I hope, it can be reproduced with it. My original database, which causes the crash, has about 100 tables and is too large for uploading and contains all my work ;)
Comment 4 raal 2015-05-31 20:31:34 UTC
Can not reproduce with LO 4.3.3, win7
Comment 5 christian_kuhn 2015-05-31 21:09:17 UTC
Created attachment 116205 [details]
new example

I could reproduce it with this example database and LO 4432. Following steps:

1) Open both forms (Demo 1 and Demo 2) in edit mode, not normally.
2) Select the contents of form 'Demo 1' and copy them to clipboard (Ctrl-C)
3) Paste the contents in form 'Demo 2' (Ctrl-V)
4) Open form navigator of form 'Demo 2'
4.1) Select all items unter 'demo 1' and move them to 'demo 2' (Delete 'demo 1')
6) Close form 'Demo 1'
7) Do something with the main window or form 'Demo 2' (resize it, press a button in main window or whatever)

I have got the crash.
Comment 6 raal 2015-06-01 07:18:53 UTC
(In reply to christian_kuhn from comment #5)
> Created attachment 116205 [details]
> new example
> 
> I could reproduce it with this example database and LO 4432. Following steps:
> 

I can confirm crash with LO 4.4.3, win7
Comment 7 QA Administrators 2016-09-20 10:01:05 UTC Comment hidden (obsolete)
Comment 8 christian_kuhn 2016-11-12 21:30:18 UTC
Created attachment 128703 [details]
message, when LO crashed

I can reproduce this crash with the uploaded example. I use LibreOffice Version: 5.2.1.2 Build-ID: 31dd62db80d4e60af04904455ec9c9219178d620 and Windows 10. But now the behaviour of the crash has changed: if I try to close the form demo1 after I have copied the contents of it to the form demo2, I get a message box with the content 'SEH exception: ACCESS VIOLATION'. Then Base hangs and I must close it with the task manager.

Best regards,
Christian
Comment 9 Julien Nabet 2017-03-19 10:18:10 UTC
(In reply to christian_kuhn from comment #5)
> Created attachment 116205 [details]
> new example
> 
> I could reproduce it with this example database and LO 4432. Following steps:
> 
> 1) Open both forms (Demo 1 and Demo 2) in edit mode, not normally.
> 2) Select the contents of form 'Demo 1' and copy them to clipboard (Ctrl-C)
> 3) Paste the contents in form 'Demo 2' (Ctrl-V)
> 4) Open form navigator of form 'Demo 2'
> 4.1) Select all items unter 'demo 1' and move them to 'demo 2' (Delete 'demo
> 1')
> 6) Close form 'Demo 1'
> 7) Do something with the main window or form 'Demo 2' (resize it, press a
> button in main window or whatever)
> 
> I have got the crash.

Would it be possible to have a more simple use case?
Indeed,
in step 2 Select the contents of form "Demo 1" : There's no "select all" option, if I try to select all the elements with mouse, it doesn't work, it only selects Demo 1 text. Is it mandatory to select every element of Demo 1?
in step 4.1) in navigator, how to access elements from demo 1 ?
Comment 10 Julien Nabet 2018-01-29 18:04:19 UTC
Created attachment 139438 [details]
bt with debug symbols

On pc Debian x6-64 with master sources updated some days ago, I could reproduce this.
Comment 11 Julien Nabet 2018-01-29 18:05:27 UTC
Christian: re reading https://bugs.documentfoundation.org/show_bug.cgi?id=91761#c5, I could reproduce this, sorry for the previous post.
Comment 12 QA Administrators 2019-01-30 03:42:05 UTC Comment hidden (obsolete)
Comment 13 Julien Nabet 2019-05-30 08:20:20 UTC
On pc Debian x86-64 with master sources updated today and trying to follow https://bugs.documentfoundation.org/show_bug.cgi?id=91761#c5, I don't reproduce this anymore.
Idem with LO Debian package 6.1.5.2

Christian: could you give a try to last LO version 6.2.4?
Comment 14 christian_kuhn 2019-05-31 23:03:36 UTC
Hello,

I downloaded the example from this page and tried it with:

Version: 6.2.4.2 (x64)
Build-ID: 2412653d852ce75f65fbfa83fb7e7b669a126d64

I could not reproduce the crash. I have resized the window and moved and manipulated the copied content.

Best regards,
Christian
Comment 15 Julien Nabet 2019-06-01 06:40:52 UTC
Thank you for your feedback, let’s put this one to WorksForMe