Bug Hunting Session
Bug 91776 - Start Center "R" accelerator conflict between "Recent Files" and "Draw Drawing" (english UI)
Summary: Start Center "R" accelerator conflict between "Recent Files" and "Draw Drawin...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.4.0.0.alpha2
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: V Stuart Foote
URL:
Whiteboard: target:5.1.0
Keywords: regression
Depends on:
Blocks: Start-Center
  Show dependency treegraph
 
Reported: 2015-05-31 15:37 UTC by Terrence Enger
Modified: 2016-10-25 19:23 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Terrence Enger 2015-05-31 15:37:45 UTC
STR

(1) In Start Center under the heading Create, observe "Draw Drawing"
    with the second "R" underlined.

(2) Type "R".  

    Expected : The program opens Draw Window "Untitled 1" and gives it
    focus.

    Obaserved : No action.


On Linux, I see this in dbgutil version 2015-05-31 ...
    Version: 5.1.0.0.alpha1+
    Build ID: 661791da72ec2ddddbba3552279e239f13df1c4f
    Locale: en-CA (en_CA.UTF-8)
and ...
    Version: 4.4.0.0.alpha2+
    Build ID: ef2ed50231fd946c1f374ffbce28ebb98eda56c5
    TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2014-11-15_01:48:42
but not in ...
    Version: 4.3.2.2
    Build ID: edfb5295ba211bd31ad47d0bad0118690f76407d

On Windows Vista 32-bit, I do see the problem in ...
    Version: 5.1.0.0.alpha1+
    Build ID: 1a8e9dae32997bf199dbd192058fcd8f187ddc49
    TinderBox: Win-x86@39, Branch:master, Time: 2015-05-31_03:55:23
    Locale: en-CA (en_CA)
Comment 1 Terrence Enger 2015-05-31 15:39:15 UTC
Setting keyword regression.
Comment 2 V Stuart Foote 2015-05-31 23:09:10 UTC
I think the issue is that both Recent Files and Draw have defined accelerators of "R" assigned. Since they conflict, they simply toggle from Sidebar Menu items without completing a selection.

However, an "r" accelerator selection followed by "enter" will launch the appropriate panel.
Comment 3 V Stuart Foote 2015-05-31 23:19:43 UTC
The conflicting accelerator "R" was assigned with
http://cgit.freedesktop.org/libreoffice/core/commit/?id=fe421533614cce6819c72c16f19b8de19e0d99da
to provide means to return from template manager
Comment 4 Terrence Enger 2015-06-01 01:12:35 UTC
Stuart,

Right you are that "R" in Start Center alternately selects "Recent
Files" and "Draw Drawing".  Even now that I am looking for it
particularly, I can barely see the extra border around whichever one
is selected.

And I must have been dreaming that the daily on Windows Vista worked
as I expected.  Now I see that it works just like the Linux version.

I am closing the report NOTABUG.

Thamk you, Stuart, for helping me with this one.

Terry.
Comment 5 Jan Holesovsky 2015-06-02 10:54:40 UTC
Still - I think it would be useful to change the accelerators so that they do not conflict :-)

Stuart - any chance to push a patch that assigns something else to "Recent Files", please?
Comment 6 tommy27 2015-07-03 05:40:52 UTC
still reproducible under Win8.1 x64 using LibO 5.1.0.0.alpha1+ (x64)
Build ID: 8b788891796ff0571f779cdbe8ce809c35c42754
TinderBox: Win-x86_64@62-TDF, Branch:MASTER, Time: 2015-07-02_23:09:27
Locale: en-US (it_IT)

IMHO accelerators should be set according to the first letter if possible, like in the File, Tools, Help menu where you have "f, t and h"

then I'll leave the "O" and "R" for Open File and Recent File and leave the "e" for Templates (the t is already used for Tools)

then I'd change all the other accelerators...

W for Writer instead of D
C for Calc instead of s
I for Impress instead of P
D for Draw instead of r (which doesn't work right now)
M for Math
B for Base instead of a

I think that it would solve all conflicts and tha the final visual look would be better 

edited summary notes.
I ask an opinion from the UX team.
Comment 7 Heiko Tietze 2015-07-03 09:18:04 UTC
(In reply to tommy27 from comment #6)
> IMHO accelerators should be set according to the first letter if possible,
> like in the File, Tools, Help menu where you have "f, t and h"
> ...
> I ask an opinion from the UX team.

Absolutely, use the first character by default. But first of all you should check against standards. So E&xit for instance would be alt+X. The proposed setup in this case looks good to me, anyway.
Comment 8 mahfiaz 2015-07-03 11:53:41 UTC
So instead of referring to Document, Presentation, Spreadsheet, we refer to the component name. Fine by me.
Comment 9 V Stuart Foote 2015-07-03 11:59:44 UTC
Thoughts on Main menu Tools vs. SC Templates, which gets the T?

Also Main Menu Help vs. SC Help, which gets the H?

Defer to the Main Menu (so its consistent through all panels)... or make StartCenter sidebar buttons consistent?  Seems the Main Menu should have precedence.
Comment 10 tommy27 2015-07-03 12:14:53 UTC
(In reply to Heiko Tietze from comment #7)
> (In reply to tommy27 from comment #6)
> ...
>
> Absolutely, use the first character by default. But first of all you should
> check against standards. So E&xit for instance would be alt+X. The proposed
> setup in this case looks good to me, anyway.

don't confuse single letter accelerators about the main start center screen and the accelerators and shortcuts in the start center menus, like "File/Exit"

the issue here is about the single letter accelerators of the first level
Comment 11 tommy27 2015-07-03 12:17:15 UTC
(In reply to V Stuart Foote from comment #9)
> Thoughts on Main menu Tools vs. SC Templates, which gets the T?
> 
> Also Main Menu Help vs. SC Help, which gets the H?
> 
> Defer to the Main Menu (so its consistent through all panels)... or make
> StartCenter sidebar buttons consistent?  Seems the Main Menu should have
> precedence.

as said before in comment 6 I'd give the "T" to the "Tools" menu and leave the "e" to Templates
Comment 12 tommy27 2015-07-03 12:22:40 UTC
another consideration is that there can be different accelerator conflicts according to the UI language.
Comment 13 V Stuart Foote 2015-07-03 12:40:01 UTC
(In reply to tommy27 from comment #12)
> another consideration is that there can be different accelerator conflicts
> according to the UI language.

Yes, and another facet to using the module names would be that those aren't translated in the UI--so those accelerators would be stable. Less impact on l10n/i18n

@Sophi, true?
Comment 14 mahfiaz 2015-07-03 14:47:17 UTC
(In reply to V Stuart Foote from comment #13)
> Yes, and another facet to using the module names would be that those aren't
> translated...

But the menu names are translated (as for T reserved for Tools not templates). I'd say we don't worry about translators. They'll manage or report.
Comment 15 tommy27 2015-07-04 04:45:00 UTC
sure, bottomline is:
- resolve current accelerator conflicts
- opt for a better accelerator selection criteria, which IMHO is "first letter, if possible"

this has to be carried out in any different UI language
Comment 16 V Stuart Foote 2015-07-06 23:03:46 UTC
Patch using first letter of module names as accelerators, as in comment 6, up for review https://gerrit.libreoffice.org/#/c/16807/
Comment 17 Commit Notification 2015-07-07 10:27:51 UTC
vsfoote committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3b355fca41dcfc94809fcdbbf31234a6abf86444

tdf#91776 Rework StartCenter accelerators, use first letter of module names

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 18 tommy27 2015-07-07 12:01:51 UTC
@Stuart
one question since I'm not very good reading code...
is your patch just about the english UI or does it apply to all languages?
Comment 19 Adolfo Jayme 2015-07-07 12:08:58 UTC
@tommy27: The patch changes the original (English) strings, which will obviously have to be re-translated by each translation team.
Comment 20 Adolfo Jayme 2015-07-07 12:09:37 UTC
And there’ll be no backport as the release branches are in string freeze.
Comment 21 tommy27 2015-07-07 12:18:22 UTC
I thought that there was "no string change" but just change of which letter gets underlined to become an accelerator... anyway I'll test the next daily build to see with my own eyes.