Bug 91810 - empty error-box
Summary: empty error-box
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
5.0.0.0.beta1
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: bibicested
Keywords: bisected, regression
Depends on:
Blocks: RenderContext
  Show dependency treegraph
 
Reported: 2015-06-02 12:20 UTC by Thomas Krumbein
Modified: 2015-06-10 10:44 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Empty Warning Box in Basic (3.25 MB, image/png)
2015-06-02 12:20 UTC, Thomas Krumbein
Details
Used extension for Basictest (17.13 KB, application/vnd.openofficeorg.extension)
2015-06-02 13:50 UTC, Thomas Krumbein
Details
Another empty box (1.43 MB, image/png)
2015-06-02 15:49 UTC, Thomas Krumbein
Details
empty menu frames (38.05 KB, image/png)
2015-06-02 15:51 UTC, Thomas Krumbein
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Krumbein 2015-06-02 12:20:35 UTC
Created attachment 116237 [details]
Empty Warning Box in Basic

Testing some of my old extensions and macros I got an empty warning box (see attached picture).

I guess, it is an error inside the code (not checked this now) - but this empty messagebox is a bug:)

Code stopped at this line.

My System: Win 8.1 64 bit, LibO 5.0.0.0.beta1, 64 bit
Comment 1 raal 2015-06-02 13:17:46 UTC
Hello Thomas,

Thank you for filing the bug. Please send us a sample document, as this makes it easier for us to verify the bug. 
I have set the bug's status to 'NEEDINFO', so please do change it back to 'UNCONFIRMED' once you have attached a document.
(Please note that the attachment will be public, remove any sensitive information before attaching it.)
How can I eliminate confidential data from a sample document?
https://wiki.documentfoundation.org/QA/FAQ#How_can_I_eliminate_confidential_data_from_a_sample_document.3F
Thank you
Comment 2 Thomas Krumbein 2015-06-02 13:50:15 UTC
Created attachment 116238 [details]
Used extension for Basictest

So - attached is my (very old) extension, which I never test with Lo 4, so there may be some more issues inside the code. 

Just the steps reprioduce the empty msg-box:

- Install the extension.
- open a new writer Document
- Insert a picture 
- start the extension (there will be a new icon bar with just 1 Icon - klick on it)
- a dialog will appear (dimesiones should be reworked....)
- Select your picture in the first upper left Listbox - in case the code works well, you will see an small preview on the right side of the dialog.

But.... code crashed an these empty Box appiears:)

Best regards
Thomas
Comment 3 raal 2015-06-02 14:35:24 UTC
With LO Version: 5.1.0.0.alpha1+
Build ID: e61fcfea5c2a306e44a053976e921160e78917ac
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2015-06-01_01:59:0

Version: 5.1.0.0.alpha1+
Build ID: cba920edf88bef06a6689e7847c5789dd3ee67b7
TinderBox: Win-x86@39, Branch:master, Time: 2015-06-01_04:22:29

message:  BASIC runtime error. Object variable not set.  ; No crash, no empty box.
Please, could you test with newer build? Seems to be fixed, thank you

http://dev-builds.libreoffice.org/daily/master/
Comment 4 Thomas Krumbein 2015-06-02 15:31:23 UTC
@ raal:

Yes, I will give feedback. 
But there is no newer build availible yet.

I am testing Win 64 bit build - and the newest ist 5.0.0.0Beta 1 ;)
Comment 5 Thomas Krumbein 2015-06-02 15:49:05 UTC
Well, made some more testing:))

seems to be a rendering / timing problem.

I have add a stopp-point to the Basic Code - afterwards nothing works as expected.

Two nice screenshots added:

 - first: try to open the management dialog für stopp-labels -> empty frame whith catches the background content - you can now move the window - backgruond will stay inside :))

 - after adding a stopp-point to code, you only get emty menus :) 
   see screen 02 - this applies to all open moduls or documents 

Only restart Libo will end this phenomen - but stopp-point is removed.

So - this may be an rendering/timing problem.
Comment 6 Thomas Krumbein 2015-06-02 15:49:58 UTC
Created attachment 116244 [details]
Another empty box
Comment 7 Thomas Krumbein 2015-06-02 15:51:44 UTC
Created attachment 116245 [details]
empty menu frames
Comment 8 Terrence Enger 2015-06-03 22:33:46 UTC
Thomas,

In tdf#91506, although point (2) does not mention
program-displayed dialogs explicitly, I did see blank dialogs.  I
wonder if this report is a duplicate?

The daily builds have had the problem fixed for a few days now.
You might try one of those, or you can wait for the next beta
version.

HTH,
Terry.
Comment 9 László Németh 2015-06-10 10:44:40 UTC
Introduced by this commit:
 2ff53e1f4a3d15553d64ae0a4dbb566fc2f4f8f0 is the first bad commit
commit 2ff53e1f4a3d15553d64ae0a4dbb566fc2f4f8f0
Author: Matthew Francis <mjay.francis@gmail.com>
Date:   Wed May 27 23:04:48 2015 +0800

    source-hash-607582291eaad26a18b1df6f7aea434b391d548c
    
    commit 607582291eaad26a18b1df6f7aea434b391d548c
    Author:     Tomaž Vajngerl <tomaz.vajngerl@collabora.co.uk>
    AuthorDate: Wed May 13 21:07:25 2015 +0900
    Commit:     Tomaž Vajngerl <tomaz.vajngerl@collabora.co.uk>
    CommitDate: Thu May 14 09:58:14 2015 +0900
    
        refactor "basctl" classes to use RenderContext
    
        Change-Id: I6eb54af9f793c614c823123c6f16a3dc4f3a0c0b


And fixed around here:

Author: Miklos Vajna <vmiklos@collabora.co.uk>
Date:   Sat May 30 05:47:12 2015 +0200

    2015-05-30: source-hash-661791da72ec2ddddbba3552279e239f13df1c4f

:100644 100644 0a24d52886dcc126e2f1d9bc65ba2dc3a38c0b8d a8a9cb2c514a1c8a2015ffa5684abf51463e0412 M	build-info.txt
:040000 040000 95a5f229a159700a74ce5e266adb582812e4cf2b a14875df1e83852257740787695a489d0f846df6 M	opt

Likely with this commit:

commit 0af0211b0f81f91727c81df909c0b41cedc4b088
Author: Tomaž Vajngerl <tomaz.vajngerl@collabora.co.uk>
Date:   Fri May 29 18:20:42 2015 +0900

    tdf#91484 fix macro editor - Invalidate in paint
    
    Change-Id: I787da9a665e54caea229def185076b29c00fd11e