Download it now!
Bug 91870 - cursor blinking abnormally if the document contains some field
Summary: cursor blinking abnormally if the document contains some field
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.0.0.beta1
Hardware: x86-64 (AMD64) All
: highest major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, regression
Depends on:
Blocks:
 
Reported: 2015-06-05 07:53 UTC by Jean-Baptiste Faure
Modified: 2016-03-25 06:10 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
bugdoc to reproduce the issue (18.87 KB, application/vnd.oasis.opendocument.text)
2015-06-05 07:53 UTC, Jean-Baptiste Faure
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jean-Baptiste Faure 2015-06-05 07:53:06 UTC
Created attachment 116296 [details]
bugdoc to reproduce the issue

Version: 5.0.0.0.beta1+
Build ID: d132cf6c18fc78c844cc5dcf210df4e8c2267172
Ubuntu_15.04_x86-64
Locale: fr-FR (fr_FR.UTF-8)

Steps to reproduce:
1/ open the attached bugdoc
2/ observe that the cursor blinks abnormally: it does not blink or it flickers. At the file opening maybe it does not blink, do a small change in the text, then it flickers.
3/ move the cursor inside the line containing two fields (creation date and modification date) ==> cursor blinks with the correct frequency.
Idem if you move the cursor in the footer.
4/ remove the previous fields and the Title field in the footer
==> the cursor blinks with the correct frequency, regardless its position.

The problem does not occur if the field is the page number or the page count.
This issue seems to induce CPU over-consumption.

Works without problem in version 4.4.x

Best regards. JBF
Comment 1 Jean-Baptiste Faure 2015-06-05 07:53:47 UTC
It works as expected in LO 4.4.x => regression
Comment 2 Tomaz Vajngerl 2015-06-05 08:25:52 UTC
This sound similar to tdf#91677 (the ruler stops functioning because there is a inf. loop, that causes constant redraws). I have debugged the issue a bit but couldn't find the cause yet..
Comment 3 Jean-Baptiste Faure 2015-06-05 12:32:09 UTC
(In reply to Tomaz Vajngerl from comment #2)
> This sound similar to tdf#91677 (the ruler stops functioning because there
> is a inf. loop, that causes constant redraws). I have debugged the issue a
> bit but couldn't find the cause yet..

With my bugdoc, I am not able to change paragraph and page margins using the rulers. It works without problem on a document without fields.

Best regards. JBF
Comment 4 tommy27 2015-06-06 05:48:04 UTC
bug confirmed under Win8.1 x64 using LibO 5.1.0.0.alpha1+
Build ID: 8d46bc15e93687f93d7c85064acc71231e2f08b1
TinderBox: Win-x86@39, Branch:master, Time: 2015-06-02_05:16:07
Locale: en-US (it_IT)

status NEW
hardware ALL
Comment 5 Jean-Baptiste Faure 2015-06-10 04:49:42 UTC
I think that this bug has a clear bad impact on the LO Writer usability. See bug description + comment #3. So rising a bit the severity.

On a real life document (~200 pages of software documentation) the impact on the CPU is 50% of a core when I do nothing, just opened the file.

Best regards. JBF
Comment 6 Jean-Baptiste Faure 2015-07-09 10:51:20 UTC
Unchecking the configuration option for Writer to update fields automatically
(in Menu Tools > Options > LibreOffice Writer > General) restores a normally blinking cursor. That said it is not an sustainable workaround.

Best regards. JBF
Comment 7 Tomaz Vajngerl 2015-07-16 04:25:45 UTC
This is fixed in master - I assume by [1]. I'll try to cherry-pick it to 5-0 and see if this is true.

[1] http://cgit.freedesktop.org/libreoffice/core/commit/?id=b0fde7a912ff3aa370496802f20895b1158b072c
Comment 8 Tomaz Vajngerl 2015-07-16 04:55:01 UTC
Ah.. wrong. It still happens..
Comment 9 Jean-Baptiste Faure 2015-07-16 05:04:52 UTC
Perhaps problem of the same kind as bug 38837 but related to some sort of fields updating. I do not see the problem if the field is page number or page count: in the test file if you remove all fields but page number / page count, the cursor blinks normally again.

Best regards. JBF
Comment 10 Jean-Baptiste Faure 2015-07-30 05:17:43 UTC
Not reproducible anymore since several days (and commits) in LO 5.0.1.0+ built at home under Ubuntu 15.04 x86-64 with gcc 5.1.
Probably fixed by commits for bug 38837 but I am not sure. So closing as worksforme.

Best regards. JBF
Comment 11 Tomaz Vajngerl 2015-07-30 05:26:23 UTC
This is what I thought too.. but only until I modified the document where the problem started to happen again.
Comment 12 Jean-Baptiste Faure 2015-07-31 19:54:03 UTC
(In reply to Tomaz Vajngerl from comment #11)
> This is what I thought too.. but only until I modified the document where
> the problem started to happen again.

Argh, you are right. Thank you for testing that more deeply than me. :-)
That said, the cursor is correct again once you have saved the modified document.

Setting back to NEW.

Best regards. JBF
Comment 13 ronny 2015-09-10 13:12:18 UTC
Still reproduceable in Writer 5.0.2.1 …
Comment 14 Per 2015-09-20 22:07:06 UTC
Also reproducible in 5.0.2rc1 64-bit on win7 64bit
/Per
Comment 15 Puggan SE 2015-10-21 20:34:04 UTC
bibisected with 50max.

conclustion:
The first bad commit could be any of:
18afb86 source-hash-d05a64df34fd143670cb939b72abfb32d6b714c7
891b689 source-hash-01f406bc28f53acc5a2734af637aa8074a5d1813

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d05a64df34fd143670cb939b72abfb32d6b714c7
http://cgit.freedesktop.org/libreoffice/core/commit/?id=01f406bc28f53acc5a2734af637aa8074a5d1813

log:
# bad: [dda106fd616b7c0b8dc2370f6f1184501b01a49e] source-hash-0db96caf0fcce09b87621c11b584a6d81cc7df86
# good: [5b9dd620df316345477f0b6e6c9ed8ada7b6c091] source-hash-2851ce5afd0f37764cbbc2c2a9a63c7adc844311
git bisect start 'latest' 'oldest'
# good: [0c30a2c797b249d0cd804cb71554946e2276b557] source-hash-45aaec8206182c16025cbcb20651ddbdf558b95d
git bisect good 0c30a2c797b249d0cd804cb71554946e2276b557
# bad: [2ce02b2ce56f12b9fcb9efbd380596975a3a5686] source-hash-17d714eef491bda2512ba8012e5b3067ca19a5be
git bisect bad 2ce02b2ce56f12b9fcb9efbd380596975a3a5686
# bad: [e4deb8a42948865b7b23d447c1547033cb54535b] source-hash-ce46c98dbeb3364684843daa5b269c74fce2af64
git bisect bad e4deb8a42948865b7b23d447c1547033cb54535b
# bad: [15e8b5cc6b4784fecd63b2a5a04ac086b3e9fc01] source-hash-26b500afcaed704db7a300836f466517c309ee77
git bisect bad 15e8b5cc6b4784fecd63b2a5a04ac086b3e9fc01
# bad: [534715525a93b0d7d56ba123d253c927cccf0afe] source-hash-40c9a46b78b8919aae82dd9b94774d63bb9cb4e6
git bisect bad 534715525a93b0d7d56ba123d253c927cccf0afe
# good: [c255ade961c9628f72d2fbca268fdf3a4e5f60c2] source-hash-4bdbea5447f36beb9cc33df173a89a49a9918290
git bisect good c255ade961c9628f72d2fbca268fdf3a4e5f60c2
# good: [2b4739cd51404149b1279b86643f1fee719de667] source-hash-8ee20e2691aa6f67c67d40c61a8cd1569458b5a8
git bisect good 2b4739cd51404149b1279b86643f1fee719de667
# good: [9891e7d487540e4650378e546aea5025876d02cf] source-hash-b2f76e0e8a81b456f47b677cd881cc105f781cdb
git bisect good 9891e7d487540e4650378e546aea5025876d02cf
# skip: [891b689ba95b9e53609194ee2a1a2d3b8955843c] source-hash-01f406bc28f53acc5a2734af637aa8074a5d1813
git bisect skip 891b689ba95b9e53609194ee2a1a2d3b8955843c
# good: [4484ce03daa4db83ee9ce6e54396d6f1a0ddcb2a] source-hash-6a3c5af4eb96d03110fcbc856c6920bfcf4063c7
git bisect good 4484ce03daa4db83ee9ce6e54396d6f1a0ddcb2a
# bad: [18afb8632caa524fbc70ed5ce3808e23e5dad16f] source-hash-d05a64df34fd143670cb939b72abfb32d6b714c7
git bisect bad 18afb8632caa524fbc70ed5ce3808e23e5dad16f
# good: [b02369ea724c86023b074987f04fd60f956c4618] source-hash-4cd7b4ab8aeaf61f5e30e4b63e039b7bb9519e85
git bisect good b02369ea724c86023b074987f04fd60f956c4618
# good: [b52e9a820cbacc502e51aeae755415ea1ac8994a] source-hash-100c518e980f6abdc93c727c524b738200236bf2
git bisect good b52e9a820cbacc502e51aeae755415ea1ac8994a
# good: [cfa6015c1d535c8e22bef6a6abb9363c757693d1] source-hash-9e678c14e4fc8e58b1e0530744f648fa3958d338
git bisect good cfa6015c1d535c8e22bef6a6abb9363c757693d1
# only skipped commits left to test
# possible first bad commit: [18afb8632caa524fbc70ed5ce3808e23e5dad16f] source-hash-d05a64df34fd143670cb939b72abfb32d6b714c7
# possible first bad commit: [891b689ba95b9e53609194ee2a1a2d3b8955843c] source-hash-01f406bc28f53acc5a2734af637aa8074a5d1813
Comment 16 Tomaz Vajngerl 2015-10-21 20:54:35 UTC
Well.. now I really don't see this anymore in master.
Comment 17 Robinson Tryon (qubit) 2015-12-13 11:13:12 UTC
Migrating Whiteboard tags to Keywords: (bibisected)
[NinjaEdit]
Comment 18 Björn Michaelsen 2016-03-25 02:16:49 UTC
cannot reproduce on todays master -- so with comment 15, closing this as WFM until there are better reproduction instructions.
Comment 19 Jean-Baptiste Faure 2016-03-25 06:10:13 UTC
(In reply to Björn Michaelsen from comment #18)
> cannot reproduce on todays master -- so with comment 15, closing this as WFM
> until there are better reproduction instructions.

I do not reproduce anymore with LO 5.1.x too.

Best regards. JBF