Download it now!
Bug 91895 - Impress Cut & paste in table sometimes loses font style (steps: Comment 11)
Summary: Impress Cut & paste in table sometimes loses font style (steps: Comment 11)
Status: RESOLVED INSUFFICIENTDATA
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.1.0.0.alpha0+ Master
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, regression
Depends on:
Blocks: ImpressDraw-Tables Paste Character
  Show dependency treegraph
 
Reported: 2015-06-06 12:17 UTC by Philippe Jung
Modified: 2017-10-04 17:19 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
printscreen (24.42 KB, image/png)
2015-06-07 19:39 UTC, raal
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Philippe Jung 2015-06-06 12:17:21 UTC
I have a table 5x8
I copy a text from a cell into another
Text style is not kept.

No specific style applied to any of the cells. If I go in the cell and type, the font style is coherent with the source. If I paste font style formatting is altered.

I have added / removed lines at the end of the table.
Comment 1 raal 2015-06-07 19:39:28 UTC
Created attachment 116358 [details]
printscreen

I can confirm with Version: 5.1.0.0.alpha1+
Build ID: eb8c323d94bf13d4a373f88c6b932a97701c283b
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2015-06-05_00:59:00
Comment 2 raal 2015-06-07 19:40:43 UTC
works OK in LO 4.3.7, regression
Comment 3 raal 2015-06-07 19:41:44 UTC
(In reply to raal from comment #1)
> Created attachment 116358 [details]
> printscreen
> 
> I can confirm with Version: 5.1.0.0.alpha1+
> Build ID: eb8c323d94bf13d4a373f88c6b932a97701c283b
> TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time:
> 2015-06-05_00:59:00

Reproduced with copy+paste
Comment 4 raal 2015-10-19 08:09:10 UTC
This seems to have begun at the below commit.
Adding Cc: to sbergman@redhat.com ; Could you possibly take a look at this one? Thanks

193ccffc25300d5c26e6f30ab06a2315b6bff879 is the first bad commit
commit 193ccffc25300d5c26e6f30ab06a2315b6bff879
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Sat Jul 11 20:21:02 2015 -0700

    source sha:c725ebaced006c02baeb9b0ee5ac6ac4625adc01

    source sha:c725ebaced006c02baeb9b0ee5ac6ac4625adc01

	author	Stephan Bergmann <sbergman@redhat.com>	2015-05-28 21:21:10 (GMT)
committer	Stephan Bergmann <sbergman@redhat.com>	2015-05-28 21:21:10 (GMT)
commit	c725ebaced006c02baeb9b0ee5ac6ac4625adc01 (patch)
Comment 5 Stephan Bergmann 2015-10-19 08:15:34 UTC
(In reply to raal from comment #4)
> This seems to have begun at the below commit.
> Adding Cc: to sbergman@redhat.com ; Could you possibly take a look at this
> one? Thanks
> 
> 193ccffc25300d5c26e6f30ab06a2315b6bff879 is the first bad commit
> commit 193ccffc25300d5c26e6f30ab06a2315b6bff879
> Author: Norbert Thiebaud <nthiebaud@gmail.com>
> Date:   Sat Jul 11 20:21:02 2015 -0700
> 
>     source sha:c725ebaced006c02baeb9b0ee5ac6ac4625adc01
> 
>     source sha:c725ebaced006c02baeb9b0ee5ac6ac4625adc01
> 
> 	author	Stephan Bergmann <sbergman@redhat.com>	2015-05-28 21:21:10 (GMT)
> committer	Stephan Bergmann <sbergman@redhat.com>	2015-05-28 21:21:10 (GMT)
> commit	c725ebaced006c02baeb9b0ee5ac6ac4625adc01 (patch)

raal, please provide either the commit message of the (last good) commit in the bibisect repo directly preceding this commit, or at least the URL of the bibisect repo (so I can determine that preceding commit myself).  (Individual commits in bibisect repos often correspond to a range of source commits, so it is always important to know that full range.)
Comment 6 raal 2015-10-19 08:23:49 UTC
(In reply to Stephan Bergmann from comment #5)
bibisect-win32-5.1

git bisect log
# bad: [d07ec272f151832493f57ce3fde37a429eaf6014] source sha:233b9b0ec95069b5ce98aab942304459ca7344a8
# good: [c1efd324c6ad448ac9edb030dc9738b9e6899e4d] source sha:ab465b90f6c6da5595393a0ba73f33a1e71a2b65
git bisect start 'd07ec272f151832493f57ce3fde37a429eaf6014' 'c1efd324c6ad448ac9edb030dc9738b9e6899e4d'
# bad: [75b0ef076d724d10ed74681ba542db53f088b4ca] source sha:6dddd1aaf5dd3c54aaf87222712c9147466056f6
git bisect bad 75b0ef076d724d10ed74681ba542db53f088b4ca
# bad: [7f6e13f8050660b9e6ff832b34e0a3f5c1f1a38d] source sha:b998be6e42eeb57abf5131adc06aa45588542f62
git bisect bad 7f6e13f8050660b9e6ff832b34e0a3f5c1f1a38d
# bad: [8a6b9507b0337ce070b2900f111fc3e947396a6a] source sha:970458c5ee4e6077836839397e556132544a3b6e
git bisect bad 8a6b9507b0337ce070b2900f111fc3e947396a6a
# bad: [ba88e179a3e86e459cfc4d15f78a4ffee7294656] source sha:9ce71b67f705ccbc6df327d1bb181ca20b3ed17f
git bisect bad ba88e179a3e86e459cfc4d15f78a4ffee7294656
# good: [98f041edb433e0a07778c5f32af45d7c5be8a456] source sha:3185b6c8caf97afa602c864f588d079cbbe04038
git bisect good 98f041edb433e0a07778c5f32af45d7c5be8a456
# good: [ff59691aca3a1607445fcdb7ccd8b6640254552e] source sha:cc7b8dab7522886f13780950c93033e3369da285
git bisect good ff59691aca3a1607445fcdb7ccd8b6640254552e
# good: [e390804b0626adbb3df1da437d2124f62b017674] source sha:39f3039724f3933963f861f4afc24a92348eb991
git bisect good e390804b0626adbb3df1da437d2124f62b017674
# good: [c23c4d2e2c6ea524463f5be38b071dede1da0e5a] source sha:82f15336cfbcb766c060c4936d11ff33c54558e4
git bisect good c23c4d2e2c6ea524463f5be38b071dede1da0e5a
# bad: [193ccffc25300d5c26e6f30ab06a2315b6bff879] source sha:c725ebaced006c02baeb9b0ee5ac6ac4625adc01
git bisect bad 193ccffc25300d5c26e6f30ab06a2315b6bff879
# good: [cf5afac9e3bcb4c0b9c5b7468b223ce0b13c0588] source sha:9d6f44ccdd5eed7dd9f1a21612be3eca01aeb429
git bisect good cf5afac9e3bcb4c0b9c5b7468b223ce0b13c0588
# good: [95e1e9454be99fdd9c4755ebd7177a07a6e5ac67] source sha:53a066b7d1a639c6d31655bfc7c6257896fb57ef
git bisect good 95e1e9454be99fdd9c4755ebd7177a07a6e5ac67
# good: [ee6ec68bde95dad4a5d07580a4e5b745e3a03935] source sha:e17fa49d99ce8de3fb9d026b515a7c7e1f00d269
git bisect good ee6ec68bde95dad4a5d07580a4e5b745e3a03935
# first bad commit: [193ccffc25300d5c26e6f30ab06a2315b6bff879] source sha:c725ebaced006c02baeb9b0ee5ac6ac4625adc01
Comment 7 Stephan Bergmann 2015-10-19 08:57:10 UTC
sorry, I'm not looking for the output of "git bisect log" but of either "git log -1 193ccffc25300d5c26e6f30ab06a2315b6bff879^" or at least "cat .git/config"
Comment 8 raal 2015-10-19 09:00:03 UTC
(In reply to Stephan Bergmann from comment #7)
> sorry, I'm not looking for the output of "git bisect log" but of either "git
> log -1 193ccffc25300d5c26e6f30ab06a2315b6bff879^" or at least "cat
> .git/config"

 git log -1 193ccffc25300d5c26e6f30ab06a2315b6bff879^
commit ee6ec68bde95dad4a5d07580a4e5b745e3a03935
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Sat Jul 11 20:15:41 2015 -0700

    source sha:e17fa49d99ce8de3fb9d026b515a7c7e1f00d269

    source sha:e17fa49d99ce8de3fb9d026b515a7c7e1f00d269

 cat .git/config
[core]
        repositoryformatversion = 0
        filemode = false
        bare = false
        logallrefupdates = true
        symlinks = false
        ignorecase = true
        hideDotFiles = dotGitOnly
[remote "origin"]
        url = git://gerrit.libreoffice.org/bibisect-win32-5.1
        fetch = +refs/heads/*:refs/remotes/origin/*
[branch "master"]
        remote = origin
        merge = refs/heads/master
Comment 9 Stephan Bergmann 2015-10-19 09:23:19 UTC
> $ git log --oneline e17fa49d99ce8de3fb9d026b515a7c7e1f00d269..c725ebaced006c02baeb9b0ee5ac6ac4625adc01
> c725eba brown paper bag

So that bibisect repo commit indeed corresponds to exactly that one source commit.  But it looks suspicious that that Writer-specific fix (of a problem introduced a few commits earlier) should be related to this issue in Impress.
Comment 10 Stephan Bergmann 2015-10-20 06:48:58 UTC
I cannot reproduce this with my own recent master (64 bit) build for Windows.  Please describe exactly the steps how to reproduce.
Comment 11 raal 2015-10-20 09:23:41 UTC
(In reply to Stephan Bergmann from comment #10)
> I cannot reproduce this with my own recent master (64 bit) build for
> Windows.  Please describe exactly the steps how to reproduce.

new impress document
insert table
write some string into the cell
set font italic
select string
ctrl+c
select another cell
ctrl+v

pasted string is not italic
Comment 12 Stephan Bergmann 2015-10-20 11:44:05 UTC
No, I still cannot reproduce (on a Win 7 box), even with the mentioned bibisect repo commit:

> $ git clone git://gerrit.libreoffice.org/bibisect-win32-5.1
> $ cd bibisect-win32-5.1
> $ git checkout 193ccffc25300d5c26e6f30ab06a2315b6bff879
> $ instdir/program/soffice.exe --impress

* select "Insert - Table..."
* select "OK"
* click into first column, first row
* type "foo"
* press Ctrl-A
* press Ctrl-I, "foo" is now italic
* press Ctrl-C
* click into second column, second row
* press Ctrl-V, italic "foo" is inserted
Comment 13 raal 2015-10-21 10:33:36 UTC
Hello Philippe,
please could you test it with dev version? You can download it here: 
http://dev-builds.libreoffice.org/daily/master/
Thank you
Comment 14 Robinson Tryon (qubit) 2015-12-13 11:13:23 UTC Comment hidden (obsolete)
Comment 15 QA Administrators 2017-01-03 19:51:12 UTC Comment hidden (obsolete)
Comment 16 Timur 2017-10-04 17:19:36 UTC
Needinfo more that 6 months and his is not progressing. 
No repro for Stephan and me. Thanks to Raal but steps are not reproducible. There must be something else that affects that "sometimes". Philippe also didn't respond.