Bug Hunting Session
Bug 91973 - "Outliner" function could be added by one-button click to make "text body" invisible
Summary: "Outliner" function could be added by one-button click to make "text body" in...
Status: RESOLVED DUPLICATE of bug 54772
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks:
 
Reported: 2015-06-09 19:34 UTC by Susan Cragin
Modified: 2016-10-06 07:30 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Susan Cragin 2015-06-09 19:34:37 UTC
There has been a lot of discussion (sometimes rancorous) about the need to have an intrinsic outline function in libreoffice. The model given is M$ Word.

Well, a basic intrinsic outliner could be accomplished with a single button-click. 

Here's how. 

Make a toggle command button that does NOTHING but change the properties of "Text Body" from "visible" to "invisible." 
Then, make that toggle able to be user-pinned to a keystroke. 

I get my intrinsic outline right now by going into Styles & Formatting / Text Body / Modify / Font Effects / and then check "Hidden." That hides my text and leaves my outlining alone. 

I would LOVE if I could make any style invisible with a keyclick. But I would settle for just Text Body. 

IF YOU WANT TO MAKE IT EVEN BETTER:

So let's say I have 8 active styles. I'd hide Text Body with a keyclick, and then I could hide Style 8 with another keyclick? Fantastic! Then Style 7, and so on up the food chain.
Comment 1 Buovjaga 2015-07-02 10:15:02 UTC
Let's ask for UX advice.
Comment 2 Cor Nouws 2015-07-07 09:47:48 UTC
I would suggest to mark this as duplicate of one of the outliner issues. And add the idea as suggestion there.
Comment 3 Robinson Tryon (qubit) 2016-08-25 05:39:17 UTC Comment hidden (obsolete)
Comment 4 Heiko Tietze 2016-10-06 07:30:44 UTC
Sounds reasonable. I would recommend to implement it somehow similar to layers, the proposal can be found here https://design.blog.documentfoundation.org/2016/07/31/how-the-navigator-may-support-object-handling-in-libreoffice-draw/

Closing this ticket as duplicate of the classic 54772'er ticket.

*** This bug has been marked as a duplicate of bug 54772 ***