Bug 91990 - StartCenter: adjust Help and Extension buttons to use same UI when hoovering mouse so UI experience is unified and consistent (comment 12)
Summary: StartCenter: adjust Help and Extension buttons to use same UI when hoovering ...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 97701 (view as bug list)
Depends on:
Blocks: Start-Center
  Show dependency treegraph
 
Reported: 2015-06-10 19:55 UTC by steve -_-
Modified: 2017-12-18 11:26 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
LO nightly as is (44.99 KB, image/jpeg)
2015-06-10 19:55 UTC, steve -_-
Details
LO mockup planned (43.63 KB, image/jpeg)
2015-06-10 19:56 UTC, steve -_-
Details
screencast for suggestion (359.54 KB, video/mp4)
2015-10-25 14:39 UTC, steve -_-
Details
The LibreOffice StartCenter as initially implemented by TDF (49.48 KB, image/png)
2015-10-25 16:25 UTC, V Stuart Foote
Details

Note You need to log in before you can comment on or make changes to this bug.
Description steve -_- 2015-06-10 19:55:47 UTC
Created attachment 116444 [details]
LO nightly as is

In the start center "Help" and "Extensions" stick out by being buttons. We should convert those so those two items match the rest of the left side panel items.

Screenshot of current nightly (still with the 2 items as buttons)
and screenshot of mockup, which should explain what is described in this bug here.
Comment 1 steve -_- 2015-06-10 19:56:08 UTC
Created attachment 116445 [details]
LO mockup planned
Comment 2 andreas_k 2015-06-10 20:27:04 UTC
galaxy also have info_26 and extension icon so it would work there too.
Comment 3 Yousuf Philips (jay) (retired) 2015-06-10 21:03:02 UTC
I dont think help and extensions need to be any bigger than they are, as they are not crucial components of the start center. Personally i'd recommend removing them as they are not highly utilized features. Help was removed from the toolbar as there is already a dedicated Help menu bar item.
Comment 4 Adolfo Jayme 2015-06-10 23:02:12 UTC
Not a fan of this proposal, TBH.

(In reply to Yousuf (Jay) Philips from comment #3)
> I dont think help and extensions need to be any bigger than they are, as
> they are not crucial components of the start center.

+1 to not making them bigger, but would not remove them right now.
Comment 5 steve -_- 2015-06-11 07:43:15 UTC
Actually agree with Yousuf on this. Both items don't add much value to the start center. The start center is about getting the user started by showing nice templates or the last used documents. So actually I'd +1 for a removal of both items.

Adolfo: Either way, should we keep those 2 items as is, then there's still the problem, that when you hoover over one of them, the user sees a button (which was not there when not hoovering. That is very odd behavior and those two items should behave consistently with the other items in the left side panel. Meaning: they should not convert to a button suddenly, once you hoover but change their background color as the other items do when the mouse if hoovered over them.
Comment 6 Jean-Baptiste Faure 2015-06-11 14:21:20 UTC
(In reply to Yousuf (Jay) Philips from comment #3)
> Personally i'd
> recommend removing them as they are not highly utilized features.

They were added to the StartCenter exactly for this reason. Many users are not aware that there is a help in LibreOffice and that it is possible to add features by installing extensions. Having big buttons under their eyes may help here.

Best regards. JBF
Comment 7 Yousuf Philips (jay) (retired) 2015-06-11 15:31:46 UTC
(In reply to Jean-Baptiste Faure from comment #6)
> They were added to the StartCenter exactly for this reason. Many users are
> not aware that there is a help in LibreOffice and that it is possible to add
> features by installing extensions.

It baffles me that people would claim that they are not aware that there is a help, when most applications have help. We also have a dedicated Help menu bar entry and until 4.3, we also had a dedicated button in the toolbar for help, though more people used the menu bar entry than the toolbar button. Only a particular level of user will ever install extensions, as the process isnt very simple.

> Having big buttons under their eyes may help here.

Doubt it will help if they havent seen the permanent Help menu at the top and also when the Start Center isnt frequently seen, except on Mac.
Comment 8 V Stuart Foote 2015-06-11 17:07:29 UTC
When the StartCenter was reworked into .UI the Get Templates, Get Features/Extensions and Help/Info icons dating back to OOo were all reimplemented as GTK+ buttons with text lables, exactly the same as the component launchers.

The Help and Extensions GTK+ buttons simply never received an icon while the Get Templates action was merged into the template manager. And of course positioning on the SC tabbar evolved with the design. 

But other than lacking the icon and being sized a bit smaller--they are exactly the same GTK+ .UI layout as all the other "buttons" in the UI--they all render and function within the GUI the same.

There has been some discussion over the months that the Help/Info button should open the Wiki Help, while the Menu's Help -> LibreOffice Help would open the local downloaded instance. But for now they both open the local help, if installed, and should open the same Wiki Help if not--but that does goes wonky from build to build.

Point to all of that, is that where we are now in the GUI design is not arbitrary--removing it would be. And the Get Extension function would still have to go somewhere. Retaining it on the StartCenter panel was evolutionary, adjacent to the Info/Help/About button. But if not there, then perhaps up to the Main Menu -> Help
Comment 9 Yousuf Philips (jay) (retired) 2015-06-11 23:07:18 UTC
(In reply to V Stuart Foote from comment #8)
> Point to all of that, is that where we are now in the GUI design is not
> arbitrary--removing it would be. And the Get Extension function would still
> have to go somewhere. Retaining it on the StartCenter panel was
> evolutionary, adjacent to the Info/Help/About button. But if not there, then
> perhaps up to the Main Menu -> Help

Extension Manager is in the Tools menu of the start center and its weird that the extension button would link to the website rather than opening the extension manager dialog, but i guess thats just because of the evolution.
Comment 10 Jean-Baptiste Faure 2015-06-12 04:29:39 UTC
(In reply to Yousuf (Jay) Philips from comment #9)
> [...]
> Extension Manager is in the Tools menu of the start center and its weird
> that the extension button would link to the website rather than opening the
> extension manager dialog, but i guess thats just because of the evolution.

It was done deliberately to make [new] users aware of the extensions website.

Best regards. JBF
Comment 11 steve -_- 2015-06-23 10:54:01 UTC
JBF: Since the extensions website is but ready for prime time, I am not sure I do agree with that change and the thought process behind it.
Comment 12 steve -_- 2015-10-25 14:39:10 UTC
Trying to update: Help and extension don't have an icon so we'll stick to buttons.

Fine, but I really don't understand why the UI we use to show those two options differs from the way the other selection options are shown. Let's unify that and show help and extension in the same way.

screencast attached to illustrate the suggestion.
Comment 13 steve -_- 2015-10-25 14:39:35 UTC
Created attachment 119942 [details]
screencast for suggestion
Comment 14 Yousuf Philips (jay) (retired) 2015-10-25 15:17:41 UTC
With the new theming introduced in 5.0, this problem is solved for me on linux, though from steve's screencast, it seems that the height of the buttons isnt the same on osx as it is on linux.
Comment 15 V Stuart Foote 2015-10-25 16:25:42 UTC
Created attachment 119943 [details]
The LibreOffice StartCenter as initially implemented by TDF

(In reply to steve -_- from comment #12)
> ... but I really don't understand why the UI we use to show those two
> options differs from the way the other selection options are shown. Let's
> unify that and show help and extension in the same way.

That would be incorrect as within our GUI we make, and have always made, distinction in functional use. We identify, and graphically represent, Primary actions as compared to Secondary actions within the GUI using icon/button size and positional placement of elements.

Current handling in the GTKwidget .UI based StartCenter descends from our legacy SO/OOo functional design of the StartCenter as can be seen in the screen clip from the LO 3.3.0.4 release. There the indicated area holds secondary action buttons to:
Get more templates
Add new features 
Get more information

Note the size of the icons and that their position is removed from the Primary elements.

As the StartCenter was moved to .UI based GTK widget packing, while reworking it we continued to distinguish a secondary role for the Help | Extensions button widgets. Also, we don't assign a GtkImage for an icon--and instead just label the buttons--maintaining their secondary role in the GUI.

Implementing Thumbnail Views from Template manager backingwindow as a way to render a preview of the document in the StartCenter has provided a new Primary action, but the functional GUI remains conceptually unchanged.  Other than that--our handling of the StartCenter and its functional roles has evolved in a consistent fashion--respectful of legacy design, despite being completely refactored in code.

I understand your suggestion, but don't see it as necessary during usage to "interpreting" the GUI.  If anything making the change suggested--bringing all Start Center widget actions into the same vertical "button bar"  would be confusing for users.

Re-sizing and adjusting the packing of the button widgets to place Help and Extensions as equal in importance to the other Create buttons would give them emphasis in usage they do not merit.

Yes, they are necessary to the completeness of the GUI, and so should not be removed--but they are not functionally equivalent in importance to the other GUI elements on the StartCenter.  Their diminutive size, lack of icon, and positioning apart are appropriate to the UX.
Comment 16 steve -_- 2015-11-02 21:21:11 UTC
So what is what? Selecting a component is primary or secondary? Selecting Help or Extension is primary or secondary?

And once that is clarified what makes them primary or secondary?

A wild guess: Help and extension open external windows, thus does that make them secondary? So the logic is, that anything that looks like a button shape, goes to an external window?

I do not know the screen clip from the (very old) 3.3.0.4 release.

Hmm, evolved or not, for me, I still believe things would be consistent if all options on the left side panel would look the same. We could now dive deeper and look into apple design guidelines. A wild guess would be that neither primary nor secondary do apply to any of that.

    "If anything making the change suggested--bringing all
Start Center widget actions into the same vertical "button bar"  would be
confusing for users."

Why?

    "Re-sizing and adjusting the packing of the button widgets to place Help and
Extensions as equal in importance to the other Create buttons would give them
emphasis in usage they do not merit."

Agreed. I am fine with the current location, yet find it confusing that a few things are buttons and other things are some custom non transparent hoovering effect.


Stuart, I agree on size, location and keeping those two items. I still disagree with making those two items differ in UI. I am not sure I understand the concept of primary and secondary and would love to hear examples where this concept can be found in e.g. Pages.
Comment 17 Buovjaga 2016-02-12 09:17:23 UTC
*** Bug 97701 has been marked as a duplicate of this bug. ***
Comment 18 Robinson Tryon (qubit) 2016-08-25 05:49:18 UTC Comment hidden (obsolete)
Comment 19 Heiko Tietze 2017-12-18 11:26:40 UTC
While I agree with the idea to keep the UI clean and also think that placing rarely used buttons at a prominent position isn't a good idea to promote the function, the overall opinion is to keep things as they are. Stuart's evolutionary argument is striking to me, and the buttons are not too obtrusive. => WFM


Remark: The better advertising of extensions is to have them directly where needed https://design.blog.documentfoundation.org/2016/11/11/additions-to-libreoffice/