Bug 92028 - Graphic Export dialog doesn’t use GtkScale
Summary: Graphic Export dialog doesn’t use GtkScale
Status: RESOLVED DUPLICATE of bug 59570
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsDevEval, topicUI
Depends on:
Blocks:
 
Reported: 2015-06-12 09:04 UTC by Adolfo Jayme
Modified: 2016-07-10 23:18 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of affected dialog (39.46 KB, image/png)
2015-06-12 09:04 UTC, Adolfo Jayme
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Adolfo Jayme 2015-06-12 09:04:00 UTC
Created attachment 116482 [details]
Screenshot of affected dialog

Until support for a proper slider widget was added [1] by Tomaž into LibreOffice (thanks a lot!), OOo has tried to emulate this widget by creating a weird scrollbar that doesn’t control any surface. This is evident in Impress’ Graphic Export dialog (depicted in the attachment, corresponding .ui is svtools/uiconfig/ui/graphicexport.ui), which can be summoned in File > Export… > [select an image format for export] > OK.

The incorrect scrollbar should be replaced by a proper slider, as used in [2].

[1]: http://cgit.freedesktop.org/libreoffice/core/commit/?id=c63497472b6b7406a07840ec312ccebe6154bb86
[2]: http://cgit.freedesktop.org/libreoffice/core/commit/?id=a39a4c750171e77266391c419fcc0acc67028571
Comment 1 Robinson Tryon (qubit) 2015-12-13 11:23:48 UTC
Migrating Whiteboard tags to Keywords: (needsDevEval, topicUI)
[NinjaEdit]
Comment 2 Adolfo Jayme 2016-07-10 23:18:15 UTC

*** This bug has been marked as a duplicate of bug 59570 ***