Bug 92062 - Crash When Click a 'New Theme...'/Gallery at Sidebar
Summary: Crash When Click a 'New Theme...'/Gallery at Sidebar
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.4.4.3 release
Hardware: Other Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: haveBacktrace
Depends on:
Blocks:
 
Reported: 2015-06-14 09:00 UTC by baffclan
Modified: 2016-05-13 12:26 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Backtrace of crash on Windows (5.49 KB, text/plain)
2015-06-16 09:15 UTC, Buovjaga
Details

Note You need to log in before you can comment on or make changes to this bug.
Description baffclan 2015-06-14 09:00:01 UTC
Steps to Reproduce:
1. Set a KeyID UI, and restart LibO
2. New Writer(or Calc, Impress, Draw)
3. Open Sidebar
4. Open Gallery Dock
5. Click [Gqz7r||New Theme...]
6. Crash a LibO


Windows 7 Pro (x64)
Version: 5.1.0.0.alpha1+
Build ID: ad84b40b084cb6c6c129c687303fb863b8b3f746
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-06-13_23:31:03
Locale: ja-JP (ja_JP)

I install UIs, en-US, Ja, KeyID.
Can reproduce KeyID.
Cannot reproduce en-US and ja.
Comment 1 Julien Nabet 2015-06-14 12:23:51 UTC
Just for the record, on pc Debian x86-64 with master sources updated today, I don't reproduce this.
Comment 2 Buovjaga 2015-06-16 09:15:11 UTC
Created attachment 116576 [details]
Backtrace of crash on Windows

Crashed successfully.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: 80ec99db4325a439a8a3f1d420d0a80f8bf9c439
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-06-16_00:00:20
Locale: fi-FI (fi_FI)
Comment 3 Julien Nabet 2015-06-16 09:33:19 UTC
Windows only bug for the moment.
Comment 4 krajcsi 2015-06-27 16:47:03 UTC
I can reproduce this on Linux Mint 17.1, and LO 4.4.

Version: 4.4.4.3
Build ID: 2c39ebcf046445232b798108aa8a7e7d89552ea8
Locale: en_US.UTF-8
Comment 5 Buovjaga 2015-07-08 09:05:46 UTC
(In reply to krajcsi from comment #4)
> I can reproduce this on Linux Mint 17.1, and LO 4.4.
> 
> Version: 4.4.4.3
> Build ID: 2c39ebcf046445232b798108aa8a7e7d89552ea8
> Locale: en_US.UTF-8

How did you manage to install KeyID for 4.4?
I could not figure out how to do it for 4.4 in Ubuntu and the steps didn't crash for me.

Ubuntu 15.04 64-bit 
Version: 4.4.4.3
Build ID: 40m0(Build:3)
Locale: en_US.UTF-8
Comment 6 Buovjaga 2015-07-08 09:58:11 UTC
Ok, Sophie clued me into this: http://downloadarchive.documentfoundation.org/libreoffice/old/4.4.0.0.beta2/deb/x86_64/LibreOfficeDev_4.4.0.0.beta2_Linux_x86-64_deb_langpack_qtz.tar.gz

I managed to reproduce the crash, clicking New theme and canceling. Yet, the Writer interface with KeyID went totally bonkers, changing vertical size constantly, up and down like a madman. The craziness does not manifest yet in the start center.

Here's how I did it, following https://wiki.documentfoundation.org/Installing_in_parallel/Linux
Untarred the pack with tar -vxzf
Created a folder install inside DEBS
Then inside it: for i in ../*.deb; do dpkg-deb -x $i . ; done
Then went inside install/opt/libreofficedev4.4
Then did: sudo cp -R * /usr/lib/libreoffice

Ubuntu 15.04 64-bit 
Version: 4.4.4.3
Build ID: 40m0(Build:3)
Locale: en_US.UTF-8
Comment 7 baffclan 2016-05-01 00:36:56 UTC
Cannot reproduce with 5.2.0.0.alpha0+.

Windows 7 Pro (x64)
Version: 5.2.0.0.alpha0+ (x64)
Build ID: e8425c48102321d4f5a8bd687c8ca1ac7bae797e
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86_64@62-TDF, Branch:MASTER, Time: 2016-04-20_16:47:56
Locale: ja-JP (ja_JP)
Comment 8 baffclan 2016-05-13 12:26:32 UTC
Cannot reproduce with 5.2.0.0.alpha1+.

Windows 7 Pro (x64)
Version: 5.2.0.0.alpha1+
Build ID: 96d5516429bc1846fc6cf7119590f7b05a65eef8
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2016-05-13_10:19:17
Locale: ja-JP (ja_JP)

-> WORKSFORME