Bug 92079 - Basic Dialog image background not set
Summary: Basic Dialog image background not set
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: BASIC (show other bugs)
Version:
(earliest affected)
5.0.0.0.alpha0+ Master
Hardware: Other All
: medium normal
Assignee: Miklos Vajna
URL:
Whiteboard: target:6.4.0 target:6.3.0.1 target:6.2.5
Keywords: bibisected, bisected, regression
Depends on:
Blocks: RenderContext
  Show dependency treegraph
 
Reported: 2015-06-15 07:20 UTC by Laurent Godard
Modified: 2019-06-14 13:07 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
sample document with macro to reproduce (11.95 KB, application/vnd.oasis.opendocument.spreadsheet)
2015-06-17 07:53 UTC, Laurent Godard
Details
the png file to be in same directory than ods file (3.52 KB, image/png)
2015-06-17 07:54 UTC, Laurent Godard
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Laurent Godard 2015-06-15 07:20:43 UTC
inside an extension, a Dialog can't load a PNG file as background anymore
the background remains gray. No error message

bibisect
--------


3b96cd1325722d6dd24754150a1e7446adaa3ffc is the first bad commit
commit 3b96cd1325722d6dd24754150a1e7446adaa3ffc
Author: Matthew Francis <mjay.francis@gmail.com>
Date:   Wed May 27 23:14:39 2015 +0800

    source-hash-e5bb5c52aeaeb60c8592b004efd88c30242e03a1
    
    commit e5bb5c52aeaeb60c8592b004efd88c30242e03a1
    Author:     Tomaž Vajngerl <tomaz.vajngerl@collabora.co.uk>
    AuthorDate: Mon May 18 11:20:48 2015 +0900
    Commit:     Tomaž Vajngerl <tomaz.vajngerl@collabora.co.uk>
    CommitDate: Mon May 18 11:22:50 2015 +0900
    
        add RenderContext to Window::PushPaintHelper, use Erase correctly
    
        Change-Id: Icc684a2dcfb4d92752b09768e5a908636910f302

bisect log
----------
$ git bisect log
# bad: [dda106fd616b7c0b8dc2370f6f1184501b01a49e] source-hash-0db96caf0fcce09b87621c11b584a6d81cc7df86
# good: [5b9dd620df316345477f0b6e6c9ed8ada7b6c091] source-hash-2851ce5afd0f37764cbbc2c2a9a63c7adc844311
git bisect start 'latest' 'oldest'
# good: [0c30a2c797b249d0cd804cb71554946e2276b557] source-hash-45aaec8206182c16025cbcb20651ddbdf558b95d
git bisect good 0c30a2c797b249d0cd804cb71554946e2276b557
# good: [2ce02b2ce56f12b9fcb9efbd380596975a3a5686] source-hash-17d714eef491bda2512ba8012e5b3067ca19a5be
git bisect good 2ce02b2ce56f12b9fcb9efbd380596975a3a5686
# good: [40875247f0002056effdf6d2fbe43627691cd86c] source-hash-93f0b14458a618ad575cd446680e5c4aa7d87bdc
git bisect good 40875247f0002056effdf6d2fbe43627691cd86c
# skip: [61f66b1a251477193d796411ca95f50d606ead45] source-hash-3fd5f8919ec2256c70ff26c14cb9f8065c5cb2f1
git bisect skip 61f66b1a251477193d796411ca95f50d606ead45
# good: [e7374cd735af2344dae55be40946d96633d2f6ee] source-hash-8a91528a3e03fe6e2923c33327b687ecf57adb0b
git bisect good e7374cd735af2344dae55be40946d96633d2f6ee
# good: [541837707e7b0c5f5335180de535043c43e78e8d] source-hash-0811de12ee6727bbb9d4265217833ba02301eed8
git bisect good 541837707e7b0c5f5335180de535043c43e78e8d
# good: [ab7dc1f0829167681894eb9f833d7ab348d91669] source-hash-e27ee95cced755e52b62d6cb095bc911ca3fbbe6
git bisect good ab7dc1f0829167681894eb9f833d7ab348d91669
# bad: [03ebd7e7d3aea3e4988648fe964aebe8e53f6bcc] source-hash-867ccbc19b419e688c81485257371e2681a7775a
git bisect bad 03ebd7e7d3aea3e4988648fe964aebe8e53f6bcc
# bad: [c22b5b4cae1e3054dd10689471bf8b29138c29bd] source-hash-3ccacb47faa625563f8bf0af8d4c62c1eea6ce7c
git bisect bad c22b5b4cae1e3054dd10689471bf8b29138c29bd
# bad: [98bf0dc108775209e7644ad47f331265ec65561a] source-hash-7092c767b54df65e64b6059a531de4950c1a3b92
git bisect bad 98bf0dc108775209e7644ad47f331265ec65561a
# bad: [b7e7b5be3a3388acbf10d0792359dcdb786ff732] source-hash-6896712f9e5c8005d0c7e4f6ab403a271d9586f7
git bisect bad b7e7b5be3a3388acbf10d0792359dcdb786ff732
# bad: [c798020710143a2d371025241043612db5251e1c] source-hash-3aebc670e1816a8f4f0759e97d8f39b6aab05044
git bisect bad c798020710143a2d371025241043612db5251e1c
# bad: [3b96cd1325722d6dd24754150a1e7446adaa3ffc] source-hash-e5bb5c52aeaeb60c8592b004efd88c30242e03a1
git bisect bad 3b96cd1325722d6dd24754150a1e7446adaa3ffc
# good: [14dd520bd2177e0af5ef0b2b97a281b161b279b7] source-hash-6fa87f3fde8316fe1e4c35d1dd5132dbd7d7d903
git bisect good 14dd520bd2177e0af5ef0b2b97a281b161b279b7
# good: [ba1284cee0c8a13810eb19284999f710116b3499] source-hash-6656e915c8e0348dcaeedb40a68ba308e174960b
git bisect good ba1284cee0c8a13810eb19284999f710116b3499
# first bad commit: [3b96cd1325722d6dd24754150a1e7446adaa3ffc] source-hash-e5bb5c52aeaeb60c8592b004efd88c30242e03a1
Comment 1 Tomaz Vajngerl 2015-06-17 06:55:06 UTC
How do you set the image as the background in a extension?
Comment 2 Laurent Godard 2015-06-17 07:07:13 UTC
in myDialog.xdl deployed within the extension
sets the dlg:image-src attribute

example

<dlg:window xmlns:dlg="http://openoffice.org/2000/dialog" xmlns:script="http://openoffice.org/2000/script" dlg:id="MydlgId" dlg:left="189" dlg:top="69" dlg:width="225" dlg:height="274" dlg:closeable="true" dlg:moveable="true" dlg:title="MyTitle" dlg:image-src="file:///the/path/to/deployed/extension//user/uno_packages/cache/uno_packages/3lymwT_/myExtension.oxt/icons/splashMouette.png">
Comment 3 Laurent Godard 2015-06-17 07:21:17 UTC
sorry previous answer is wrong
it is set by code, not through xdl file

	urlImage = convertToURL(getExtensionPath() + "icons/MyImage.png")
	oDlg.model.imageURL = urlImage
Comment 4 Laurent Godard 2015-06-17 07:53:58 UTC
Created attachment 116599 [details]
sample document with macro to reproduce

needs the png file in the same directory
Comment 5 Laurent Godard 2015-06-17 07:54:31 UTC
Created attachment 116601 [details]
the png file to be in same directory than ods file
Comment 6 Cor Nouws 2015-07-07 09:17:04 UTC
I confirm that in 5.0.0.3 no background image is shown
Comment 7 Björn Michaelsen 2015-08-29 08:49:46 UTC
As per description this seems to be bibisected down to a RenderContext change, thus blocking on the tracker issue.
Comment 8 Laurent Godard 2015-09-03 08:14:28 UTC
if of any help

if background is set to a color as
oDlg.model.BackgroundColor = rgb(0,255,0)

--> it works
Comment 9 Laurent Godard 2015-09-03 09:03:57 UTC
if of any help

using a picto control

	ctrlImg = oDlg.getControl("ImageControl1")
	ctrlImg.model.imageURL = urlImage

--> it works
--> so the problem is bounded to dialogControl background

Moreover, the
oDlg.model.imageURL property is correctly set (even after endExecute)
Comment 10 Robinson Tryon (qubit) 2015-12-13 11:13:19 UTC Comment hidden (obsolete)
Comment 11 Xisco Faulí 2016-09-26 15:09:40 UTC
Adding Cc: to Tomaž Vajngerl
Comment 12 QA Administrators 2018-05-02 02:32:51 UTC Comment hidden (obsolete)
Comment 13 Laurent Godard 2018-05-02 08:46:20 UTC
still reproduced in

Version: 6.0.4.1
Build ID: 1:6.0.4~rc1-4
Threads CPU : 8; OS : Linux 4.15; UI Render : par défaut; VCL: gtk3; 
Locale : fr-FR (fr_FR.UTF-8); Calc: group
Comment 14 QA Administrators 2019-05-03 02:51:59 UTC Comment hidden (obsolete)
Comment 15 Commit Notification 2019-06-13 19:51:07 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/f4e0cc1ff145287f80738f070a8c46a64b2f76d1%5E%21

tdf#92079 vcl: fix missing image background on dialog from basic

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 Commit Notification 2019-06-14 09:31:34 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/+/4046b51e6f6bd31b0188d9c00273a1761254a9d6%5E%21

tdf#92079 vcl: fix missing image background on dialog from basic

It will be available in 6.3.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 17 Xisco Faulí 2019-06-14 09:37:47 UTC
Verified in

Version: 6.4.0.0.alpha0+
Build ID: af37bb23f63b209af1193e20177c3aacbd777543
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Miklos, thanks for fixing this issue!!
Comment 18 Commit Notification 2019-06-14 13:07:34 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/1fd61b1a2aac3e52f3c0a0ab8fbd3ff5170713c3%5E%21

tdf#92079 vcl: fix missing image background on dialog from basic

It will be available in 6.2.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.