Bug 92096 - Pasting copied web page produces weird document
Summary: Pasting copied web page produces weird document
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-06-15 19:39 UTC by Kalkulator
Modified: 2019-12-09 17:45 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
generated doc that is wrong (152.31 KB, application/vnd.oasis.opendocument.text)
2015-06-15 19:39 UTC, Kalkulator
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kalkulator 2015-06-15 19:39:55 UTC
Created attachment 116566 [details]
generated doc that is wrong

Go to this website and select the main frame entirely.

Paste it to writer. Weird stuff in generated. Online Microsoft Office gets it right.
Comment 1 Buovjaga 2015-06-17 08:31:05 UTC
Don't know, if this can be considered a bug, but let's set to NEW anyways.
"This" website means: http://www.bike-parts-honda.es/pieces-honda-detail-10836-13MFJ701-CBR600RR7-2007-F__1800-CBR+600+RR.html

I can reproduce, the table is pasted too wide so it goes over the page width.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: 80ec99db4325a439a8a3f1d420d0a80f8bf9c439
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-06-16_00:00:20
Locale: fi-FI (fi_FI)
Comment 2 QA Administrators 2016-09-20 10:00:57 UTC Comment hidden (obsolete)
Comment 3 QA Administrators 2019-12-03 14:40:32 UTC Comment hidden (obsolete)
Comment 4 Timur 2019-12-09 17:15:13 UTC
That web is gone. And I cannot select content. 
We need reproducible steps, to exactly say: select on...from...to...
Comment 5 Buovjaga 2019-12-09 17:45:23 UTC
The page is archived:
https://web.archive.org/web/20140921212138/http://www.bike-parts-honda.es/pieces-honda-detail-10836-13MFJ701-CBR600RR7-2007-F__1800-CBR+600+RR.html

Seems to work a bit better now. I selected the table from the start of the heading to the end.

Now the problem is that the heading columns do not align with the product columns - HOWEVER: on the web page the heading is a separate table and the products are another table! So maybe we should be happy and close.

Arch Linux 64-bit
Version: 6.5.0.0.alpha0+
Build ID: 7e403195e574be5174815a51cf5c42f06f76a87a
CPU threads: 8; OS: Linux 5.3; UI render: default; VCL: kf5; 
Locale: fi-FI (fi_FI.UTF-8); UI-Language: en-US
Calc: threaded
Built on 1 December 2019