Bug 92102 - Table of Contents dialog rendered transparent or grabbing content of unrelated windows
Summary: Table of Contents dialog rendered transparent or grabbing content of unrelate...
Status: RESOLVED DUPLICATE of bug 91393
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.0.0.beta1
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-06-16 05:47 UTC by Jim Avera
Modified: 2015-06-16 11:23 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
Screenshot showing pixels copied from underlying window (before moving the corrupted window) (542.73 KB, image/png)
2015-06-16 05:47 UTC, Jim Avera
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jim Avera 2015-06-16 05:47:55 UTC
Created attachment 116570 [details]
Screenshot showing pixels copied from underlying window (before moving the corrupted window)

I'm seeing a wierd rendering problem where pixels from an unrelated window underneath (e.g. a terminal) are copied into part of the background of the "Insert Indexes & Tables" dialog when it first opens.

This happens for me using 5.0.0.0.beta1 but *not* in any earlier version.  It's hard to see how LO by itself could do this even if it wanted to; maybe something it is doing differently now tickles an X.org bug ... ?   FWIW, Ubuntu uses a compositing window manager.

==> Please see the attached screen-shot.

STEPS TO REPRODUCE:

1. Open attached "new.odt" document.
2. Place cursor below the paragraph which says "INSERT TABLE ... BELOW HERE"
3. Insert->Indexes and Tables->Indexes and Tables...

(it seems to depend on the positioning of the windows; it happens most often if the main window is the full height of the monitor, and about in the middle of the screen)
Comment 1 Adolfo Jayme 2015-06-16 11:23:55 UTC

*** This bug has been marked as a duplicate of bug 91393 ***