Bug Hunting Session
Bug 92131 - dual screen: tooltips appear only on the primary screen if secondary screen is connected later
Summary: dual screen: tooltips appear only on the primary screen if secondary screen i...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.4.3.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Multimonitor
  Show dependency treegraph
 
Reported: 2015-06-17 08:34 UTC by tim
Modified: 2017-11-27 09:06 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot of dual screen showing tooltip placement bug (308.16 KB, image/jpeg)
2015-06-17 08:34 UTC, tim
Details

Note You need to log in before you can comment on or make changes to this bug.
Description tim 2015-06-17 08:34:16 UTC
Created attachment 116602 [details]
screenshot of dual screen showing tooltip placement bug

how to reproduce:
with a dual screen extended desktop set up, open a libreoffice component eg. writer or scalc. 
move the application window to the second screen. once moved it can be windowed or full screen on the second screen.
move mouse over any tool button or document part for which a tooltip pops up. The tool tip will appear only on the first screen, not on the second screen.

expected behaviour:
tip should show on the same screen as the application is running on, near to the cursor position.
Comment 1 raal 2015-06-17 11:27:43 UTC
I can not confirm with LO 4.4.3, win7, 2 monitors
Comment 2 tommy27 2015-06-17 11:41:28 UTC
me neither LibO 4.4.3.2 under Win8.1 x64

which Windows version are you using?
did you try resetting the user profile?

https://wiki.documentfoundation.org/UserProfile
Comment 3 tim 2015-06-17 18:56:20 UTC
I am using windows 7 home premium 64bit. Having tested further, the problem occurred after I added the second monitor (without rebooting the pc). Windows recognised and configured the monitor, but libreoffice obviously did not realise the hardware had been added (and thus the screen width had been increased).
having made no changes other than restarting the pc with both screens attached has fixed the problem. I guess that a simple check of the screen size when the window is moved might help. I did open another instance of writer before restarting which still exhibited the problem, but as a reboot fixed it, it is probably pretty low priority.
Comment 4 tommy27 2015-06-18 05:43:55 UTC
I confirm bug under Win8.1 x64 using LibO 4.4.3.2

if you start with already 2 monitors connected the tooltips are correctly shown in both of them.

but if the second monitor connected later, the tooltips are still shown in the primary monitor

status NEW. edited summary notes.
Comment 5 QA Administrators 2016-09-20 10:01:56 UTC Comment hidden (obsolete)
Comment 6 tim 2016-09-20 16:38:09 UTC
I can confirm the bug is still present with v5.2.1.2 on windows 7 home premium. If the second screen's data connection is disconnected before a libreoffice application is run, and then is connected while the LO application is still running, if you drag the running program window to the second screen, all tool tips are limited to the far right edge of the first screen.

It looks like the positioning of the tool tip has it's (x + width) position truncated/checked against the screen width when the program loaded, instead of against the current screen width.
an option would be that if the placement x position is larger than the recorded screen width, then the current screen width should be updated, and the positioning then re-checked. something like the following psudo-code
....
if ((tooltip.x+tooltip.width)>screen.width) {
  /* re-get screen width in case it has changed */
  screen.width=getcurrentscreenwidth();
  if ((tooltip.x+tooltip.width)>screen.width) {
    /* adjust x position of tooltip so it fits on screen */
    tooltip.x=screen.width-tooltip.width;
  }
}
...
in the tooltip position checking routine would likely resolve the issue.
Comment 7 QA Administrators 2017-11-26 17:11:28 UTC Comment hidden (obsolete)
Comment 8 tim 2017-11-27 09:06:25 UTC
problem not occuring in libreoffice 5.4.3