Bug 92167 - Documents open with filemanager are not on top
Summary: Documents open with filemanager are not on top
Status: RESOLVED DUPLICATE of bug 48300
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
(earliest affected) release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
Depends on:
Reported: 2015-06-18 22:15 UTC by JSladek
Modified: 2015-06-28 17:14 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:

The attached is a typical file that opens underneath the file manager (28.07 KB, application/vnd.oasis.opendocument.text)
2015-06-18 22:23 UTC, JSladek

Note You need to log in before you can comment on or make changes to this bug.
Description JSladek 2015-06-18 22:15:59 UTC
When I open odt, ods, or doc files from the file manager (Dolphin), some files are on top of the file manager and some are underneath. Some files may have been created with OpenOffice and others with various generations of LO. There seems to be no pattern to this and I suspect it is an option for LO, but I can find no trace of it. It is a bit of a nuisance not knowing where the file is going to appear on the desktop.
Comment 1 JSladek 2015-06-18 22:23:13 UTC
Created attachment 116639 [details]
The attached is a typical file that opens underneath the file manager
Comment 2 JSladek 2015-06-19 12:48:24 UTC
I have attempted to "sanitize" a personal document to submit as a sample that will open on top of the file manager, but after editing and saving that document it then becomes one that opens beneath.

This also occurs with Calc files and has been a relatively recent anomaly.
Comment 3 JSladek 2015-06-20 13:08:03 UTC
I downloaded the file that I recently uploaded and opened it the same way via the file manager and it opened ON TOP.  Strange.  Then I closed it and reopened it again and it opened UNDERNEATH.  By repeated opening and closing, the file would change from "on top" to "underneath", but it was not alternating between the two position.  The number of successive openings were random - sometimes two or three times "underneath" top" and then maybe once "on top".

I tried the same process with a text file opening in a text editor, but it would ALWAYS open "on top".  It appears that there is some kind of position information that is being saved in the document when it's closed - but it has a random characteristic to it and it seems to only occur when opening/closing with LO.
Comment 4 JSladek 2015-06-20 13:41:56 UTC
The LibreOffice logo ALWAYS comes up "on top".
Comment 5 Carlos Rodriguez 2015-06-21 18:50:37 UTC
I'm trying to understand what you've done to reproduce this bug. I'm using KDE on Debian 8.

Steps that I'm doing:
1.- Open Dolphin
2.- Navigate to the folder where I've got some odt ods ...
3.- Click on one file (including the one you uploaded)
4.- Always shows the LibO logo and after a while opens the document on top (focus goes to the document automatically).

Then if I close only the document and minimize LibO, go to Dolphin and click on the file again:
1.- First the focus go to LibO window.
2.- After a while the focus goes to the document, opening on top.

On the other way if I'm closing the document and closing LibO, makes me go to the beginning.

So, I'm not able to reproduce on Debian 8 (jessie) with:

Build ID: 9a0b23dd0ab9652e0965484934309f2d49a7758e
Locale: es-ES (es_ES.UTF-8)

Id. de compilación: 8a35821d8636a03b8bf4e15b48f59794652c68ba

Please check the windows manager configuration on KDE to see if there is any personalization about windows focus. There you have six different possibilities to configure the focus on windows...
Comment 6 JSladek 2015-06-21 20:13:11 UTC
I am using KDE 4.14.2 with Solydk64 (Debian 8.1).

In your steps, I do the first three but step 4 shows the logo, but usually opens the document under Dolphin.  It is random - sometimes on top, but mostly under.

Each time I close the document, I actually hit the "X" to close both the document and LO.

This was first brought to my attention by a friend who experiences the same thing under the latest Kubuntu.

There is no problem opening a txt file under kwrite - it opens on top of Dolphin every time.

I checked the different focus options and there is no difference - the results are the same.   I normally use the "click to focus" option.
Comment 7 Carlos Rodriguez 2015-06-26 10:54:28 UTC
Sorry again but I'm unable to reproduce this bug.

What I've got as a similar "issue" is by clicking twice on a file when you had just set on KDE System Settings to just click once to open file... What happens is that the second click will focus the Dolphin Window instead of the LibO window.

Can you verify this?
Comment 8 JSladek 2015-06-26 14:36:04 UTC
This is all quite bizarre.  I have the opposite situation.

I have KDE System Settings the same as you.  But if I do a second click on the file in Dolphin when the LO logo comes up, the file will always(?) open with the focus on the document.  If I do a fast double click (the second click before the LO logo comes up), the behavior is the same as I have with the single click - the focus is randomly either Dolphin Window or the document.
Comment 9 JSladek 2015-06-26 14:54:18 UTC
There is another way that this problem can be duplicated for you and I just tested it.

Download a copy of Solydk-64 version 201505 (I presume you are using 64-bit) at:  http://solydxk.com/downloads/solydk/ and create a live disk.  Bring the system up and using the defaults except changing the mouse to single click, open LO and create a Writer file saving it in Documents.  Then close out LO and open Dolphin to open the file in Documents.  The behavior is there.
Comment 10 Carlos Rodriguez 2015-06-26 16:49:05 UTC
Ok, got this bug with SolydK ISO live. Investigating I get through System Settings -> Configure Desktop effect -> General tab and uncheck "Improved window management".

Try it and tell me if you still are getting this issue.
Comment 11 JSladek 2015-06-26 17:41:49 UTC
Normally, I had a dash rather than a check mark for "Improved window management".

But I cleared it and also tried the checkmark and the problem is the same no matter what I di=o with that setting.
Comment 12 Carlos Rodriguez 2015-06-28 10:40:36 UTC
Well, googling a little bit it seems that this bug had been around for a while:

Bug #75471 seems to be the same and is marked as duplicate of bug #48300, also KDE is aware of this in https://bugs.kde.org/show_bug.cgi?id=340915 or https://bugs.kde.org/show_bug.cgi?id=339621 where they applied a workaround.

What is mentioned in bug #48300 is that this is a inheriting issue from OOo. I should mark this as a duplicated of #48300.
Comment 13 JSladek 2015-06-28 13:24:42 UTC
I understand that this bug will be referred to #48300.  I should also mention that this behavior also occurs and was first noted with Calc files.
Comment 14 Carlos Rodriguez 2015-06-28 17:07:58 UTC
This bug is replicated on Linux Debian based distro (Solydk) with LibreOffice version:

Id. de compilación: 430m0(Build:2)

Fortunately, after installing updated versions of LibO I can't replicate this bug:

Build ID: 7847365292bf0c5e35cf94835b46e414dbe4692e
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:libreoffice-4-4, Time: 2015-06-25_10:22:13
Locale: es_ES.UTF-8

Build ID: e36ca8d3c69d0c08ad28ceea278b05a0af81e102
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:libreoffice-5-0, Time: 2015-06-25_07:19:18
Locale: es-ES (es_ES.UTF-8)

Build ID: a7a95af74badcb745bb1c86c7f9a21444ca12c77
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2015-06-25_09:37:54
Locale: es-ES (es_ES.UTF-8)
Comment 15 Carlos Rodriguez 2015-06-28 17:14:07 UTC
As I mention, this bug should be considered duplicate of bug #48300

On Linux with updated versions of LibO I'm not getting it.

*** This bug has been marked as a duplicate of bug 48300 ***