Download it now!
Bug 92181 - Formulas in Tables in Writer & Conversion to pdf
Summary: Formulas in Tables in Writer & Conversion to pdf
Status: RESOLVED DUPLICATE of bug 63570
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All Windows (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-06-19 12:34 UTC by Butch
Modified: 2018-12-07 16:17 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Example file: Formulas in Tables in Writer & Conversion to pdf (70.34 KB, application/vnd.oasis.opendocument.text)
2015-06-19 12:34 UTC, Butch
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Butch 2015-06-19 12:34:25 UTC
Created attachment 116652 [details]
Example file: Formulas in Tables in Writer & Conversion to pdf

To calculate a sum in a table in a Writer document the following formulas can be used:
i) <A1>+<A2>+<A3>
ii) <A1:A3>
iii) SUM <A1:A3>
The result in the Writer document is correct with all these formulas.

The problem becomes visible when the Writer document is converted to the pdf format, e.g. using the LO command line conversion method
soffice.exe --convert-to pdf WriterBug.odt
or another odt2pdf tool:
A correct conversion to the pdf file is possible only with the (i) formula, the two other formulas result in 
"** Expression is faulty **"

See the attached WriterBug.odt.

If you use the Writer export function to create the pdf file, there is no problem.
Comment 1 Buovjaga 2015-06-21 15:17:04 UTC
Confirmed with soffice.exe --convert-to pdf WriterBug.odt
Exporting through the gui is fine.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: 3ecef8cedb215e49237a11607197edc91639bfcd
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-06-19_23:16:58
Locale: fi-FI (fi_FI)
Comment 2 QA Administrators 2016-09-20 10:10:00 UTC Comment hidden (obsolete)
Comment 3 Butch 2016-09-29 06:18:36 UTC
Why QA Administrators is asking? 
I don't think that there was an effort to fix this bug at all.
The bug is still present in 5.2.1.2 (32 bit).
Comment 4 Buovjaga 2016-09-29 08:00:27 UTC
(In reply to Butch from comment #3)
> Why QA Administrators is asking? 
> I don't think that there was an effort to fix this bug at all.
> The bug is still present in 5.2.1.2 (32 bit).

Because something like 20% of pinged old reports have actually been fixed, when tested.
Comment 5 QA Administrators 2017-10-23 14:07:37 UTC Comment hidden (obsolete)
Comment 6 Timur 2018-12-07 16:17:34 UTC
Looks like a duplicate of Bug 63570. 
If you disagree, please explain, test with lastest LO and sent back New.
If you agree and think some info may be useful, please write to 63570.

*** This bug has been marked as a duplicate of bug 63570 ***