Bug 92204 - WRITER: Japanese Character is not shown on Property > Description >Comment text box.
Summary: WRITER: Japanese Character is not shown on Property > Description >Comment te...
Status: RESOLVED DUPLICATE of bug 96687
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.0.0.beta3
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: RenderContext
  Show dependency treegraph
 
Reported: 2015-06-20 08:52 UTC by sawakaze
Modified: 2016-03-13 15:00 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Description of Comments text box (32.39 KB, image/jpeg)
2015-06-20 08:52 UTC, sawakaze
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sawakaze 2015-06-20 08:52:28 UTC
Created attachment 116675 [details]
Description of Comments text box

Hi,

After following step, character is not shown text box.
(1) open Writer.
(2) File > Properties
(3) Press Description tab
(4) input Japanese character to Comments text box (Attachment is Comment text box capture).
--> not shown Japanese Character...

info. alphabet is shown.

env..
OS : Debian Linux Jessie

LibreOffice Version: 5.0.0.0.beta3+
Build ID: 6889dd9477e7049a7249e89725244dcc9355fc9c
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:libreoffice-5-0, Time: 2015-06-19_23:27:42
Locale: ja-JP (ja_JP.UTF-8)
Comment 1 noharra 2015-06-20 09:10:46 UTC
I succeeded reproducing.
Tested using Windows7(64bit) with Libreoffice 5.0.0.0.beta3
Build ID: 96345c15d8ab19c49014f055fe41ba8e1f421e5c
Comment 2 Christian Lohmaier 2015-06-20 09:15:25 UTC
confirm on linux as well. 
Characters are shown while IME dialog is active, but once you commit, it is "white text on white background"
Continue typing, and the already-typed text (as well as new text) is shown, again until you commit new part, then text is white on white again.

Close and reopen the preference dialog and all text is shown. (if you add text, then same effect again)
Comment 3 baffclan 2015-06-20 23:43:15 UTC
I can reproduce in Calc, Impress, Draw.
It is not only Writer problem.
Comment 4 Christian Lohmaier 2015-07-05 14:47:35 UTC
bibisected to 29b1e6718f6ebdb45d2a8c6a89a86bc0a6bbb3ae
"refactor "TextEdit" & co. to use RenderContext"
Comment 5 Björn Michaelsen 2015-08-28 11:47:10 UTC
Blocking on 91488, as per comment 4 seems to be RenderContext related.
Comment 6 Robinson Tryon (qubit) 2015-12-13 11:13:06 UTC
Migrating Whiteboard tags to Keywords: (bibisected)
[NinjaEdit]
Comment 7 baffclan 2016-03-13 11:14:23 UTC
Cannot reproduce this problem.

Windows 7 Pro
Version: 5.1.1.3 (x64)
Build ID: 89f508ef3ecebd2cfb8e1def0f0ba9a803b88a6d
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
Locale: ja-JP (ja_JP)
Comment 8 Christian Lohmaier 2016-03-13 15:00:49 UTC
was fixed with bug#96687 for 5.1.0 and later

*** This bug has been marked as a duplicate of bug 96687 ***