Bug 92226 - LO50rc1 OSX: Empty folders installed as dictionary extensions
Summary: LO50rc1 OSX: Empty folders installed as dictionary extensions
Status: RESOLVED DUPLICATE of bug 87075
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Extensions (show other bugs)
Version:
(earliest affected)
4.4.3.2 release
Hardware: Other Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-06-21 10:54 UTC by Martin Srebotnjak
Modified: 2017-03-19 19:12 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Extension Manager on OSX (64.66 KB, image/png)
2015-06-21 10:54 UTC, Martin Srebotnjak
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Srebotnjak 2015-06-21 10:54:00 UTC
Created attachment 116703 [details]
Extension Manager on OSX

Hi, noticed this for a long time and even mentioned it sometimes on the list but was said to delete my user profile, which didn't fix it.

I explored it now on my OSX with LO50rc1 and saw that these dictionaries get "bundled" with the main installer so that has nothing to do with a user's LO profile on OSX.

What really happens, is this:
In the installed LibreOffice package under Resources/extensions there is a big list of folders, like "dict-bs", "dict-sk" etc. Most of them just have a subfolder "META-INF" but are totally empty.

Just few of these directories have files in them and those are the actually installed/bundled dictionaries with properly localizable descriptions shown in UI of Extension Manager; all the rest are either fictionally listed or should have the metadata there to be properly displayed in the UI/Extension Manager.

Attaching this list of dictionaries after already manually deleting many of those "empty folders" from the OSX LO package, so the list is not complete, many more are there upon a clean install. As you can see, the bundled English dictionary pack has properly displayed name, and it's folder does contain files under /Resources/extensions/dict-en
Comment 1 Alex Thurgood 2015-06-22 07:28:28 UTC
Confirming, but I seem to recall that this is deliberate, due to the specifics of integrating lang-packs that would otherwise invalidate code signing on OSX.

Setting to NEW, but someone else might be able to explain why, and whether this is/is not a bug after all.
Comment 2 Alex Thurgood 2015-06-22 07:29:35 UTC
I see it in 4432, changing version to earliest found so far.
Comment 3 Martin Srebotnjak 2015-06-22 18:58:57 UTC
Alex, this is a bug, no doubt.

When a dictionary is installed, in the Extension Manager a l10n-ed string should describe every installed extension.

These bundled spelling extensions in basic LO OSX package have strings like "el" shown, meaning nothing to a normal user, not even that it is a dictionary. Remember, all these strings are localized, are part of LibreOffice, but just do not get pulled into these OS X packages as it seems.

Also, you cannot uninstall these dictionaries making the Extension Manager clean enough to be useful. And most users do not need most of those extensions; it would be much cleaner to include them into OSX lang-pack (of course, if that is possible).

So this is definitely a UI/UX bug. Otherwise all extensions could be just shown with strings "el", "yx", "th", "fdklsgk", "opigsoglsmd" etc.

The only question is how to remedy this situation and whether anyone has time/will to do it.
Comment 4 Martin Srebotnjak 2015-08-11 06:37:15 UTC
*** Bug 87075 has been marked as a duplicate of this bug. ***
Comment 5 QA Administrators 2016-09-20 10:21:55 UTC Comment hidden (obsolete)
Comment 6 steve -_- 2016-09-27 09:29:43 UTC
Version: 5.3.0.0.alpha0+
Build ID: a4c974293e84685aa055922b70b2470fcff2d844
CPU Threads: 4; OS Version: Mac OS X 10.12; UI Render: default; 
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2016-09-27_01:05:19
Locale: de-DE (de_DE.UTF-8); Calc: group

persisting. cluttered extension manager with wrong info.
Comment 7 Alex Thurgood 2016-12-14 11:30:04 UTC
See also bug 33060, in relation to bundled extensions, which has just been closed as WONTFIX
Comment 8 Stephan Bergmann 2017-03-19 19:12:38 UTC

*** This bug has been marked as a duplicate of bug 87075 ***