Bug 92233 - EDITING: Subtotals not working properly
Summary: EDITING: Subtotals not working properly
Status: RESOLVED DUPLICATE of bug 88793
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-06-21 19:23 UTC by Robert Gonzalez MX
Modified: 2015-06-21 22:18 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Original test file with the mentioned bug (34.75 KB, application/vnd.oasis.opendocument.spreadsheet)
2015-06-21 19:24 UTC, Robert Gonzalez MX
Details
Second test file (23.79 KB, application/vnd.oasis.opendocument.spreadsheet)
2015-06-21 19:25 UTC, Robert Gonzalez MX
Details
Third test file (25.46 KB, application/vnd.oasis.opendocument.spreadsheet)
2015-06-21 19:25 UTC, Robert Gonzalez MX
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Gonzalez MX 2015-06-21 19:23:19 UTC
Description: The Data Subtotals doesn't display the result in the cells.

Open test file “Bug subtotals 20150125.ods”
Go to cell A1

Select in the menu Data – subtotals
Select group by “Category”
Select on the Calculate subtotals for options the 12 months of the year and the “Totals”
Leave the function to “Sum”
Press OK.

The subtotals are applied but there is no value

go to cell D3, the function is in place.
Press F2 to edit the formula and press enter, (to refresh) but nothing changes.

Press F9 to recalculate the sheet, and the subtotals display, but without format.

Press the undo icon to restart the test or close the file en open it again

Repeat all the steps except the F9.
After pressing F2 go to the Menu – Insert – Function 
Don't change anything, observe and just press OK.

The result displays as it should, value and format.

Additionally, the range selection remains visible, until the file is closed, doesn't affect the real format of the cell.

I have tried with various test files, that I am attaching. But not all reproduces this.

I have cleared the subtotals selecting Group – none. But still keep failing to produce the subtotals.
Comment 1 Robert Gonzalez MX 2015-06-21 19:24:30 UTC
Created attachment 116712 [details]
Original test file with the mentioned bug
Comment 2 Robert Gonzalez MX 2015-06-21 19:25:13 UTC
Created attachment 116713 [details]
Second test file
Comment 3 Robert Gonzalez MX 2015-06-21 19:25:47 UTC
Created attachment 116714 [details]
Third test file
Comment 4 Robert Gonzalez MX 2015-06-21 19:31:53 UTC
I have added the related bugs I have submitted,  referring to the absence of the format, and the column outlining problem, that I traced back to OO 3.2.1.
Comment 5 m.a.riosv 2015-06-21 22:18:36 UTC
Hi @Rober, thanks for reporting.

About calculation maybe you have forgotten to set up the Menu/Tools/Cells contens/Autocalculate to on.

On format this is a duplicate.

*** This bug has been marked as a duplicate of bug 88793 ***