Download it now!
Bug 92235 - Font STYLES for Table Headers are not copied when defining auto table format
Summary: Font STYLES for Table Headers are not copied when defining auto table format
Status: RESOLVED DUPLICATE of bug 104389
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: low minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Table-AutoFormat
  Show dependency treegraph
 
Reported: 2015-06-21 21:42 UTC by Axel Bock
Modified: 2020-07-04 09:43 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
The result of the failed application of a paragraph style with autoformat (12.64 KB, application/vnd.oasis.opendocument.text)
2015-06-22 07:28 UTC, Axel Bock
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Axel Bock 2015-06-21 21:42:14 UTC
STEPS TO REPRODUCE:

format a table with a header row, format the header using a cusotom header row paragraph style.

apply the newly created autoformat to a new table.


RESULT:
the header row will look like the original header.
But the paragraph styles of the original table are not applied.


EXPECTED RESULT:
that the paragraph styles are applied.


PERSONAL SIDE NOTE:
This is my first document with a LOT of tables in LO. It will most probably be the last - formatting a lot of tables is a serious pain in ... ... .
Comment 1 Joel Madero 2015-06-21 22:02:03 UTC
Please attach a document that makes it easier for us to repro. Setting to NEEDINFO - once you attach a simple document, please set to UNCONFIRMED. Thanks!
Comment 2 Axel Bock 2015-06-22 07:28:20 UTC
Created attachment 116719 [details]
The result of the failed application of a paragraph style with autoformat

If you know what to look for (paragraph styles in the table header row) you can see what is NOT there - which is the paragraph style "Table Heading" in the header row.
Comment 3 Alex Thurgood 2015-06-22 08:32:16 UTC
If you redefine your default Table Header paragraph style in the styles and formatting dialog rather than via AutoFormat > New, this appears to work OK.

By default, if the Table Header option is not clicked in the Table Properties dialog, the first row will be assigned the Table Content paragraph style. When you tick the Table Header option in the Table Properties dialog, the default Table Header style is applied (even if you have set a different paragraph style. In order to change this, you need to change the default Table Header style in Styles and Formatting - I would admit that this kind of defeats having an AutoFormat > New dialog, if you can't set up your own customised paragraph styles as well.

Confirming
Comment 4 Joel Madero 2015-06-22 13:28:29 UTC
Setting as:
Minor - slows down professional quality work but will not prevent it;
Low - default for minor issues.

Would be nice to find out if this is a regression or not (testing 3.3 and seeing if the issue was around there would tell us that information). 

http://downloadarchive.documentfoundation.org/libreoffice/old/
Comment 5 Axel Bock 2015-06-22 16:17:17 UTC
Well, MS Paint also makes professional work hard but possible :) . After editing only a single document I must say tables in LO need a _much_ better approach.

But to the point: Checked version 3.3.4.1, same thing.
Comment 6 QA Administrators 2016-09-20 10:11:35 UTC Comment hidden (obsolete)
Comment 7 Axel Bock 2016-10-08 01:01:13 UTC
unchanged, still open
 
LibreOffice 5.1.5.2
Build ID 7a864d8825610a8c07cfc3bc01dd4fce6a9447e5
Mac OS X 10.12
Locale: de-DE (de_DE.UTF-8)
Comment 8 QA Administrators 2017-10-23 14:00:47 UTC Comment hidden (obsolete)
Comment 9 Axel Bock 2017-10-26 19:50:59 UTC
Bug still present.


LIBREOFFICE INFORMATION:

Version: 5.4.2.2
Build ID: 22b09f6418e8c2d508a9eaf86b2399209b0990f4
CPU threads: 8; OS: Mac OS X 10.13; UI render: default; 
Locale: de-DE (de_DE.UTF-8); Calc: group



STEPS TO REPRODUCE:

* add table
* format table header with PARAGRAPH STYLE "Table heading"
* format table contents with PARAGRAPH STYLE "Table contents"
* create a table auto-format from that
  * Table auto-format dialog
  * Use "Add" when table is marked to add new format type

* Create NEW table
* format table with table auto-format style.



RESULT:
* The PARAGRAPH STYLES are *NOT* applied
* ... just the formatting is.



EXPECTED RESULT:
* the formatting is not applied,
* but the PARAGRAPH STYLE is.



That is a real PITA if you format a lot of tables and want to change all headings / contents at once.
Comment 10 Axel Bock 2017-10-26 19:51:50 UTC
set version field to "inherited from ooo" cause I already tested with 3.3.4.1, as per the instructions.
Comment 11 QA Administrators 2018-11-08 04:07:08 UTC Comment hidden (obsolete)
Comment 12 eisa01 2018-12-11 20:36:15 UTC
This is still present.

Note: Important to check the paragraph style! The formatting (e.g., bold header) is applied, but the paragraph style is not. As such, you lose the format if you press ctrl+m (presumably resetting format)

Version: 6.3.0.0.alpha0+
Build ID: beae6c7a7f163daad0d4dea63a3d403af2745fd1
CPU threads: 2; OS: Mac OS X 10.13.6; UI render: default; VCL: osx; 
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2018-12-06_23:52:29
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 13 eisa01 2020-05-09 23:09:51 UTC
This is now fixed

Version: 7.0.0.0.alpha0+
Build ID: f14691683900f6b28737be8c599e1ee4e8386e14
CPU threads: 4; OS: Mac OS X 10.14.6; UI render: default; VCL: osx; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 14 Justin L 2020-07-04 08:57:07 UTC Comment hidden (no-value)
Comment 15 Justin L 2020-07-04 09:40:15 UTC
No change - repro 7.1+ using Linux.

The paragraph style on the first row is still "Table Contents" and not "Table Header".
Comment 16 Justin L 2020-07-04 09:43:59 UTC

*** This bug has been marked as a duplicate of bug 104389 ***