Download it now!
Bug 92236 - Table Autoformat: Allow to select if "SUM" line is present for auto format
Summary: Table Autoformat: Allow to select if "SUM" line is present for auto format
Status: RESOLVED DUPLICATE of bug 83667
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.4.2 rc
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-06-21 21:52 UTC by Axel Bock
Modified: 2015-12-30 18:24 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Axel Bock 2015-06-21 21:52:58 UTC
STEPS TO REPRODUCE:

create a new table autoformat with alternating table rows.

create two new tables, one with an odd number of rows, one with an even number. 

apply the autoformat.


RESULT:
in one new table the two bottom rows will have the same background color.


PROBLEM:
the table format simply assumes that there is a bottom "sum" row with its own format. this is not always the case. 


PROPOSED RESOLUTION:
please allow to select whether the "sum" row table format should be applied to the last row.
Comment 1 Buovjaga 2015-06-26 14:04:44 UTC
(In reply to Axel Bock from comment #0)
> STEPS TO REPRODUCE:
> 
> create a new table autoformat with alternating table rows.

I went to Table - Autoformat, then Add, but I don't know how to achieve alternating rows.
Help didn't help: https://help.libreoffice.org/index.php?title=Writer/AutoFormat_for_Tables&Language=en-US&System=WIN&Version=5.1#bm_id3148770

Can you give more detailed steps?

Set to NEEDINFO.
Change back to UNCONFIRMED after you have provided the information.
Comment 2 QA Administrators 2015-12-27 20:31:17 UTC
Dear Bug Submitter,

This bug has been in NEEDINFO status with no change for at least
6 months. Please provide the requested information as soon as
possible and mark the bug as UNCONFIRMED. Due to regular bug
tracker maintenance, if the bug is still in NEEDINFO status with
no change in 30 days the QA team will close the bug as INVALID
due to lack of needed information.

For more information about our NEEDINFO policy please read the
wiki located here:
https://wiki.documentfoundation.org/QA/Bugzilla/Fields/Status/NEEDINFO

If you have already provided the requested information, please
mark the bug as UNCONFIRMED so that the QA team knows that the
bug is ready to be confirmed.
 
Thank you for helping us make LibreOffice even better for everyone!


Warm Regards,
QA Team
Comment 3 Axel Bock 2015-12-28 00:22:35 UTC
created a little video to illustrate what I mean. 
please watch it here: https://youtu.be/_7HrwRlDueQ
Comment 4 Buovjaga 2015-12-29 14:05:04 UTC
(In reply to Axel Bock from comment #3)
> created a little video to illustrate what I mean. 
> please watch it here: https://youtu.be/_7HrwRlDueQ

Unable to watch private vid.
Comment 5 Axel Bock 2015-12-29 20:19:34 UTC
oops. sorry for that, should be fixed now.
Comment 6 Buovjaga 2015-12-30 18:24:03 UTC
Ok, thanks. I confirm the behavior.
I found this report, which is apparently complaining about the same thing: bug 83667
I confirm that by inserting new rows, the "two colored lower rows" phenomenon repeats with an even number of rows.

I will close this as a dupe and add a comment to the older report that this behavior also occurs also on applying.

*** This bug has been marked as a duplicate of bug 83667 ***