Bug Hunting Session
Bug 92261 - Windows explorer crashes at open of directory with LO documents
Summary: Windows explorer crashes at open of directory with LO documents
Status: RESOLVED DUPLICATE of bug 92269
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.0.0.1 rc
Hardware: Other Windows (All)
: medium blocker
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-06-22 18:53 UTC by Helmut Leininger
Modified: 2015-06-30 22:39 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Helmut Leininger 2015-06-22 18:53:17 UTC
LO 5.0.0 RC1 64-bit on Windows 8.1 64-bit

Windows explorer or other similar tools (e.g. TotalCommander) crash when browsing a directory that contain LO documents.
Comment 1 Helmut Leininger 2015-06-22 19:17:38 UTC
Also happens with 32-bit LO
Comment 2 Eric M 2015-06-23 08:06:49 UTC
Sounds similar to bug92269. Try disabling the property handler as a workaround.
Comment 3 Helmut Leininger 2015-06-23 09:39:41 UTC
Bypass works (disabling Infotip, Property, Property Sheet Handlers).
Comment 4 Aleksei 2015-06-23 11:47:18 UTC
LO Version: 5.0.0.1 (x64) Build ID: 9a0b23dd0ab9652e0965484934309f2d49a7758e
Win7x64 6.1.7601 SP 1 Build 7601

Can't reproduce. Everything is working fine.
Comment 5 Eric M 2015-06-23 16:26:01 UTC
Interesting, I'm also using Build ID: 9a0b23dd0ab9652e0965484934309f2d49a7758e
and had a similar issue  bug92269. 
The workaround seems to have solved Helmut's problem. 

Is there a way the install could have left the shell property handlers set up differently on your system Aleksei?
Comment 6 Helmut Leininger 2015-06-23 16:50:46 UTC
@Aleksei:
is it still working ok if you move the cursor over a LO document and/or single click it ?
Comment 7 Helmut Leininger 2015-06-27 20:33:42 UTC
The problem is still present in Version: 5.0.0.2 (x64)
Build-ID: a26d58f11b99b6aeddf7f7884effea188cc6e512
Comment 8 Helmut Leininger 2015-06-28 06:34:49 UTC
To bypass the problem in 5.0.0.2 it is necessary to deactivate the LibreOffice Infotip Handler
Comment 9 Christian Lohmaier 2015-06-30 21:13:52 UTC
confirm. The trick is to wait long enough with still mouse so that a tooltip is triggered.
Comment 10 Christian Lohmaier 2015-06-30 22:39:30 UTC

*** This bug has been marked as a duplicate of bug 92269 ***