Bug Hunting Session
Bug 92272 - SLIDESHOW: slide color inversion during transitions
Summary: SLIDESHOW: slide color inversion during transitions
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.0.0.1 rc
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:5.1.0 target:5.0.4
Keywords:
Depends on:
Blocks:
 
Reported: 2015-06-23 08:54 UTC by Technologov
Modified: 2016-10-25 19:21 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
example document. (1.94 MB, application/zip)
2015-06-23 08:54 UTC, Technologov
Details
rendered image (correct color) (498.80 KB, image/png)
2015-06-23 12:14 UTC, Technologov
Details
during slide animation (inverted color) (467.81 KB, image/png)
2015-06-23 12:15 UTC, Technologov
Details
Colours display as inverse during fade smoothly transition (12.56 KB, application/vnd.oasis.opendocument.presentation)
2015-09-13 01:34 UTC, neil
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Technologov 2015-06-23 08:54:22 UTC
Created attachment 116755 [details]
example document.

LibreOffice 5.0.0.1 RC1 Impress. 

Use file attached below. And run a slideshow. When doing transformation animation (loading next page), pages have inversed colors.

-Technologov, 23.Jun.2015
Comment 1 tommy27 2015-06-23 12:04:07 UTC
please tell which is your O/S.
would you please attach a screenshot as well?
Comment 2 Technologov 2015-06-23 12:14:26 UTC
Created attachment 116762 [details]
rendered image (correct color)
Comment 3 Technologov 2015-06-23 12:15:10 UTC
Created attachment 116763 [details]
during slide animation (inverted color)
Comment 4 Technologov 2015-06-23 12:16:09 UTC
Host: Windows 7 x64 + Intel HD 4400 graphics
Comment 5 Aleksei 2015-06-23 12:49:13 UTC
1
Win7x64 6.1.7601 SP 1 Build 7601
Version: 5.0.0.1 (x64) Build ID: 9a0b23dd0ab9652e0965484934309f2d49a7758e

Yeah the colors are inversed (red turns blue, blue turns march (dark green) color)

2
Ubuntu14x64
Version: 1:5.0.0~rc1-0ubuntu1~trusty1

Couldn't reproduce.
Comment 6 tommy27 2015-06-23 12:52:44 UTC
I confirm issue with color inversion during transitions using a recent LibO 5.1.0.0 alpha daily build.  status NEW
Comment 7 tommy27 2015-06-23 13:57:45 UTC
forthe record I see the same issue on Win7x64 and Win8.1x64
Comment 8 neil 2015-09-13 01:34:39 UTC
Created attachment 118660 [details]
Colours display as inverse during fade smoothly transition

Transitions display as inverse colours when using fade smoothly in LO 5.0.1.2
Comment 9 Commit Notification 2015-10-30 17:32:25 UTC
Tor Lillqvist committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f96508f3230f6f098a26546d12a50b7a19130117

tdf#92272: We need to twiddle the bytes from BGR to RGB

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Tor Lillqvist 2015-10-30 17:40:52 UTC
When the fix becomes available in a 5.1 nightly build it would be nice if people could verify that it fixes this problem (it did for me, but you never know...), and that it doesn't cause any immediately visible other issue. Then I can cherry-pick it to the 5.0 branch.
Comment 11 Technologov 2015-10-30 20:09:46 UTC
Can you give me exact link ? I'm the original reporter and can validate.

I see too many builds... in Daily Master:
http://dev-builds.libreoffice.org/daily/master/
[DIR] Win-x86@39/                              20-Oct-2015 09:27    -   
[DIR] Win-x86@42/                              30-Oct-2015 16:57    -   
[DIR] Win-x86@51-TDF/                          15-Dec-2014 00:05    -   
[DIR] Win-x86@62-TDF/                          01-May-2015 00:05    -   
[DIR] Win-x86@62-merge-TDF/                    30-Oct-2015 02:50    -   
[DIR] Win-x86_64@42/                           31-May-2015 00:05    -   
[DIR] Win-x86_64@62-TDF/                       30-Oct-2015 02:33    -   
[DIR] win-x86@39/                              20-Oct-2015 09:27    -  
...
Comment 12 Tor Lillqvist 2015-11-02 07:28:25 UTC
Whichever that has a Windows build that is from 2015-10-31 or later?
Comment 13 roumanet 2015-11-24 21:44:06 UTC
Under Windows too... I'm teacher and use transitions for some video curses : could you publish a patch for Windows users ?
Thanks

example of problem
http://david.roumanet.free.fr/bug_transition.avi
Comment 14 Tor Lillqvist 2015-11-25 06:38:26 UTC
The patch *is* for Windows. This is a Windows-only bug.
Comment 15 Commit Notification 2015-11-26 12:26:00 UTC
Tor Lillqvist committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f7d1ea37a557d904caecb080deab162bd70e1a87&h=libreoffice-5-0

tdf#92272: We need to twiddle the bytes from BGR to RGB

It will be available in 5.0.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 Technologov 2015-11-26 12:29:36 UTC
May I ask how come "BGR" problem only shows up on Windows machines, but not on Linux ? Usually all the cross-platform GUI frameworks are API compatible across platforms.
Comment 17 Tor Lillqvist 2015-11-26 13:16:51 UTC
Feel free to even just check the pathnames of the source files that the commit above touches, that should make it fairly obvious.