Download it now!
Bug 92332 - SIDEBAR: Customizing the sidebar tabs isn't saved between sessions
Summary: SIDEBAR: Customizing the sidebar tabs isn't saved between sessions
Status: RESOLVED DUPLICATE of bug 67770
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.2.8.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Sidebar-UI-UX
  Show dependency treegraph
 
Reported: 2015-06-25 13:33 UTC by Yousuf Philips (jay) (retired)
Modified: 2016-10-24 16:27 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2015-06-25 13:33:44 UTC
Steps:
1) Open Writer
2) Click the customization button in the sidebar tab bar
3) In the context menu, click Customization > Navigator to hide Navigator tab button in the tab bar
4) Close Writer
5) Open Writer
6) Navigator tab button is back

Version: 5.1.0.0.alpha1+
Build ID: 2135fe0cef7bcf7160719f1f29ad65f2b064984b
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2015-06-24_03:00:35
Comment 1 Laurent Godard 2015-06-25 14:08:48 UTC
caution
sidebar layout is now definded per document (since 5.1.0), so saving should ideally be into document
if not possible, save the last closed sidebar configuration ?
Comment 2 Yousuf Philips (jay) (retired) 2015-06-25 22:36:59 UTC
(In reply to Laurent Godard from comment #1)
> caution
> sidebar layout is now definded per document (since 5.1.0), so saving should
> ideally be into document
> if not possible, save the last closed sidebar configuration ?

Saving the layout of the sidebar per document seems like a very stupid idea in my view, as we dont save toolbar, ruler, and other view settings per document. I just checked in master (5.1) and it doesnt save per document.
Comment 3 tommy27 2015-06-26 04:46:07 UTC
confirmed under Win8.1 x64 using LibO 5.1.0.0.alpha1+
Build ID: df7595a5f5871f8343e4ee3869ad153e3ae4a7f3
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-06-25_14:29:31
Locale: en-US (it_IT)

I agree with Jay... a custom layout per document is non-sense.
you should be able to customize the sidebar exactly like other toolbars with permanent changes
Comment 4 V Stuart Foote 2015-06-26 15:03:50 UTC
Please see https://bugs.documentfoundation.org/show_bug.cgi?id=67770#c4

*** This bug has been marked as a duplicate of bug 67770 ***