Bug 92376 - LO 5.0 doesn't open librevenge's files
Summary: LO 5.0 doesn't open librevenge's files
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
5.0.0.0.beta1
Hardware: Other Mac OS X (All)
: medium normal
Assignee: David Tardon
URL:
Whiteboard: target:5.1.0 target:5.0.0.3
Keywords:
Depends on:
Blocks:
 
Reported: 2015-06-27 10:13 UTC by Bernd Marsch
Modified: 2016-10-25 19:23 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Example 1 (58.49 KB, application/clarisworks)
2015-06-27 10:13 UTC, Bernd Marsch
Details
Text 1 (28.44 KB, image/png)
2015-06-27 10:16 UTC, Bernd Marsch
Details
Example 2 (81.87 KB, application/clarisworks)
2015-06-27 10:17 UTC, Bernd Marsch
Details
Result 2 (79.35 KB, image/png)
2015-06-27 10:17 UTC, Bernd Marsch
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bernd Marsch 2015-06-27 10:13:29 UTC
Created attachment 116867 [details]
Example 1

LO 5.0.0.1 rc doesn't open old AppleWorks files anymorse. LO 4.4.3 works with these files.
There are different results on trying to open these files. See attachments
Comment 1 Bernd Marsch 2015-06-27 10:16:30 UTC
Created attachment 116868 [details]
Text 1
Comment 2 Bernd Marsch 2015-06-27 10:17:20 UTC
Created attachment 116869 [details]
Example 2
Comment 3 Bernd Marsch 2015-06-27 10:17:58 UTC
Created attachment 116870 [details]
Result 2
Comment 4 Jacques Guilleron 2015-06-27 13:12:16 UTC
Hi Bernd,

An extension is missing to the first file. Adding .cwk, I could open them with 
LO 5.0.0.1 on Windows 7 Home Premium. Images embeded can also be opened like a spreadsheet by using double clic.
Comment 5 Bernd Marsch 2015-06-27 16:32:55 UTC
I'm on Mac Yosemite. I tried it. The message s the same as before (Text 1).

An extension wasn't needed in LO 4.4.3 and the second file has an extension.
Comment 6 Maxim Monastirsky 2015-06-27 21:08:45 UTC
Cannot reproduce with 5.0rc1/5.0 daily/master under Fedora 22. I'm able to open these files whether they have an extension or not. So this bug must be Mac specific.
Comment 7 osnola 2015-06-28 08:02:53 UTC
(In reply to Bernd Marsch from comment #0)
> LO 5.0.0.1 rc doesn't open old AppleWorks files anymorse. LO 4.4.3 works
> with these files.
> There are different results on trying to open these files. See attachments

Hello Bernd,
thank you for noting this problem.

David:
at least the libetonyek library is not fully installed, i.e.  
> otool -l libetonyek-0.1.1.dylib |grep lib
libetonyek-0.1.1.dylib:
    name /@.__________________________________________________OOO/lib/libetonyek-0.1.1.dylib (offset 24)
    name /@.__________________________________________________OOO/lib/librevenge-0.0.0.dylib (offset 24)
instead of
    name /@.__________________________________________________OOO/lib/libetonyek-0.1.1.dylib (offset 24)
    name  @loader_path/librevenge-0.0.0.dylib (offset 24)
can you take a look ?

Note: 
- I do not check other libraries, but libwpftdrawlo still works (when I force it to use the LibreOffice.app libraries), so there are probably fine...
Comment 8 Commit Notification 2015-06-28 10:36:02 UTC
David Tardon committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a94acabae7defe562e3702f605c63afbd86f9696

tdf#92376 fix build of libetonyek on OS X

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 9 Bernd Marsch 2015-06-28 12:19:18 UTC
Thank you for the quick work. I'll try the patch tuesday.
Comment 10 Commit Notification 2015-07-01 11:56:05 UTC
David Tardon committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=045e3aa799851f905f7ba180207f88cca93607fb&h=libreoffice-5-0

tdf#92376 fix build of libetonyek on OS X

It will be available in 5.0.0.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 11 Bernd Marsch 2015-07-02 21:49:42 UTC
Today I tried the version LibreOfficeDev 5.0.0.2.0 from 
dev-builds.libreoffice.org/daily.

This new version opens my files like 4.4.3 did. Many thanks for the work.
Comment 12 Bernd Marsch 2015-07-25 20:27:46 UTC
I tried the version LibreOffice 5.0.0.3 from 
libreoffice.org/download/libreoffice-fresh

This version opens my files like 4.4.3 did. Many thanks for the work.