Download it now!
Bug 92381 - Tooltips for Styles Pane wrong with GB locale
Summary: Tooltips for Styles Pane wrong with GB locale
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Localization (show other bugs)
Version:
(earliest affected)
5.0.0.1 rc
Hardware: Other Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-06-27 11:20 UTC by Iandol
Modified: 2016-11-08 20:25 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot for 6th icon (57.30 KB, image/png)
2015-06-27 11:20 UTC, Iandol
Details
example in 5.0.0.2 (55.80 KB, image/png)
2015-07-01 13:12 UTC, Iandol
Details
Erronious Tooltips (329.61 KB, image/png)
2015-10-29 05:25 UTC, John L. ten Wolde
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Iandol 2015-06-27 11:20:25 UTC
Created attachment 116874 [details]
screenshot for 6th icon

The tooltips for the 5th and 6th icons on the styles and formatting pane are incorrect (see screenshot).
Comment 1 Iandol 2015-06-27 11:24:28 UTC
I also just noticed that tooltip is showing up if you hover the styles themselves!!!
Comment 2 Iandol 2015-06-27 11:24:52 UTC
OS X 10.10.4 and LO:

Version: 5.0.0.1
Build ID: 9a0b23dd0ab9652e0965484934309f2d49a7758e
Locale: en-GB (en_GB.UTF-8)
Comment 3 Alex Thurgood 2015-06-28 08:38:46 UTC
Version: 5.1.0.0.alpha1+
Build ID: cbe60f979590615f61d914f1c937c69e89c58880
Locale : fr-FR (fr.UTF-8)

OSX 10.10.3

Tooltip seems to be correct, I see "Fill format mdoe" and "New style from selection", at least in the sidebar.
Comment 4 Iandol 2015-07-01 13:09:28 UTC
I'm still seeing wrong tooltips in Version: 5.0.0.2 Build ID: a26d58f11b99b6aeddf7f7884effea188cc6e512 Locale: en-GB (en_GB.UTF-8)

I tried reinstalling a language pack in case this depends on that but it didn't change anything...
Comment 5 Iandol 2015-07-01 13:12:13 UTC
Created attachment 116972 [details]
example in 5.0.0.2

Example from RC2, hovering the list formatting icon.
Comment 6 Alex Thurgood 2015-07-04 10:33:01 UTC
No repro

Version: 5.0.0.2
Build ID: a26d58f11b99b6aeddf7f7884effea188cc6e512
Locale: fr-FR (fr.UTF-8)

OSX 10.10.4
Comment 7 Iandol 2015-07-05 17:50:12 UTC
Hm, not sure apart from locale what the difference is. I did test this in 5.1 nightly and I see correct tooltips there...

Version: 5.1.0.0.alpha1+
Build ID: 10008d6ecd076006ca9f3c178baabc9e0d01c485
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2015-07-05_10:41:24
Locale: en-GB (en_GB.UTF-8)
Comment 8 Buovjaga 2015-07-26 17:54:45 UTC
This might be some user profile corruption issue: https://wiki.documentfoundation.org/User_Profile#Resolving_corruption_in_the_user_profile

5.0 RC4 is in the release process and should be out very soon, so it would be good to know, how it works for you, Iandol.

Set to NEEDINFO.
Change back to UNCONFIRMED, if the problem persists. Change to RESOLVED WORKSFORME, if the problem went away.
Comment 9 John L. ten Wolde 2015-10-29 05:25:45 UTC
Created attachment 120067 [details]
Erronious Tooltips

@Alex Thurgood (comment 3): You need to activate "Extended tips" in the LibreOffice/General options.

@Beluga (comment 8): It's not a corrupt profile issue.  I can completely corroborate Iandol's findings.  I've attached a far more verbose screenshot collection that should clarify matters.  As you'll see it's all just as he describes.

Taken using 5.0.3.1 on Linux x86_64.
Comment 10 John L. ten Wolde 2015-10-29 05:43:10 UTC
I should have added that I am using the en_GB interface even though my locale is en_CA (in case someone was wondering).

Also, I'm setting to NEW as I'm confident my screenshots confirm the issue.
Comment 11 QA Administrators 2016-11-08 12:09:49 UTC Comment hidden (obsolete)
Comment 12 Aron Budea 2016-11-08 20:25:33 UTC
Tested with 5.2.3.3 / Windows 7, UK help pack, and it seems the extended tooltips have been corrected since then.