Download it now!
Bug 92404 - Web Wizard - no result / crash
Summary: Web Wizard - no result / crash
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.1.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Julien Nabet
URL:
Whiteboard: target:5.1.0 target:4.4.6 target:5.0.1
Keywords:
: 76844 92534 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-06-28 12:39 UTC by Thomas Krumbein
Modified: 2016-10-25 19:24 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Web wizzard "hang" (68.09 KB, image/jpeg)
2015-06-28 12:39 UTC, Thomas Krumbein
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Krumbein 2015-06-28 12:39:20 UTC
Created attachment 116895 [details]
Web wizzard "hang"

Try to use the Web-wizzard:

multipe problems:

1. Selecting documents... if mark more then one document - prozess stops. no reactivation possible - need taskmanager tio stop LibO.

2. Rendering Problems Step 3 and 4 - see Bug #92403

3. Last Step (7): 
 -  Preview - nothing happend - need taskmanager to stop LibO
 -  create - prozess stopps very early (see screenshot) - needs taskmanager to stop LibO

So - unusable for users...

OS: Win 8.1 64 bit , LibO 32 Bit 

Version: 5.0.0.1
Build-ID: 9a0b23dd0ab9652e0965484934309f2d49a7758e
Gebietsschema: de-DE (de_DE)
Comment 1 Julien Nabet 2015-06-30 18:54:40 UTC
If you create 2 brand documents (eg 2 odt files with just "test") and then you try to load them both, do you reproduce this?

Indeed, on pc Debian x86-64 with master sources updated today, I don't reproduce this but it selects only 1 file.
Just a remark for devs:
Searching a bit, I found it was because list of files was always truncated to first element (see vcl/unx/gtk/fpicker/SalGtkFilePicker.cxx) but considering http://opengrok.libreoffice.org/xref/core/offapi/com/sun/star/ui/dialogs/XFilePicker.idl#77, it seems it needs some work here
Comment 2 Michael Meeks 2015-07-02 13:07:13 UTC
As discussed on the list - the file picker API there works as expected - modulo the documentation being wrong =)
Comment 3 Julien Nabet 2015-07-02 13:33:17 UTC
Michael: the commit http://cgit.freedesktop.org/libreoffice/core/commit/?id=fb2889512adf7d08a4083235a2fdabe080b5c8fa should be just the beginning.
Since now, we should use the other API to really be able to take into account several files.
For the moment, when trying to pick more than 1 file, it just picks one on my case.
Comment 4 László Németh 2015-07-02 14:56:04 UTC
It's reproducible also with LO 4.3 using SAL_USE_VCLPLUGIN=gen.

Traceback (most recent call last):
  File "/home/laci/m/bibisect/lo-linux-dbgutil-daily/opt/program/wizards/web/WWD_Events.py", line 249, in addDocument
    oLoadDocs = self.LoadDocs(self.xMSF, self.xUnoDialog, files, self)
TypeError: __init__() missing 1 required positional argument: 'parent_'
Comment 5 Julien Nabet 2015-07-04 12:28:44 UTC
*** Bug 92534 has been marked as a duplicate of this bug. ***
Comment 6 Julien Nabet 2015-07-04 14:24:28 UTC
László: I submitted a patch to review, see https://gerrit.libreoffice.org/16756

Remark: with SAL_USE_VCLPLUGIN=gen, I can with this patch pick several files in the same time.
Comment 7 Commit Notification 2015-07-14 11:11:48 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2f0d1a23759c1b973593bfba642d01fb3df3c269

tdf#92404: Web Wizard - no result / crash

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2015-07-14 11:49:22 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "libreoffice-4-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=bdc50ac10d5987b7d0545d765f4097c9246a2dc0&h=libreoffice-4-4

tdf#92404: Web Wizard - no result / crash

It will be available in 4.4.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2015-07-14 11:49:27 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4f0f8a5c6860bde571ab8babc6559cfd638d6c3d&h=libreoffice-5-0

tdf#92404: Web Wizard - no result / crash

It will be available in 5.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 10 Timur 2015-07-16 15:31:23 UTC
Since master is not generated, I'll ask: what is solved here, marking more than one document and/or freezing in last step?
Is it related to Bug 76845 and Bug 76844?
Comment 11 Julien Nabet 2015-07-16 17:28:58 UTC
Timur: I had a crash when using "SAL_USE_VCLPLUGIN=gen". This is fixed.

Now, we obviously someone to test on Windows with this patch.
According to the result of it, this bug may obviously be reopened.
Comment 12 Julien Nabet 2015-09-19 07:31:35 UTC
*** Bug 76844 has been marked as a duplicate of this bug. ***