Bug Hunting Session
Bug 92423 - EDITING Text to columns... does not respect currently selected cells
Summary: EDITING Text to columns... does not respect currently selected cells
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.8.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.1.0
Keywords:
Depends on:
Blocks:
 
Reported: 2015-06-29 11:43 UTC by Jarkko Vatjus-Anttila
Modified: 2018-05-06 18:49 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Spreadsheet which can be used to demo the bug report (82.05 KB, application/vnd.oasis.opendocument.spreadsheet)
2015-06-29 12:12 UTC, Jarkko Vatjus-Anttila
Details
screenshot after reproduction (201.58 KB, image/jpeg)
2015-06-29 12:19 UTC, Marc Kaulisch
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jarkko Vatjus-Anttila 2015-06-29 11:43:03 UTC
When a group of cells is copied around and after copy operation the copied cells are selected, "text to columns..." operation refuses to operate but only with the first cell.

Use the attached spreadsheet:

1) select cells A1:A31
2) copy cells
3) move cursor to another location, say, cell A35
4) paste
5) at this point the pasted cells are all selected. 
6) DO NOT ALTER THE SELECTION AND use "data->text to columns..."
7) the operation is applied only to the first cell of the selection

One needs to reselect the cells in order to apply for all cells. This is misleading for the user because all the cells were selected in the first place.
Comment 1 Marc Kaulisch 2015-06-29 12:10:33 UTC
Hi Jarkko, I cannot see an attachement yet.
Comment 2 Jarkko Vatjus-Anttila 2015-06-29 12:12:29 UTC
Created attachment 116916 [details]
Spreadsheet which can be used to demo the bug report

Re-adding the attachment
Comment 3 Marc Kaulisch 2015-06-29 12:19:48 UTC
Created attachment 116919 [details]
screenshot after reproduction

I cannot reproduce this with LO5.0.0.2 64bit on Win8.1 64bit

It works for me as intended.
Comment 4 Marc Kaulisch 2015-06-29 12:27:00 UTC
In addition I cannot reproduce this in
Version: 4.4.5.0.0+
Build-ID: 7ea962bd8f2e5303b7719add1f47bb79047b0739
TinderBox: Win-x86@51-TDF, Branch:libreoffice-4-4, Time: 2015-06-28_23:43:12

For me it seems to be solved in upcoming LO versions
Comment 5 Buovjaga 2015-06-29 12:41:23 UTC
Jarkko: please try with 4.4.x.

Set to NEEDINFO.
Change back to UNCONFIRMED, if the problem persists. Change to RESOLVED WORKSFORME, if the problem went away.
Comment 6 Jarkko Vatjus-Anttila 2015-06-29 15:55:19 UTC
I got a change to test this on Win 8.1 Pro x86-64 with LibreOffice 4.4.3.2. I can confirm that the bug does not exist, and the behavior is as expected.

Do you want me to verify the issue on Linux PC as well, as I originally found the bug on a Linux PC. However, I do not think this is anyway related to operating system.
Comment 7 Buovjaga 2015-06-29 15:59:06 UTC
(In reply to Jarkko Vatjus-Anttila from comment #6)
> I got a change to test this on Win 8.1 Pro x86-64 with LibreOffice 4.4.3.2.
> I can confirm that the bug does not exist, and the behavior is as expected.
> 
> Do you want me to verify the issue on Linux PC as well, as I originally
> found the bug on a Linux PC. However, I do not think this is anyway related
> to operating system.

Well it would be nice to verify on Linux, too. There is no hurry :)
If you are using Ubuntu or a derivative that doesn't offer 4.4 yet, you can use this ppa: https://launchpad.net/~libreoffice/+archive/ubuntu/ppa
Comment 8 Jarkko Vatjus-Anttila 2015-06-30 06:06:24 UTC
Thanks for the PPA link! I now updated LibreOffice on my Ubuntu 14.04 LTS machine, and the latest on 4.4 series was "Version: 4.4.4.3 Build ID: 40m0(Build:3)". I can confirm that this issue does not exist with this version either.
Comment 9 Marc Kaulisch 2015-06-30 07:02:59 UTC
I assume this is correct status of this bug now, or?
Comment 10 Commit Notification 2018-05-06 18:49:00 UTC
Zdeněk Crhonek committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=30251adb962f55c6486c491691015fc07052d069

uitest for bug tdf#92423 (text to columns)

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.