Download it now!
Bug 92451 - Enhancement: PIVOT TABLES Enable column selection when selecting source
Summary: Enhancement: PIVOT TABLES Enable column selection when selecting source
Status: RESOLVED DUPLICATE of bug 44419
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.4.3.2 release
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-06-30 11:41 UTC by marcostinez
Modified: 2015-10-05 09:59 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description marcostinez 2015-06-30 11:41:40 UTC
Related to 44419, but not sure if my request will be covered 

When creating a Pivot table that is constantly updated with new rows it would be handy to be able to just select the column headers instead of having to define an array. 

Example: Now

$TabX.$A$1:$X$499

This implies you have to worry about not going beyond row 499 otherwise the pivot won't include the data.

Suggestion (similar as in Excel):

$TabX.$A:$X

Something like this will take everything into account that will be included within these columns, without row limit and easy to select by just grabbing the corresponding columns.
Comment 1 Buovjaga 2015-07-02 13:39:48 UTC
Sounds good to me -> NEW.
Comment 2 marcostinez 2015-10-05 09:42:33 UTC
Not sure whether I Should open another bug, maybe you can advise. I have noticed that this issue exists whenever an array is involved. Example: If you use the Vlookup function you can also not just select the columns but need to define an array, let's say A1:C500. How should I report this bug in the most efficient way? If there is an solutin for Pivot Table, this should be implemented in potentially all array formulas. Thanks!
Comment 3 Buovjaga 2015-10-05 09:51:23 UTC
Just noticed this is a duplicate and the feature exists already in LibO 5.0.
Please try LibO 5.0 and then think what you want to do.
https://wiki.documentfoundation.org/ReleaseNotes/5.0#A:A_.2F_1:1_entire_column.2Frow_references

*** This bug has been marked as a duplicate of bug 44419 ***
Comment 4 marcostinez 2015-10-05 09:59:27 UTC
Hi, yes it is a duplicate, although it is not released yet. Thanks anyway, looking forward to version 5.1 Great work