Bug Hunting Session
Bug 92585 - Base: Pegged CPU, All New Text Rendering Stopped on All LO Menus and Interfaces when Button Control open with White Text, Background Dark Regression LO 5.0.0
Summary: Base: Pegged CPU, All New Text Rendering Stopped on All LO Menus and Interfac...
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
5.0.0.1 rc
Hardware: Other Windows (All)
: high critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-07-07 02:57 UTC by Doug
Modified: 2015-07-17 02:09 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
demonstration database: see Form1 (1.71 KB, application/vnd.sun.xml.base)
2015-07-07 02:57 UTC, Doug
Details
screenshot of anomalous rendering of menus when form used (44.96 KB, image/png)
2015-07-07 02:59 UTC, Doug
Details
screen capture of button at time when text flashing off and not rendered (1.08 KB, image/png)
2015-07-07 03:01 UTC, Doug
Details
demonstration database : see Form1 (10.68 KB, application/vnd.sun.xml.base)
2015-07-07 03:05 UTC, Doug
Details
New push button and properties (283.31 KB, image/jpeg)
2015-07-16 12:28 UTC, Ove
Details
Flicker properties (287.18 KB, image/jpeg)
2015-07-16 12:32 UTC, Ove
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Doug 2015-07-07 02:57:09 UTC
Created attachment 117091 [details]
demonstration database: see Form1

Starting in LO 5.0.0.1 (rc), when there is white text in a control button in a Base Form, where the button has a dark background, the text flickers.  It almost looks like a bad refresh rate.  However, I was able to capture a screenshot with the button text missing, indicating that this is actually an LO problem and not a graphics display issue.  The flashing only occurs in Windows, and only with white text on a dark background.

In short, a fraction of the time, perhaps 1/8th of the time, the white colored text is missing and not rendered, and it is flashing in an unaesthetic way.

At the same time that this occurs, the menus are not populated with menu items.  This is almost like a pegged-CPU, but my CPU utilization is normal when this occurs, 1-2%.  This is very odd.  Screenshot captured.

Windows 7 64-bit confirmed on LO 5.0.0.2.  

NOT experienced when tested on Linux OpenSuse 13.3/KDE4.
Comment 1 Doug 2015-07-07 02:59:15 UTC
Created attachment 117092 [details]
screenshot of anomalous rendering of menus when form used

see what is missing from the dropdown menus when this bug is in action.
Comment 2 Doug 2015-07-07 03:01:28 UTC
Created attachment 117093 [details]
screen capture of button at time when text flashing off and not rendered

its a black box that is the button.  This was like the sixth attempt to capture the flashing artifact.  As you can see, the artifact is that the text completely disappears.
Comment 3 Doug 2015-07-07 03:05:09 UTC
Created attachment 117094 [details]
demonstration database : see Form1

this is the demonstration database.  Open Form1.  Obsoletes prior version.
Comment 4 Doug 2015-07-07 04:26:30 UTC
this bug prevents the contents of the Base administrative window from populating, prevents the contents of dialog boxes from being seen, and prevents macro access to opening and drawing forms so that when you call a macro to open a new form the new form will open but it will hang before populating itself with data (experienced in split-database setup).  In short, the bug is highly adverse should block production use of LO 5.0.0 in Windows 7 until fixed.
Comment 5 Doug 2015-07-08 03:17:36 UTC
on retest, appears to be pegged CPU core caused by LO.  Perhaps infinite loop or something similar.  All text rendering including in Basic editor and dialog boxes blocked when form open with button that has white text on dark background.

Definitely blocks use of this version of LO.
Comment 6 Doug 2015-07-08 03:30:20 UTC
Triggered by a background color on the control button of any color other than `(Default)`.
Comment 7 Alex Thurgood 2015-07-12 09:06:16 UTC
fyi

No repro on

Version: 5.1.0.0.alpha1+
Build ID: 9136f2344af88d524b6c10b6b2dfd6017bba60ec
Locale: fr-FR (fr.UTF-8)

OSX 10.10.4
Comment 8 Alex Thurgood 2015-07-12 09:52:44 UTC
Version: 5.0.0.2
Build ID: a26d58f11b99b6aeddf7f7884effea188cc6e512
Locale: fr-FR (fr.UTF-8)

No flicker on OSX
Comment 9 Doug 2015-07-14 01:36:33 UTC
I had to uninstall LO 5.0.0.2 because of repeated crashes of Windows Explorer on Windows 7 Professional 64-bit, which ceased when I rolled back to LO 4.4.4.3.  The crashes occurred regardless of whether the LO application was open, but correlated to certain LO application actions like saves.
Comment 10 Ove 2015-07-16 12:28:22 UTC
Created attachment 117275 [details]
New push button and properties

Push button is as it should, also properties.
Comment 11 Ove 2015-07-16 12:32:15 UTC
Created attachment 117276 [details]
Flicker properties

See properties, some missing and flicker looks as you described/ have shown - if I were you I'd try reinstallation of LO.
Comment 12 Doug 2015-07-17 02:09:10 UTC
I uninstalled LO 4.4.4.3 (all LO) before newly installing LO 5.0.0.3RC3, thinking maybe it was something about special dev configuration.  Not sure.  Could also have been another branch of Bug 92110.  In any event, fixed in LO 5.0.0.3 after reinstall.  Based on feedback I'll call it INVALID.