Bug Hunting Session
Bug 92608 - Enable Find & Replace by format in Impress & Draw
Summary: Enable Find & Replace by format in Impress & Draw
Status: RESOLVED DUPLICATE of bug 92584
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Object-Selection-Alignment Find-Search
  Show dependency treegraph
 
Reported: 2015-07-07 21:37 UTC by MarjaE
Modified: 2019-02-28 13:29 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Messed-Up Document. (105.67 KB, application/vnd.oasis.opendocument.graphics)
2015-07-07 22:17 UTC, MarjaE
Details

Note You need to log in before you can comment on or make changes to this bug.
Description MarjaE 2015-07-07 21:37:10 UTC
I wanted to remove all underlines from the text in a draw document. I tried "select all" and various text options, with inconsistent results. I managed to delete the underlines and change the font on one page. I haven't been able to reproduce this on the other pages, or reverse this on the one page, so I now have a total mess.

I also have a mess with colors, other formatting, etc...
Comment 1 MarjaE 2015-07-07 22:12:36 UTC
Same bug exists in OO as in LO.
Comment 2 MarjaE 2015-07-07 22:17:58 UTC
Created attachment 117110 [details]
Messed-Up Document.

Note the different fonts on different pages [mostly Liberation Serif on one, mostly probably Ariel on the other], and the difficulty of editing fonts.
Comment 3 Buovjaga 2015-07-26 18:36:35 UTC
In the future to avoid such a situation, it would be wise to use styles from the beginning. Then you could simply edit the style, Font effects - toggle underlining on and off.

I don't know, why you think "Select all" would enable text editing through separate shapes.

I don't see a bug here, so closing.
Comment 4 MarjaE 2015-07-26 19:03:05 UTC
> In the future to avoid such a situation, it would be wise to use styles from the beginning.

I disable styles, autoformat, etc. because in my experience, if I don't disable styles, autoformat, etc., the software keeps changing what I typed, adds unwanted formatting in the wrong places, and makes it impossible to consistently recreate the right formatting. How is enabling that "wise"?

> I don't know, why you think "Select all" would enable text editing through separate shapes.

Because having to individually select and edit 1,400 text frames is an arm-destroying pain.

Reopened, because making it harder for users to use LibreOffice Draw is a bug.
Comment 5 MarjaE 2015-07-26 19:03:55 UTC
I have arm injuries, and this worsens them.
Comment 6 Buovjaga 2015-07-26 19:16:29 UTC
Ok, the issue could be solved in a different way: enabling find & replace by format, like in Writer (Other options in the F&R dialog).
Then you could find by underline and replace by regular.

Changing summary and setting to NEW. I could not find duplicates.

I would not accept your original proposal to enable editing text in all selected shapes at once.
Comment 7 MarjaE 2015-07-26 19:51:51 UTC
Find/Replace would be very useful, especially if it can be extended to colors, etc.

I still think it's confusing that "select all" doesn't allow these edits though.
Comment 8 MarjaE 2015-11-18 00:25:06 UTC
As of 3.3.1 it was possible to mass-edit text, change fonts, etc. in all text frames, to ensure consistent formatting across text frames, in a document using the workaround discussed in bug #34749.

A find and replace option would be a better long-term solution, of course.

As of 5.0.2.2 it is no longer possible and not yet again possible to mass-edit text in LibreOffice Draw. Users must manually select and edit text in each frame, which may involve selecting and editing dozens of frames.

The fix to bug #34749 has solved one bug, but created another.
Comment 9 MarjaE 2015-11-18 00:32:29 UTC
My bad. "Select All" and Format > Character go a long way to solve this.
Comment 10 Heiko Tietze 2016-06-18 09:38:02 UTC
Same comment as in bug 92584, comment 5.
Comment 11 Heiko Tietze 2019-02-28 13:29:18 UTC
Don't see a big reason to distinguish between Format and Attribute. => dup

*** This bug has been marked as a duplicate of bug 92584 ***