Bug Hunting Session
Bug 92611 - Crash exiting bibiography database
Summary: Crash exiting bibiography database
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.1.0.0.alpha0+ Master
Hardware: All All
: highest critical
Assignee: Michael Meeks
URL:
Whiteboard: target:5.1.0 target:5.0.0.3 target:5.4.0
Keywords: haveBacktrace, regression
Depends on:
Blocks: VclPtr
  Show dependency treegraph
 
Reported: 2015-07-08 01:12 UTC by Gordo
Modified: 2017-01-15 19:36 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
backtrace (14.67 KB, text/plain)
2015-07-08 01:12 UTC, Gordo
Details
bt with debug symbols (9.32 KB, text/plain)
2015-07-08 20:50 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gordo 2015-07-08 01:12:23 UTC
Created attachment 117113 [details]
backtrace

1. New Text Document.
2. Tools -> Bibliography Database.
3. Close db.
Result:
Crash.

Windows Vista 64
Version: 5.1.0.0.alpha1+
Build ID: a625cd702700ae1773966a3133d27027d1c4d083
TinderBox: Win-x86@39, Branch:master, Time: 2015-07-07_08:23:06
Comment 1 Joel Madero 2015-07-08 01:37:16 UTC
Confirmed:

Ubuntu 15.04 x64
Version: 5.1.0.0.alpha1+
Build ID: ec44f1ae39e44f55ef1b1625fc5f638d2dbf5256
Locale: en-US (en_US.UTF-8)
Comment 2 Joel Madero 2015-07-08 01:38:25 UTC
Set to:

Critical - crash + regression
Highest - equivalent to MAB, regression, crash, loss of data

Note: Major could have been appropriate here but I sided with critical just because it's a single step in a "main menu" item (one level tools -> biblio... is unusable with the crash)
Comment 3 Julien Nabet 2015-07-08 20:50:13 UTC
Created attachment 117138 [details]
bt with debug symbols

On pc Debian x86-64 with master sources updated today, I could reproduce this.
It's equivalent to Gordo's bt with Linux.
Comment 4 Julien Nabet 2015-07-08 20:52:33 UTC
Michael: thought you might be interested in this one.
Comment 5 Michael Meeks 2015-07-09 11:46:47 UTC
Wow - this only worked in the past because it leaked I suspect. It seems we have an UNO referenced object which is a static member of another object - which looks really odd to me. Chasing it now ... have a prototype fix.
Comment 6 Michael Meeks 2015-07-09 11:55:50 UTC
https://gerrit.libreoffice.org/16889 tdf#92611 - unwind UNO lifecycle snafu.

Will push when CI has its say =)

Noel - this is an interesting one =)

It would be fantastic to have a clang plugin that checks for any member (ie. non-heap allocated thing) that implements an UNO interface (or at least uses these helper classes). I wonder if we could easily find more of these to fix left & right ? =)

Thanks for the report !
Comment 7 Commit Notification 2015-07-09 17:16:33 UTC
Michael Meeks committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=6a2643b92d05a51ef241aeb1e4d5948647e646ef

tdf#92611 - unwind UNO lifecycle snafu.

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2015-07-09 20:37:10 UTC
Michael Meeks committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e3e9684ef8974f4d0d4c72fdf24418d565a1e66b&h=libreoffice-5-0

tdf#92611 - unwind UNO lifecycle snafu.

It will be available in 5.0.0.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 9 Julien Nabet 2015-07-10 20:46:17 UTC
With master sources updated today, I don't reproduce the crash.
Thank you Michael! :-)
Comment 10 Robinson Tryon (qubit) 2015-12-15 22:34:20 UTC Comment hidden (obsolete)
Comment 11 Commit Notification 2017-01-15 19:36:51 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=91f8766db597e25714be0eab8c69510e19865c04

tdf#92611: Add uitest

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.