Download it now!
Bug 92623 - mail merge crashes between step 6 and 7
Summary: mail merge crashes between step 6 and 7
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.0.0.alpha0+ Master
Hardware: Other Linux (All)
: low normal
Assignee: Not Assigned
URL:
Whiteboard: target:5.2.0 target:5.1.0.2 target:5.0.5
Keywords: bibisected, regression
Depends on:
Blocks:
 
Reported: 2015-07-08 11:58 UTC by Justin L
Modified: 2017-05-19 10:41 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
bibisect log and gdb backtrace (11.17 KB, text/plain)
2015-07-08 11:58 UTC, Justin L
Details
mailmerge db connector, spreadsheet data, and merge template (29.10 KB, application/zip)
2015-07-10 08:29 UTC, Justin L
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Justin L 2015-07-08 11:58:06 UTC
Created attachment 117124 [details]
bibisect log and gdb backtrace

Somewhere between Sept 9 and 10 this bug was introduced.  Bibisected with bibisect44.  The full bibisect log and a gdb backtrace are provided in the attachment.


    commit 1964870db4ad1e4334e8fc5050795469dc1fb05e
    Author:     Giuseppe Bilotta <giuseppe.bilotta@gmail.com>
    AuthorDate: Tue Sep 9 21:34:45 2014 +0200
    Commit:     Chris Sherlock <chris.sherlock79@gmail.com>
    CommitDate: Wed Sep 10 11:23:56 2014 +0000
    
        Fallback DPI detection on X11
    
        When the Xft.dpi setting is not found, and if only one screen is
        available, fall back to detecting the screen DPI from the reported


# good: [312241a875e22a660f37f2484e56674a173dc3be] source-hash-355267ba5885ad0a26ae1caa24460b89fff45b12
git bisect good 312241a875e22a660f37f2484e56674a173dc3be
# first bad commit: [95d4432551fd58a604029ea886134d0126ec0289] source-hash-1964870db4ad1e4334e8fc5050795469dc1fb05e

last known Good commit
author	Jan Holesovsky <kendy@collabora.com>	2014-09-07 10:14:30 (GMT)
committer	Jan Holesovsky <kendy@collabora.com>	2014-09-09 04:58:27 (GMT)
commit	355267ba5885ad0a26ae1caa24460b89fff45b12 (patch)
tree	8f4f105247f0c78460dd02e065592c5d7fdabd49
parent	047d2f953ada34ada593768766d3ea8a725f9442 (diff)
vcl: Move MenuFloatingWindow to an own file + adapt code.
The needed changes included:

* Move MenuItemList and MenuItemData to an own file
* Introduce MenuWindow class for pieces shared between MenuFloatingWindow and
  MenuBarWindow.

Change-Id: I129b6ddba6efb8f0cb60018a2d8abafed42552c8
Comment 1 Justin L 2015-07-10 08:29:31 UTC
Created attachment 117166 [details]
mailmerge db connector, spreadsheet data, and merge template

Very specific failure case, seemingly related to the writer template.  Having trouble isolating the exact regression commit: I clean compiled to the last "good" position and still had a crash failure.  Double-checked bibisect-44 and confirmed the same results.

In the writer template, note that the one cell is protect-locked, but you can't unprotect it - which seems to be the element that causes the crash.  Unable to reproduce this in a start-from-scratch document.  Simply locking a cell does not produce a crash.
Comment 2 Justin L 2015-07-15 16:13:42 UTC
using bibisect-44max:
76421b038ac8a442fef758fd746834c4c86aeff5 is the first bad commit
commit 76421b038ac8a442fef758fd746834c4c86aeff5
Author: Matthew Francis <mjay.francis@gmail.com>
Date:   Sun Mar 15 02:24:47 2015 +0800

    source-hash-ddffb797904c5ae1a5ab3bc66eeb9bfc168a0148
    
    commit ddffb797904c5ae1a5ab3bc66eeb9bfc168a0148
    Author:     Jan-Marek Glogowski <glogow@fbihome.de>
    AuthorDate: Mon Jun 23 09:16:18 2014 +0200
    Commit:     Björn Michaelsen <bjoern.michaelsen@canonical.com>
    CommitDate: Tue Sep 9 15:22:04 2014 +0000
    
        Replace the whole content for copied documents
    
        If the document is initialized in CreateCopy, it already contains
        the initial empty paragraph. So we have to delete the content from
        initial document, as we're going to replace the whole content with
        the pasted document.
    
        Change-Id: Ie6a64dcb070f7d611dfde97f2c1a721834b4167b
        Reviewed-on: https://gerrit.libreoffice.org/10963
        Reviewed-by: Björn Michaelsen <bjoern.michaelsen@canonical.com>
        Tested-by: Björn Michaelsen <bjoern.michaelsen@canonical.com>

:040000 040000 fe0436fe59a55373276a2f6407858b2329b5513a 4a07ecb544ec83ebd8df93f4b03d32a6d83a3878 M	opt
justin@jcl-1404 ~/git/bibisect-44max $ git bisect log
# bad: [cf6ea17155fabb2a120ba07c150735591ac861d7] source-hash-3f94c9e9ddfd807b449f3bb9b232cf2041fa12d2
# good: [fc71ac001f16209654d15ef8c1c4018aa55769f5] source-hash-c15927f20d4727c3b8de68497b6949e72f9e6e9e
git bisect start 'latest' 'oldest'
# good: [8cf60cc706948588e2f33a6d98b7c55d454e362a] source-hash-f340f0454627939f1830826fb5cc53a90e6c62a4
git bisect good 8cf60cc706948588e2f33a6d98b7c55d454e362a
# bad: [7beddf3808dadd525d7e55c00a5a90a2b44c23d3] source-hash-2f10386ce577f52e139aa23d41bc787d8e0b4d59
git bisect bad 7beddf3808dadd525d7e55c00a5a90a2b44c23d3
# skip: [7d319609d8266af06aa3256fd3773d052b9150dc] source-hash-1fec67aab152e0c0ad6dd85082c50f1beff7d520
git bisect skip 7d319609d8266af06aa3256fd3773d052b9150dc
# good: [3fad161e9fbd6c9415e4874b6d858ffada1bb51e] source-hash-7abf6861f96052de3b04424ba64b4ee07de35348
git bisect good 3fad161e9fbd6c9415e4874b6d858ffada1bb51e
# bad: [0cf71189bd0af83a6dd3dc8208b0e6c44e76163e] source-hash-cbee6e53e6345080dc52c75c98cfe0eb1c60e52e
git bisect bad 0cf71189bd0af83a6dd3dc8208b0e6c44e76163e
# bad: [2ae727267d9c60fe2fa6e60d3a484be0e47015a1] source-hash-9de2ad3474e34383dfee6166d31983ba24ef0da8
git bisect bad 2ae727267d9c60fe2fa6e60d3a484be0e47015a1
# bad: [6c3c3d012b4f756e7e33c87c32471d936e81c005] source-hash-deeeb88f37170860366ef5ba25c96016917e1f30
git bisect bad 6c3c3d012b4f756e7e33c87c32471d936e81c005
# bad: [72698903e75d3bc051f3aa14e6fad8a8d0950b37] source-hash-8712f0555baab0830aace424f143ad3c9eeaa028
git bisect bad 72698903e75d3bc051f3aa14e6fad8a8d0950b37
# bad: [777b090d084a8167bc3265114bf6f3dd3d0901f4] source-hash-b01bbc3516b63d2772e53fef4dc016788c779612
git bisect bad 777b090d084a8167bc3265114bf6f3dd3d0901f4
# bad: [539b875f11f781c9546a3103259dc83c61260099] source-hash-2fe5d93f82d2875b34301b67e6ccc4959bf4b575
git bisect bad 539b875f11f781c9546a3103259dc83c61260099
# good: [1bdb33d63c09695d1b70a03256bb48c93f71ee2d] source-hash-a29ece90621b2fef9126a6e9a976561ce5d1b461
git bisect good 1bdb33d63c09695d1b70a03256bb48c93f71ee2d
# bad: [76421b038ac8a442fef758fd746834c4c86aeff5] source-hash-ddffb797904c5ae1a5ab3bc66eeb9bfc168a0148
git bisect bad 76421b038ac8a442fef758fd746834c4c86aeff5
# good: [4f820ae22b77a5641ff7b5c00d9eae02cda1c1ae] source-hash-45582edd8dcbfba0c91c53dfd76a18ad06011721
git bisect good 4f820ae22b77a5641ff7b5c00d9eae02cda1c1ae
# good: [5a63d5f3c9de4084b015b9ad63a8c21212558d15] source-hash-62c0ff126a97df0601054fa15498ccccf96077f7
git bisect good 5a63d5f3c9de4084b015b9ad63a8c21212558d15
# good: [a316b9523edf0246cd4e80f2fb0a3558b2a3933d] source-hash-a685de59fce89ab77e1e03b0044621c3f43a00c3
git bisect good a316b9523edf0246cd4e80f2fb0a3558b2a3933d
# first bad commit: [76421b038ac8a442fef758fd746834c4c86aeff5] source-hash-ddffb797904c5ae1a5ab3bc66eeb9bfc168a0148
Comment 3 Buovjaga 2015-07-29 19:39:08 UTC
Jan-Marek: might your commit mentioned in comment 2 be the cause?
Comment 4 Björn Michaelsen 2015-11-25 13:53:35 UTC
bibisected, thus assuming confirmed
Comment 5 Björn Michaelsen 2015-11-25 21:44:23 UTC
Possible dupe tdf#94816?
Comment 6 Commit Notification 2015-12-09 18:48:25 UTC
Jan-Marek Glogowski committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=689962feae2054f965a7378c3408b0ccfad2bbd5

tdf#92623 Handle StartOfContent node for copying bookmarks

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Robinson Tryon (qubit) 2015-12-17 09:18:12 UTC Comment hidden (obsolete)
Comment 8 Commit Notification 2016-01-02 03:22:17 UTC
Jan-Marek Glogowski committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=480e943f0100154fa82942db092ed1f66b76ef66

tdf#92623 MM: add unit test

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2016-01-05 14:52:14 UTC
Jan-Marek Glogowski committed a patch related to this issue.
It has been pushed to "libreoffice-5-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=bdcafdff89836518cb94f362ca7ea4c09a82fa03&h=libreoffice-5-1

tdf#92623 Handle StartOfContent node for copying bookmarks

It will be available in 5.1.0.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2016-01-11 09:12:09 UTC
Jan-Marek Glogowski committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=cce1320efa93cc42300e457b898d892ca580ddca&h=libreoffice-5-0

tdf#92623 Handle StartOfContent node for copying bookmarks

It will be available in 5.0.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.