Bug 92644 - some inserted .eps image files disappear
Summary: some inserted .eps image files disappear
Status: RESOLVED DUPLICATE of bug 67465
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.1.2 release
Hardware: Other macOS (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Images-EPS
  Show dependency treegraph
 
Reported: 2015-07-09 08:07 UTC by pbpaulrbarnes
Modified: 2017-10-21 22:52 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
example with 2 inserted EPS files, one that is currently displaying correctly and one that is not (104.99 KB, application/vnd.oasis.opendocument.text)
2015-07-09 08:07 UTC, pbpaulrbarnes
Details
screenshot of Writer document with EPS images in LO51alpha (42.27 KB, image/png)
2015-07-12 07:38 UTC, Alex Thurgood
Details

Note You need to log in before you can comment on or make changes to this bug.
Description pbpaulrbarnes 2015-07-09 08:07:50 UTC
Created attachment 117148 [details]
example with 2 inserted EPS files, one that is currently displaying correctly and one that is not

When I insert graphics files (EPS files, created from Finale 2014), each initially appears correctly when it is inserted in the document.  However, when I go back to look at a part of the document I've previously worked on, some (but not all) have disappeared - now I see only the Title, Creator (application), and Creator Date.

From what I can tell, there is nothing different about those inserted EPS graphics that continue to display correctly and those that do not.  I copied examples of each from a large document into a small example document, and the same problem persists.

I'm attempting to use LibreOffice to create a draft of a music book.  It must have displayed music examples in order to make sense (even as a draft), and these are the EPS files I am attempting to insert.

Thanks for any help you can give!
Comment 1 Alex Thurgood 2015-07-12 07:38:12 UTC
Version: 5.1.0.0.alpha1+
Build ID: 9136f2344af88d524b6c10b6b2dfd6017bba60ec
Locale: fr-FR (fr.UTF-8)


I see both images, but as you don't provide the reference images with which to compare, I can't tell whether they are complete or not.

I am enclosing a screenshot of the Writer document.
Comment 2 Alex Thurgood 2015-07-12 07:38:56 UTC
Created attachment 117186 [details]
screenshot of Writer document with EPS images in LO51alpha
Comment 3 Alex Thurgood 2015-07-12 07:46:25 UTC
@pbpaulrbarnes: if there is stuff missing on the staves of the second image, then this would appear to be a DUP of other reports on incorrect EPS display. If the images have been exported as EMF/EMF+/WMF instead of EPS, then it is a different set of bugs.

Can you provide us with the original image files ?

Setting to NEEDINFO
Comment 4 V Stuart Foote 2015-09-10 13:59:45 UTC
EPS that are missing previews get mangled as generating previews of EPS requires programs external to LibreOffice that often are not present on OS X and Windows. Work on bug 67464 will at some point resolve that.

For now, users having issues with EPS should check availability/configuration of ghostscript, pstoedit and Imagemagick on their system.

Note: Imagemagick's convert and ghostscript handling will be raster--while pstoedit renders a somewhat rough vector preview. 


Regards the Needinfo of this issue, if you open the ODF document archive, in the Pictures directory the EPS images are retained into the ODF.

However, despite OPs suggestion of preparation in Finale 2014 the origin of the EPS differs.

20000002000001BF000000414EC65893.eps image -- "cross ex 16" was created in Finale 2008, it does not have an embedded TIFF preview.

While the 20000002000001EC00000073ACD7B0DE.eps image -- "Untitled" was created in Finale 2012, and has an embedded TIFF preview.

Difference is the lack or availability of the preview when the EPS was created.

*** This bug has been marked as a duplicate of bug 67465 ***