Bug 92670 - Rendering artifacts between menu and toolbar with some GTK2 themes
Summary: Rendering artifacts between menu and toolbar with some GTK2 themes
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.1.0.0.alpha0+ Master
Hardware: Other All
: medium normal
Assignee: Miklos Vajna
URL:
Whiteboard: target:5.1.0 target:5.0.1
Keywords:
Depends on:
Blocks:
 
Reported: 2015-07-10 09:53 UTC by Miklos Vajna
Modified: 2016-10-25 19:24 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
How it looks like currently (36.27 KB, image/png)
2015-07-10 09:53 UTC, Miklos Vajna
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Miklos Vajna 2015-07-10 09:53:33 UTC
Created attachment 117168 [details]
How it looks like currently

With VCL_DOUBLEBUFFERING_FORCE_ENABLE=1, there is a 2px height white line between the menu and the toolbar with some themes (e.g. oxygen-gtk, which is the default on openSUSE/KDE).
Comment 1 Commit Notification 2015-07-10 11:56:28 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=12d1a2a08a8056df2c14ad3e75b309847989bc23

tdf#92670 GtkSalGraphics::NWPaintGTKMenubar: fix modified clip rectangle

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 2 Commit Notification 2015-07-10 19:49:14 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7609867f60edb5eaf785ce44386e8ed28ab9e01c&h=libreoffice-5-0

tdf#92670 GtkSalGraphics::NWPaintGTKMenubar: fix modified clip rectangle

It will be available in 5.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.