Bug 92719 - EDITING: Charts in Report-Builder show Date instead of Number, if Number is Decimal
Summary: EDITING: Charts in Report-Builder show Date instead of Number, if Number is D...
Status: RESOLVED DUPLICATE of bug 90352
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
4.3.0.4 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2015-07-14 06:00 UTC by robert
Modified: 2016-09-26 10:20 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Open the report "report_gender_chart" for editing and execute it. (43.56 KB, application/vnd.oasis.opendocument.database)
2015-07-14 06:00 UTC, robert
Details

Note You need to log in before you can comment on or make changes to this bug.
Description robert 2015-07-14 06:00:13 UTC
Created attachment 117222 [details]
Open the report "report_gender_chart" for editing and execute it.

Open the attached database.
Execute the report "report_gender_chart".
Since LO 4.3 it shows DATE-formatted values at x-axis.
Now open the report for editing.
Preview shows the right values for x-axis.

Close the report and execute the report "report_gender_chart_new".
Shows the right values in x-axis of the chart.

Difference between the queries for the charts is:
"report_gender_chart" has numbers in the x-axis, which seem to be sometimes decimal numbers with one decimalpoint like '20.0' or '50.0'. This decimalpoint isn't shown in query, but appers when changing the numbers to text-format.
"report_gender_chart_new" has text-formatted values for the x-axis.

Could be this buggy behavior could reproduced only with language-settings, where date is formatted like 14.07.2015.

There is another bug with LO 5.0.0.3 - both reports for charts could not be opened. Will report this also. So please test with LO 4.4.4.3. I tested with this and older versions. Worked right with LO 4.1.* and LO 4.2.3.1 (last installed 4.2-version here). Failed first with LO 4.3.0.4.
Comment 1 Alex Thurgood 2015-07-14 14:44:13 UTC
Confirming that in 
ersion: 4.4.3.2
Build ID: 88805f81e9fe61362df02b9941de8e38a9b5fd16
Locale : fr_

I see dates along x axis, so not just DE locale related
Comment 2 Alex Thurgood 2015-07-14 14:46:10 UTC
Also confirming that preview of chart in Report Edit mode show f or m with a number.
Comment 3 Alex Thurgood 2015-07-14 14:55:16 UTC
I sse same bug in LO4352, and additionally, the charts are incorrectly sized, to that the bottom of the charts is invisible (well half of the chart to be more exact).

Charts are correctly displayed in 
Version: 4.2.4.2
Build ID: 63150712c6d317d27ce2db16eb94c2f3d7b699f8
OSX 10.10.4
Comment 4 Matthew Francis 2015-08-11 09:25:27 UTC
This seems to have begun at the below commit. Unfortunately Kohei's no longer with us so nobody to forward this to.

The incorrect sizing and failure to open the report are separate issues

    commit 1d38cb365543924f9c50014e6b2227e77de1d0c9
    Author:     Kohei Yoshida <kohei.yoshida@collabora.com>
    AuthorDate: Fri Jun 13 11:12:50 2014 -0400
    Commit:     Kohei Yoshida <kohei.yoshida@collabora.com>
    CommitDate: Thu Jun 19 14:46:56 2014 -0400
    
        fdo#71076, fdo#71767: Preserve number formats when charts are copied.
    
        Change-Id: If5ae8852152012483237e7602e56a0c46ea8748a
Comment 5 Matthew Francis 2015-08-11 09:58:39 UTC
For reference, the incorrect chart sizing/cropping seems to have been fixed prior to the current failure-to-load breakage, probably on bug 83354

The load breakage is bug 92720
Comment 6 Robinson Tryon (qubit) 2015-12-13 11:13:19 UTC Comment hidden (obsolete)
Comment 7 Xisco Faulí 2016-09-24 14:29:48 UTC

*** This bug has been marked as a duplicate of bug 90352 ***
Comment 8 robert 2016-09-24 18:44:27 UTC
(In reply to Xisco Faulí from comment #7)
> 
> *** This bug has been marked as a duplicate of bug 90352 ***

How could this one be a duplicate of bug 90352? Have tested that bug? Couldn't reproduce bug 90352 it, if I am using *.ods instead of *.xls. Could reproduce bug 92719, when I am using Base and the report-builder with a chart in a (from report created) writer-document.

If there will appear a date instead of a text in a chart of a Base-report when using the source-format of the query without any date its something else than trying to change the format for the axis to other format instead.
Comment 9 Alex Thurgood 2016-09-26 10:20:04 UTC
(In reply to robert from comment #8)

> 
> How could this one be a duplicate of bug 90352? Have tested that bug?
> Couldn't reproduce bug 90352 it, if I am using *.ods instead of *.xls. Could
> reproduce bug 92719, when I am using Base and the report-builder with a
> chart in a (from report created) writer-document.
> 
> If there will appear a date instead of a text in a chart of a Base-report
> when using the source-format of the query without any date its something
> else than trying to change the format for the axis to other format instead.

Hi Robert,

Xisco's setting as duplicate appears to stem from the same commit being identified as responsible for the behaviour, i.e. Kohei's changes to the Calc number formatter which is also used in charts by the report wizard.